aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorgrog <grog@FreeBSD.org>2015-11-27 13:53:39 +0800
committergrog <grog@FreeBSD.org>2015-11-27 13:53:39 +0800
commitec8c0af67600136b735a5b7cdc4204cdf44fa5c0 (patch)
tree46a66557e036aa8e7ebdbeae07be349602a28278 /graphics
parent38d951925008df4b3f7814cdd297c5febaf03917 (diff)
downloadfreebsd-ports-gnome-ec8c0af67600136b735a5b7cdc4204cdf44fa5c0.tar.gz
freebsd-ports-gnome-ec8c0af67600136b735a5b7cdc4204cdf44fa5c0.tar.zst
freebsd-ports-gnome-ec8c0af67600136b735a5b7cdc4204cdf44fa5c0.zip
Depend on sqlite3
Not found by: port test Find a more general way to determine the python path. Approved by: edwin@ (mentor) MFC after: 3 weeks
Diffstat (limited to 'graphics')
-rw-r--r--graphics/hugin/Makefile3
-rw-r--r--graphics/hugin/files/patch-src__hugin_script_interface__CMakeLists.txt4
2 files changed, 4 insertions, 3 deletions
diff --git a/graphics/hugin/Makefile b/graphics/hugin/Makefile
index 953da0f46d86..03b2dc952d4c 100644
--- a/graphics/hugin/Makefile
+++ b/graphics/hugin/Makefile
@@ -3,7 +3,7 @@
PORTNAME= hugin
PORTVERSION= 2015.0.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION:R}
@@ -16,6 +16,7 @@ LIB_DEPENDS= libIlmImf.so:${PORTSDIR}/graphics/OpenEXR \
libexiv2.so:${PORTSDIR}/graphics/exiv2 \
liblensfun.so:${PORTSDIR}/graphics/lensfun \
libpano13.so:${PORTSDIR}/graphics/libpano13 \
+ libsqlite3.so:${PORTSDIR}/databases/sqlite3 \
libvigraimpex.so:${PORTSDIR}/graphics/vigra \
libpng.so:${PORTSDIR}/graphics/png \
libtiff.so:${PORTSDIR}/graphics/tiff
diff --git a/graphics/hugin/files/patch-src__hugin_script_interface__CMakeLists.txt b/graphics/hugin/files/patch-src__hugin_script_interface__CMakeLists.txt
index 12cd0788f1df..b68bc28eb218 100644
--- a/graphics/hugin/files/patch-src__hugin_script_interface__CMakeLists.txt
+++ b/graphics/hugin/files/patch-src__hugin_script_interface__CMakeLists.txt
@@ -1,11 +1,11 @@
--- src/hugin_script_interface/CMakeLists.txt~ 2015-07-18 02:44:01.000000000 +1000
-+++ src/hugin_script_interface/CMakeLists.txt 2015-11-23 13:02:39.000000000 +1100
++++ src/hugin_script_interface/CMakeLists.txt 2015-11-24 12:49:59.000000000 +1100
@@ -201,7 +201,7 @@
# Linux/MacOS
# install Python related files into folder depending on used Python version
- EXECUTE_PROCESS( COMMAND ${PYTHON_EXECUTABLE} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))"
-+ EXECUTE_PROCESS( COMMAND ${PYTHON_EXECUTABLE} -c "import string; from distutils.sysconfig import get_python_lib; print(string.replace (get_python_lib(1), \"/usr/local/\", \"\"))"
++ EXECUTE_PROCESS( COMMAND ${PYTHON_EXECUTABLE} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1).replace(\"/usr/local/\", \"\"))"
OUTPUT_VARIABLE pyinstalldir
OUTPUT_STRIP_TRAILING_WHITESPACE)