aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorzeising <zeising@FreeBSD.org>2014-06-15 18:26:46 +0800
committerzeising <zeising@FreeBSD.org>2014-06-15 18:26:46 +0800
commitee6407ef49c74acb5859d0a79dd401a5e840a52b (patch)
tree061b06480016652bf964c76c45b85a7d1e3e251d /graphics
parent9a753dd7baf4c139c6433068a40d7a356e4955b1 (diff)
downloadfreebsd-ports-gnome-ee6407ef49c74acb5859d0a79dd401a5e840a52b.tar.gz
freebsd-ports-gnome-ee6407ef49c74acb5859d0a79dd401a5e840a52b.tar.zst
freebsd-ports-gnome-ee6407ef49c74acb5859d0a79dd401a5e840a52b.zip
Update to 2.12 [1]
Add CAM option, controlling the install of feh-cam and gen-cam-menu, on by default. Changelog: http://feh.finalrewind.org/archive/2.12/ PR: 190618 [1] Submitted by: <mp39590@gmail.com> [1]
Diffstat (limited to 'graphics')
-rw-r--r--graphics/feh/Makefile23
-rw-r--r--graphics/feh/distinfo4
-rw-r--r--graphics/feh/pkg-plist8
3 files changed, 24 insertions, 11 deletions
diff --git a/graphics/feh/Makefile b/graphics/feh/Makefile
index 12a3d8be2707..71759761eff2 100644
--- a/graphics/feh/Makefile
+++ b/graphics/feh/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= feh
-PORTVERSION= 2.10
+PORTVERSION= 2.12
CATEGORIES= graphics
MASTER_SITES= http://feh.finalrewind.org/ \
${MASTER_SITE_LOCAL}
@@ -13,20 +13,33 @@ COMMENT= Image viewer that utilizes Imlib2
LICENSE= MIT
-LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl \
- libgiblib.so:${PORTSDIR}/graphics/giblib
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
USE_XORG= x11 xt xinerama
USES= gmake perl5 tar:bzip2 shebangfix desktop-file-utils
+USE_EFL= imlib2
USE_PERL5= run
-SHEBANG_FILES= ${WRKSRC}/cam/feh-cam
CPPFLAGS+= -I${LOCALBASE}/include -std=c99
LDFLAGS+= -L${LOCALBASE}/lib
MAKE_ENV+= LDFLAGS="${LDFLAGS}"
+OPTIONS_DEFINE= CAM
+CAM_DESC= Install feh-cam and related tools
+OPTIONS_DEFAULT=CAM
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MCAM}
+MAKE_ENV+= cam=1
+SHEBANG_FILES= ${WRKSRC}/cam/feh-cam
+PLIST_SUB= CAM=""
+.else
+MAKE_ENV+= cam=0
+PLIST_SUB= CAM="@comment "
+.endif
+
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/feh
-
.include <bsd.port.mk>
diff --git a/graphics/feh/distinfo b/graphics/feh/distinfo
index 37913b8a482e..c24f43f42692 100644
--- a/graphics/feh/distinfo
+++ b/graphics/feh/distinfo
@@ -1,2 +1,2 @@
-SHA256 (feh-2.10.tar.bz2) = bc782a884eedd7a73284804d8145238f140fa59fed8d483102d1d25e8144ca83
-SIZE (feh-2.10.tar.bz2) = 2082905
+SHA256 (feh-2.12.tar.bz2) = 60e07a0f545f6fb7af7b6c0d2ce1ba6bacfa65380e83cbbc2c54e8aa6b8b7032
+SIZE (feh-2.12.tar.bz2) = 2090538
diff --git a/graphics/feh/pkg-plist b/graphics/feh/pkg-plist
index a8354ba78985..d38c38bc4850 100644
--- a/graphics/feh/pkg-plist
+++ b/graphics/feh/pkg-plist
@@ -1,10 +1,10 @@
bin/feh
-bin/feh-cam
-bin/gen-cam-menu
+%%CAM%%bin/feh-cam
+%%CAM%%bin/gen-cam-menu
share/applications/feh.desktop
-man/man1/feh-cam.1.gz
+%%CAM%%man/man1/feh-cam.1.gz
man/man1/feh.1.gz
-man/man1/gen-cam-menu.1.gz
+%%CAM%%man/man1/gen-cam-menu.1.gz
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/find-lowres
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/buttons
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/keys