aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2009-10-17 19:12:29 +0800
committerstas <stas@FreeBSD.org>2009-10-17 19:12:29 +0800
commitf0cd4388b82af979ce308ab7c8fda4bf563b5814 (patch)
tree3f0fcfe298b20db4c17920ee57b402f7d802f742 /graphics
parentf86393d51332c545ba98b17dda6788ae7efa5c57 (diff)
downloadfreebsd-ports-gnome-f0cd4388b82af979ce308ab7c8fda4bf563b5814.tar.gz
freebsd-ports-gnome-f0cd4388b82af979ce308ab7c8fda4bf563b5814.tar.zst
freebsd-ports-gnome-f0cd4388b82af979ce308ab7c8fda4bf563b5814.zip
- Install shared library.
- Bump portrevision.
Diffstat (limited to 'graphics')
-rw-r--r--graphics/podofo/Makefile5
-rw-r--r--graphics/podofo/files/patch-src_CMakeLists.txt24
-rw-r--r--graphics/podofo/pkg-plist3
3 files changed, 30 insertions, 2 deletions
diff --git a/graphics/podofo/Makefile b/graphics/podofo/Makefile
index 2d0eb1b4a023..c417c36911d0 100644
--- a/graphics/podofo/Makefile
+++ b/graphics/podofo/Makefile
@@ -7,6 +7,7 @@
PORTNAME= podofo
PORTVERSION= 0.7.0
+PORTREVISION= 1
CATEGORIES= graphics print
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTNAME}/${PORTVERSION:R}
@@ -21,8 +22,10 @@ OPTIONS= JPEG "Enable JPEG support" on \
TIFF "Enable TIFF support" on \
IMPOSE "Build impose tool (needs Lua)" off
-#USE_GETTEXT= yes
USE_CMAKE= yes
+USE_LDCONFIG= yes
+CMAKE_ARGS+= -DPODOFO_BUILD_SHARED:BOOL=TRUE \
+ -DPODOFO_BUILD_STATIC:BOOL=FALSE
.include <bsd.port.pre.mk>
diff --git a/graphics/podofo/files/patch-src_CMakeLists.txt b/graphics/podofo/files/patch-src_CMakeLists.txt
new file mode 100644
index 000000000000..b17e52a87307
--- /dev/null
+++ b/graphics/podofo/files/patch-src_CMakeLists.txt
@@ -0,0 +1,24 @@
+--- src/CMakeLists.txt.orig 2008-11-23 12:37:23.000000000 +0300
++++ src/CMakeLists.txt 2009-10-17 14:43:48.000000000 +0400
+@@ -199,8 +199,8 @@
+ ADD_LIBRARY(podofo_static STATIC ${PODOFO_SOURCES})
+ TARGET_LINK_LIBRARIES(podofo_static ${PODOFO_LIB_DEPENDS})
+ SET_TARGET_PROPERTIES(podofo_static PROPERTIES
+- VERSION "0.6.99"
+- SOVERSION "0.6.99"
++ VERSION "0"
++ SOVERSION "0"
+ CLEAN_DIRECT_OUTPUT 1
+ OUTPUT_NAME "podofo"
+ )
+@@ -222,8 +222,8 @@
+ # Visual Studio, since it produces invalid warnings about STL
+ # use.
+ SET_TARGET_PROPERTIES(podofo_shared PROPERTIES
+- VERSION "0.6.99"
+- SOVERSION "0.6.99"
++ VERSION "0"
++ SOVERSION "0"
+ CLEAN_DIRECT_OUTPUT 1
+ OUTPUT_NAME "podofo"
+ )
diff --git a/graphics/podofo/pkg-plist b/graphics/podofo/pkg-plist
index 5107c717172e..d9e92cfcf66f 100644
--- a/graphics/podofo/pkg-plist
+++ b/graphics/podofo/pkg-plist
@@ -87,6 +87,7 @@ include/podofo/podofo.h
include/podofo/podofoapi.h
include/podofo/util/PdfMutex.h
include/podofo/util/PdfMutexWrapper.h
-lib/libpodofo.a
+lib/libpodofo.so.0
+lib/libpodofo.so
@dirrm include/podofo/util
@dirrm include/podofo