aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2021-04-21 22:31:16 +0800
committerAdriaan de Groot <adridg@FreeBSD.org>2021-04-22 15:25:15 +0800
commitf365336113039825140dd68ddb69340a5ecf0ab4 (patch)
tree8453006d8feee5ecfef67ed4fa7261312bf95880 /graphics
parent5ac58edc57f032444d53c11d8381022f2e4c997b (diff)
downloadfreebsd-ports-gnome-f365336113039825140dd68ddb69340a5ecf0ab4.tar.gz
freebsd-ports-gnome-f365336113039825140dd68ddb69340a5ecf0ab4.tar.zst
freebsd-ports-gnome-f365336113039825140dd68ddb69340a5ecf0ab4.zip
KDE Applications: sanitize DOCS option
If a port has no documentation, it doesn't need a DOCS option (which turns on, or off, exactly an empty set of documentation). This is now handled correctly by kde.mk since ports 620d7678c8. KDE **applications** with a DOCS option get doctools_build added for free; this covers the majority of KDE-things-with documentation. Note that DOCS isn't expected to **change** anything: most of the ports that have (or had) that option didn't do anything with it and always built the docs anyway. PR: 255260 Reported by: Naram Qashat
Diffstat (limited to 'graphics')
-rw-r--r--graphics/kdegraphics-mobipocket/Makefile2
-rw-r--r--graphics/kdegraphics-svgpart/Makefile2
-rw-r--r--graphics/kdegraphics-thumbnailers/Makefile2
-rw-r--r--graphics/libkdcraw/Makefile2
-rw-r--r--graphics/libkexiv2/Makefile2
-rw-r--r--graphics/libkipi/Makefile2
6 files changed, 0 insertions, 12 deletions
diff --git a/graphics/kdegraphics-mobipocket/Makefile b/graphics/kdegraphics-mobipocket/Makefile
index 72587016aee2..92c84b3985a4 100644
--- a/graphics/kdegraphics-mobipocket/Makefile
+++ b/graphics/kdegraphics-mobipocket/Makefile
@@ -13,6 +13,4 @@ USE_QT= concurrent core dbus gui network widgets \
USE_LDCONFIG= yes
-OPTIONS_DEFINE= DOCS
-
.include <bsd.port.mk>
diff --git a/graphics/kdegraphics-svgpart/Makefile b/graphics/kdegraphics-svgpart/Makefile
index e0d5c6b9f44b..946f3ba86180 100644
--- a/graphics/kdegraphics-svgpart/Makefile
+++ b/graphics/kdegraphics-svgpart/Makefile
@@ -13,6 +13,4 @@ USE_KDE= auth codecs completion config configwidgets coreaddons ecm \
USE_QT= concurrent core dbus gui network svg widgets xml \
buildtools_build qmake_build
-OPTIONS_DEFINE= DOCS
-
.include <bsd.port.mk>
diff --git a/graphics/kdegraphics-thumbnailers/Makefile b/graphics/kdegraphics-thumbnailers/Makefile
index e35ed07a9dae..5317e61bfaac 100644
--- a/graphics/kdegraphics-thumbnailers/Makefile
+++ b/graphics/kdegraphics-thumbnailers/Makefile
@@ -11,6 +11,4 @@ USE_KDE= archive completion config coreaddons ecm jobwidgets libkdcraw \
USE_QT= concurrent core dbus gui network widgets \
buildtools_build qmake_build
-OPTIONS_DEFINE= DOCS
-
.include <bsd.port.mk>
diff --git a/graphics/libkdcraw/Makefile b/graphics/libkdcraw/Makefile
index 737831de5efb..dfd999b025d6 100644
--- a/graphics/libkdcraw/Makefile
+++ b/graphics/libkdcraw/Makefile
@@ -21,6 +21,4 @@ USE_LDCONFIG= yes
CMAKE_ARGS= -DWITH_OpenMP:BOOL=False \
-DENABLE_RAWSPEED=True
-OPTIONS_DEFINE= DOCS
-
.include <bsd.port.mk>
diff --git a/graphics/libkexiv2/Makefile b/graphics/libkexiv2/Makefile
index b69c31753e20..a241142b58eb 100644
--- a/graphics/libkexiv2/Makefile
+++ b/graphics/libkexiv2/Makefile
@@ -13,6 +13,4 @@ USE_QT= core gui \
buildtools_build qmake_build
USE_LDCONFIG= yes
-OPTIONS_DEFINE= DOCS
-
.include <bsd.port.mk>
diff --git a/graphics/libkipi/Makefile b/graphics/libkipi/Makefile
index 021560221889..5763300f551f 100644
--- a/graphics/libkipi/Makefile
+++ b/graphics/libkipi/Makefile
@@ -15,6 +15,4 @@ USE_QT= core dbus gui widgets xml \
buildtools_build qmake_build
USE_LDCONFIG= yes
-OPTIONS_DEFINE= DOCS
-
.include <bsd.port.mk>