aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2017-05-27 23:07:11 +0800
committerlinimon <linimon@FreeBSD.org>2017-05-27 23:07:11 +0800
commitf427d85883d325fa56a13e2d34236051a61e2762 (patch)
tree63c89da74eed9e490571d2f4431a86387cc1eb81 /graphics
parent616751b74e7581b43a094683d687f80b26d2a29b (diff)
downloadfreebsd-ports-gnome-f427d85883d325fa56a13e2d34236051a61e2762.tar.gz
freebsd-ports-gnome-f427d85883d325fa56a13e2d34236051a61e2762.tar.zst
freebsd-ports-gnome-f427d85883d325fa56a13e2d34236051a61e2762.zip
Mark some ports failing on armv6, for errors classified as "clang".
While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/picpuz/Makefile2
-rw-r--r--graphics/pixie/Makefile7
2 files changed, 6 insertions, 3 deletions
diff --git a/graphics/picpuz/Makefile b/graphics/picpuz/Makefile
index 40b16d4a2d82..919e6ee65c34 100644
--- a/graphics/picpuz/Makefile
+++ b/graphics/picpuz/Makefile
@@ -11,6 +11,8 @@ MASTER_SITES= http://kornelix.squarespace.com/storage/downloads/ \
MAINTAINER= devel@stasyan.com
COMMENT= Jigsaw puzzle program
+BROKEN_armv6= fails to compile: use of undeclared identifier __NR_SYSCALL_BASE
+
USES= dos2unix execinfo gmake pkgconfig
DOS2UNIX_GLOB= *.h
USE_GNOME= gtk20
diff --git a/graphics/pixie/Makefile b/graphics/pixie/Makefile
index f64e0f8a5b97..48645836948f 100644
--- a/graphics/pixie/Makefile
+++ b/graphics/pixie/Makefile
@@ -18,6 +18,10 @@ LIB_DEPENDS= libIlmImf.so:graphics/OpenEXR \
libtiff.so:graphics/tiff \
libfltk_gl.so:x11-toolkits/fltk
+BROKEN_aarch64= fails to compile: use of undeclared identifier CRenderer
+BROKEN_armv6= fails to compile: use of undeclared identifier CRenderer
+BROKEN_sparc64= fails to compile
+
USE_GL= glu
USES= bison compiler:c++0x libtool pathfix tar:tgz
GNU_CONFIGURE= yes
@@ -41,9 +45,6 @@ CFLAGS+= -fPIC
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-BROKEN_aarch64= Fails to compile: error: use of undeclared identifier CRenderer
-BROKEN_sparc64= Does not compile on sparc64
-
OPTIONS_DEFINE= DOCS
post-patch: