aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2020-06-16 13:58:55 +0800
committerAlexey Dokuchaev <danfe@FreeBSD.org>2020-06-16 13:58:55 +0800
commitf5c567909cbb257cda6b74285fbde60d62ac392d (patch)
tree97832faddf003b167a4c31aa569a6d9040150e64 /graphics
parent4afbd002789d7b8d6e7f0bf6d84edb079c5a7051 (diff)
downloadfreebsd-ports-gnome-f5c567909cbb257cda6b74285fbde60d62ac392d.tar.gz
freebsd-ports-gnome-f5c567909cbb257cda6b74285fbde60d62ac392d.tar.zst
freebsd-ports-gnome-f5c567909cbb257cda6b74285fbde60d62ac392d.zip
- Update to version 2.8
- Assume maintainership
Diffstat (limited to 'graphics')
-rw-r--r--graphics/zint/Makefile10
-rw-r--r--graphics/zint/distinfo6
-rw-r--r--graphics/zint/files/patch-backend__qt_qzint.cpp4
-rw-r--r--graphics/zint/pkg-plist8
4 files changed, 12 insertions, 16 deletions
diff --git a/graphics/zint/Makefile b/graphics/zint/Makefile
index 6d29fb1e9659..111700c7010a 100644
--- a/graphics/zint/Makefile
+++ b/graphics/zint/Makefile
@@ -2,13 +2,11 @@
# $FreeBSD$
PORTNAME= zint
-DISTVERSION= 2.6.3_rc2 # NOT a "release candidate", fixup for 2.6.3
-PORTREVISION= 2
+PORTVERSION= 2.8.0
CATEGORIES= graphics
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/2.6.3
-DISTNAME= ${PORTNAME}-${DISTVERSION}.src
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= danfe@FreeBSD.org
COMMENT= Zint Barcode Generator
LICENSE= GPLv3+
@@ -16,8 +14,6 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libpng.so:graphics/png
-PORTSCOUT= skipv:2.6.3
-
USES= cmake compiler:c++11-lang qt:5
USE_LDCONFIG= yes
USE_QT= buildtools_build qmake_build uitools_build core gui widgets
diff --git a/graphics/zint/distinfo b/graphics/zint/distinfo
index d6dde2753806..d7869bde54c2 100644
--- a/graphics/zint/distinfo
+++ b/graphics/zint/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1519159191
-SHA256 (zint-2.6.3_rc2.src.tar.gz) = db7e91ce917d85bc2f710e96a2adde9d942ad7aebc23a497222d32a6e8484c63
-SIZE (zint-2.6.3_rc2.src.tar.gz) = 769756
+TIMESTAMP = 1586522868
+SHA256 (zint-2.8.0.tar.gz) = 0abb92df28e61dd3efb2bcaf324588ff77e5037cac7bb7098b8da814e622639c
+SIZE (zint-2.8.0.tar.gz) = 1707535
diff --git a/graphics/zint/files/patch-backend__qt_qzint.cpp b/graphics/zint/files/patch-backend__qt_qzint.cpp
index 7c9b05fa93c0..943134c40425 100644
--- a/graphics/zint/files/patch-backend__qt_qzint.cpp
+++ b/graphics/zint/files/patch-backend__qt_qzint.cpp
@@ -2,8 +2,8 @@
+++ backend_qt/qzint.cpp
@@ -17,6 +17,7 @@
- #include "qzint.h"
- #include <stdio.h>
+ #include <math.h>
+ #include <QFontMetrics>
+#include <QPainterPath>
namespace Zint {
diff --git a/graphics/zint/pkg-plist b/graphics/zint/pkg-plist
index edae5fe7d996..bcab71cda675 100644
--- a/graphics/zint/pkg-plist
+++ b/graphics/zint/pkg-plist
@@ -3,9 +3,9 @@ bin/zint-qt
include/qzint.h
include/zint.h
lib/libQZint.so
-lib/libQZint.so.2.6
-lib/libQZint.so.2.6.3
+lib/libQZint.so.2.8
+lib/libQZint.so.2.8.0
lib/libzint.so
-lib/libzint.so.2.6
-lib/libzint.so.2.6.3
+lib/libzint.so.2.8
+lib/libzint.so.2.8.0
share/cmake/Modules/FindZint.cmake