aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-06-11 16:26:26 +0800
committerpav <pav@FreeBSD.org>2006-06-11 16:26:26 +0800
commitf6d4e283cfe201d7155fa740167eae08c2e17a29 (patch)
treee40a749d0a55979cb985c43b2aa1570f0a4dd846 /graphics
parent73cc3b86d7ca390c483ee100510fd01274b9a0b4 (diff)
downloadfreebsd-ports-gnome-f6d4e283cfe201d7155fa740167eae08c2e17a29.tar.gz
freebsd-ports-gnome-f6d4e283cfe201d7155fa740167eae08c2e17a29.tar.zst
freebsd-ports-gnome-f6d4e283cfe201d7155fa740167eae08c2e17a29.zip
- Fix LDFLAGS
- Install documentation PR: ports/93270 Submitted by: Michael Winking <mwfp@foldl.net> <mwfp@alfa12.isp-service.biz> Approved by: maintainer timeout (4 months)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/ocaml-images/Makefile23
-rw-r--r--graphics/ocaml-images/pkg-descr2
2 files changed, 23 insertions, 2 deletions
diff --git a/graphics/ocaml-images/Makefile b/graphics/ocaml-images/Makefile
index c706a02f44a5..efe5e4924f2f 100644
--- a/graphics/ocaml-images/Makefile
+++ b/graphics/ocaml-images/Makefile
@@ -8,7 +8,7 @@
PORTNAME= images
PORTVERSION= 2.2
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.inria.fr/INRIA/caml-light/bazar-ocaml/
@@ -37,12 +37,20 @@ HAS_CONFIGURE= yes
CONFIGURE_ENV= \
CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include -I${X11BASE}/include" \
CFLAGS="${CFLAGS} -I${LOCALBASE}/include -I${X11BASE}/include" \
- LDFLAGS="${LDFLAGS} -I${LOCALBASE}/include -I${X11BASE}/include"
+ LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib -L${X11BASE}/lib"
CONFIGURE_ARGS= --includedir=${LOCALBASE}/include --includedir=${X11BASE}/include
USE_GMAKE= yes
PKGDEINSTALL= ${PKGINSTALL}
+#the default docsdir gets expanded to ${PREFIX}/share/doc/images
+#which isn't of much help when you are searching for the package docs
+DOCSDIR= ${PREFIX}/share/doc/ocaml-images
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= Announce Announce-2.2 CHANGES INSTALL LICENSE doc
+.endif
+
pre-everything::
.if !defined(WITH_GHOSTSCRIPT_AFPL) || ${WITH_GHOSTSCRIPT_AFPL} != yes
@${ECHO_MSG} ""
@@ -52,6 +60,17 @@ pre-everything::
.endif
post-install:
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} -n ">> Installing documentation..."
+ @${MKDIR} ${DOCSDIR}
+ @cd ${WRKSRC} && ${FIND} doc | ${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR} > /dev/null 2>&1
+ @${INSTALL_DATA} ${WRKSRC}/Announce ${DOCSDIR}/
+ @${INSTALL_DATA} ${WRKSRC}/Announce-2.2 ${DOCSDIR}/
+ @${INSTALL_DATA} ${WRKSRC}/CHANGES ${DOCSDIR}/
+ @${INSTALL_DATA} ${WRKSRC}/INSTALL ${DOCSDIR}/
+ @${INSTALL_DATA} ${WRKSRC}/LICENSE ${DOCSDIR}/
+ @${ECHO_MSG} " [DONE]"
+.endif
@${FIND} ${PREFIX}/lib/ocaml/camlimages -type f | \
${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
@${ECHO_CMD} "@dirrm lib/ocaml/camlimages" >> ${TMPPLIST}
diff --git a/graphics/ocaml-images/pkg-descr b/graphics/ocaml-images/pkg-descr
index 7184025d6bb4..26acfb0be000 100644
--- a/graphics/ocaml-images/pkg-descr
+++ b/graphics/ocaml-images/pkg-descr
@@ -3,3 +3,5 @@ image processing and loading/saving various image file formats. In addition
the library can handle huge images that cannot be (or can hardly be) stored
into the memory (the library automatically creates swap files and escapes
them to reduce the memory usage).
+
+WWW: http://pauillac.inria.fr/camlimages/