aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2014-09-16 18:19:40 +0800
committergahr <gahr@FreeBSD.org>2014-09-16 18:19:40 +0800
commitf746e76b22a72cc41c639d74ba155344dbadb5ee (patch)
tree3caeedd3d61b6d6a5ce1cb82aabe6e357e0cefc8 /graphics
parentc7a181a3e5313ff7e9cb23e7277b3553984ac32e (diff)
downloadfreebsd-ports-gnome-f746e76b22a72cc41c639d74ba155344dbadb5ee.tar.gz
freebsd-ports-gnome-f746e76b22a72cc41c639d74ba155344dbadb5ee.tar.zst
freebsd-ports-gnome-f746e76b22a72cc41c639d74ba155344dbadb5ee.zip
- Use flex and bison from ports
- Bump PORTREVISION PR: 193654 Submitted by: ohartman@zedat.fu-berlin.de
Diffstat (limited to 'graphics')
-rw-r--r--graphics/libosmesa/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/graphics/libosmesa/Makefile b/graphics/libosmesa/Makefile
index 127ace957e11..e71dfbd41a74 100644
--- a/graphics/libosmesa/Makefile
+++ b/graphics/libosmesa/Makefile
@@ -3,6 +3,7 @@
PORTNAME= libosmesa
PORTVERSION= 10.2.7
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.freedesktop.org/pub/mesa/${PORTVERSION}/
DISTNAME= MesaLib-${PORTVERSION}
@@ -11,11 +12,14 @@ MAINTAINER= gahr@FreeBSD.org
COMMENT= Off-Screen Mesa implementation of the OpenGL API
LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2
-BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/libxml2mod.so:${PORTSDIR}/textproc/py-libxml2
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/libxml2mod.so:${PORTSDIR}/textproc/py-libxml2 \
+ ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex
-USES= gmake pkgconfig tar:bzip2 libtool python:2 bison
+USES= bison gmake pkgconfig tar:bzip2 libtool python:2
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
+CONFIGURE_ENV+= ac_cv_prog_YACC=${LOCALBASE}/bin/bison \
+ ac_cv_prog_LEX=${LOCALBASE}/bin/flex
CONFIGURE_ARGS+=--enable-osmesa \
--disable-driglx-direct \
--disable-gallium-llvm \