aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-02-15 21:02:53 +0800
committertijl <tijl@FreeBSD.org>2014-02-15 21:02:53 +0800
commitf93f2b7314452826fa387b7badeeaa8d86d4e10c (patch)
tree6755e331f4e7083e9175a7b3dd160ebc069d760e /graphics
parentb3885beba3b3b70f549c237922889929d4331105 (diff)
downloadfreebsd-ports-gnome-f93f2b7314452826fa387b7badeeaa8d86d4e10c.tar.gz
freebsd-ports-gnome-f93f2b7314452826fa387b7badeeaa8d86d4e10c.tar.zst
freebsd-ports-gnome-f93f2b7314452826fa387b7badeeaa8d86d4e10c.zip
Fix build after r344318. Libtool no longer adds implicit dependencies to
the linker command line. PR: ports/186789
Diffstat (limited to 'graphics')
-rw-r--r--graphics/exiv2/files/patch-src-Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/graphics/exiv2/files/patch-src-Makefile b/graphics/exiv2/files/patch-src-Makefile
new file mode 100644
index 000000000000..6a943950f49f
--- /dev/null
+++ b/graphics/exiv2/files/patch-src-Makefile
@@ -0,0 +1,11 @@
+--- src/Makefile.orig
++++ src/Makefile
+@@ -249,7 +249,7 @@
+ @$(LIBTOOL) --mode=link $(LINK.cc) -o $@ $(LIBRARY) $@.o -rpath $(libdir)
+
+ $(EXIV2BIN): lib $(EXIV2OBJ) $(EXIV2COBJ)
+- @$(LIBTOOL) --mode=link $(LINK.cc) -o $@ $(LIBRARY) $(EXIV2OBJ) $(EXIV2COBJ) -rpath $(libdir)
++ @$(LIBTOOL) --mode=link $(LINK.cc) -o $@ $(LIBRARY) $(EXIV2OBJ) $(EXIV2COBJ) -rpath $(libdir) $(LIBS)
+
+ $(MCBIN): lib $(MCOBJ)
+ @$(LIBTOOL) --mode=link $(LINK.cc) -o $@ $(LIBRARY) $(MCOBJ) -rpath $(libdir)