aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2004-09-16 13:59:43 +0800
committerleeym <leeym@FreeBSD.org>2004-09-16 13:59:43 +0800
commitfbf3fe9aefd7f189d1b6a12929268c0a2433a1a9 (patch)
tree0e1e8c875952c7ba561b3b4487c453d104ba97bf /graphics
parent33917dcb17e053a0837d39959daa3cce87360e46 (diff)
downloadfreebsd-ports-gnome-fbf3fe9aefd7f189d1b6a12929268c0a2433a1a9.tar.gz
freebsd-ports-gnome-fbf3fe9aefd7f189d1b6a12929268c0a2433a1a9.tar.zst
freebsd-ports-gnome-fbf3fe9aefd7f189d1b6a12929268c0a2433a1a9.zip
- apply better way to handle PKGMESSAGE
- unbreak this port PR: 71738 Submitted by: leeym Approved by: portmgr (marcus)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/tcm/Makefile8
-rw-r--r--graphics/tcm/pkg-message4
2 files changed, 8 insertions, 4 deletions
diff --git a/graphics/tcm/Makefile b/graphics/tcm/Makefile
index dc1b4e9e5b42..5db6bda9f4a9 100644
--- a/graphics/tcm/Makefile
+++ b/graphics/tcm/Makefile
@@ -19,7 +19,7 @@ COMMENT= The Toolkit for Conceptual Modeling, create diagrams/tables/trees
RUN_DEPENDS= fig2dev:${PORTSDIR}/print/transfig
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-
+PKGMESSAGE= ${WRKSRC}/pkg-message
USE_REINPLACE= yes
USE_MOTIF= yes
USE_BISON= yes
@@ -36,7 +36,11 @@ post-patch:
@${CHMOD} 0644 ${WRKSRC}/lib/colorrgb.txt
@${REINPLACE_CMD} -e 's:gcc:g++:g' ${WRKSRC}/bin/makedepend.sh
+post-build:
+ @${CP} pkg-message ${PKGMESSAGE}
+ @${REINPLACE_CMD} -e 's:%%LOCALBASE%%:${PREFIX}:g' ${PKGMESSAGE}
+
post-install:
- @${REINPLACE_CMD} -e 's:/usr/local:${PREFIX}:g' ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/graphics/tcm/pkg-message b/graphics/tcm/pkg-message
index 39c97cdaf1ca..b9773a0c4bdb 100644
--- a/graphics/tcm/pkg-message
+++ b/graphics/tcm/pkg-message
@@ -1,5 +1,5 @@
==================================================================
You need to set the environment variable TCM_HOME to
-/usr/local/tcm for tcm to be able to start. You may also want to
-add /usr/local/tcm/man in your manpath.config.
+%%LOCALBASE%%/tcm for tcm to be able to start. You may also want to
+add %%LOCALBASE%%/tcm/man in your manpath.config.
==================================================================