aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2013-12-30 21:58:27 +0800
committerjohans <johans@FreeBSD.org>2013-12-30 21:58:27 +0800
commitfd55c732037ac1eb2e659ef7ef045540e43c062f (patch)
treefbf5a77cf8b5be17a54acc3239e4bdf96cba0b2f /graphics
parent21db05a929ad36e433974ee85b4f4cc6a8180016 (diff)
downloadfreebsd-ports-gnome-fd55c732037ac1eb2e659ef7ef045540e43c062f.tar.gz
freebsd-ports-gnome-fd55c732037ac1eb2e659ef7ef045540e43c062f.tar.zst
freebsd-ports-gnome-fd55c732037ac1eb2e659ef7ef045540e43c062f.zip
Fix build issue with freetype (again), hopefully now working for all versions
Diffstat (limited to 'graphics')
-rw-r--r--graphics/xpaint/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/graphics/xpaint/Makefile b/graphics/xpaint/Makefile
index 0740896b515f..393f2f5b558c 100644
--- a/graphics/xpaint/Makefile
+++ b/graphics/xpaint/Makefile
@@ -30,7 +30,8 @@ GNU_CONFIGURE= yes
USES= shebangfix
SHEBANG_FILES= share/bin/imgmerge share/bin/xpaint_ocr
-CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2
+CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2 \
+ -I${LOCALBASE}/include/freetype2/freetype
LDFLAGS+= -L${LOCALBASE}/lib
MAKE_ENV+= RM="${RM} -f"
@@ -39,6 +40,7 @@ post-extract:
post-patch:
@${REINPLACE_CMD} -e 's/-ldl //' \
+ -e 's|freetype/||g' \
${WRKSRC}/configure ${WRKSRC}/rw/configure
@${REINPLACE_CMD} -e '/^LIBTOOL/d' \
-e '/^install-exec-am:/s/install-libLTLIBRARIES//' \