aboutsummaryrefslogtreecommitdiffstats
path: root/irc/bitchx
diff options
context:
space:
mode:
authorkevlo <kevlo@FreeBSD.org>2000-09-30 23:57:08 +0800
committerkevlo <kevlo@FreeBSD.org>2000-09-30 23:57:08 +0800
commitd02c3374b5d4799ceb339c45358c6a378ae56fb4 (patch)
treec3781c901bcd0fdca891eb941543867a08a05826 /irc/bitchx
parentb325618e319af005f4be0351864d8ea71a20add2 (diff)
downloadfreebsd-ports-gnome-d02c3374b5d4799ceb339c45358c6a378ae56fb4.tar.gz
freebsd-ports-gnome-d02c3374b5d4799ceb339c45358c6a378ae56fb4.tar.zst
freebsd-ports-gnome-d02c3374b5d4799ceb339c45358c6a378ae56fb4.zip
Make corrections in Makefile and remove pkg/MESSAGE
PR: 21651 Submitted by: MAINTAINER
Diffstat (limited to 'irc/bitchx')
-rw-r--r--irc/bitchx/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/irc/bitchx/Makefile b/irc/bitchx/Makefile
index dbea6d977862..d7734f2d33fb 100644
--- a/irc/bitchx/Makefile
+++ b/irc/bitchx/Makefile
@@ -33,8 +33,8 @@ CONFIGURE_ARGS+= --without-gtk
.endif
.if defined(WITH_TCL)
CONFIGURE_ARGS+= --with-tcl \
- --with-tcl-includes=/usr/local/include/tcl8.3 \
- --with-tcl-libs=/usr/local/lib
+ --with-tcl-includes="${PREFIX}/include/tcl8.3" \
+ --with-tcl-libs="${PREFIX}/lib"
.endif
.if defined(WITH_ESD)
CONFIGURE_ARGS+= --enable-sound
@@ -61,11 +61,17 @@ MAKE_ENV+= INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
INSTALL_DATA="${INSTALL_DATA}"
pre-extract:
- @${CAT} ${PKGDIR}/MESSAGE
+ @${ECHO} "Available switches:"
+ @${ECHO} "-------------------"
+ @${ECHO} "WITH_GNOME - Build GTK BitchX"
+ @${ECHO} "WITH_ESD - Build GTK BitchX with ESD sound support"
+ @${ECHO} "WITH_PLUGINS - Build the plugins"
+ @${ECHO} "WITH_LATIN - Recommended if you are using an ISO-8859-1 display"
+ @${ECHO} "WITH_TCL - Build BitchX with TCL scripting"
.if defined(WITH_TCL)
post-extract:
- @uudecode -p files/tcl-freebsd.o.uu > ${WRKSRC}/source/tcl.o
+ @uudecode -p ${FILESDIR}/tcl-freebsd.o.uu > ${WRKSRC}/source/tcl.o
.endif
.if defined(WITH_LATIN)