aboutsummaryrefslogtreecommitdiffstats
path: root/irc/hexchat
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2014-04-02 01:54:02 +0800
committernemysis <nemysis@FreeBSD.org>2014-04-02 01:54:02 +0800
commit04ae12d3b724603668d81e8c9f1769e480417d0b (patch)
tree984aded1bb49ad00b7b0ef0c5fda097c640363f9 /irc/hexchat
parent812b69d35c5c3ecc0a5a3dfefc959462ae2938b9 (diff)
downloadfreebsd-ports-gnome-04ae12d3b724603668d81e8c9f1769e480417d0b.tar.gz
freebsd-ports-gnome-04ae12d3b724603668d81e8c9f1769e480417d0b.tar.zst
freebsd-ports-gnome-04ae12d3b724603668d81e8c9f1769e480417d0b.zip
- Change Makefile header, use my name and @FreeBSD.org email
- Use tar:xz instead of USE_XZ=yes - Strip libraries - Break lines around 80 characters - Change pkg-message, add information about FiSH Protection - Change pkg-descr, update WWW
Diffstat (limited to 'irc/hexchat')
-rw-r--r--irc/hexchat/Makefile14
-rw-r--r--irc/hexchat/files/pkg-message.in6
-rw-r--r--irc/hexchat/pkg-descr11
3 files changed, 19 insertions, 12 deletions
diff --git a/irc/hexchat/Makefile b/irc/hexchat/Makefile
index e6c68c6d68bb..3197528d128f 100644
--- a/irc/hexchat/Makefile
+++ b/irc/hexchat/Makefile
@@ -1,4 +1,4 @@
-# Created by: nemysis <nemysis@gmx.ch>
+# Created by: Rusmir Dusko <nemysis@FreeBSD.org>
# $FreeBSD$
PORTNAME= hexchat
@@ -14,13 +14,13 @@ LICENSE= GPLv2
LIB_DEPENDS= libproxy.so:${PORTSDIR}/net/libproxy
-USE_XZ= yes
-USES= gmake desktop-file-utils pkgconfig
+USES= gmake desktop-file-utils pkgconfig tar:xz
USE_GNOME= gtk20 libxml2
USE_AUTOTOOLS= automake autoconf libtool
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--enable-openssl --enable-gtkfe --disable-sysinfo \
--with-pkgconfigdir=${LOCALBASE}/libdata/pkgconfig
+MAKE_ENV= INSTALL_STRIP_FLAG=${STRIP}
INSTALLS_ICONS= yes
LDFLAGS+= -pthread
@@ -29,7 +29,8 @@ SUB_FILES= pkg-message
PORTDOCS= *
-OPTIONS_DEFINE= CANBERRA DBUS DOAT DOCS FISHLIM NLS NOTIFY PERL PYTHON SOCKS TEXTFE XFT
+OPTIONS_DEFINE= CANBERRA DBUS DOAT DOCS FISHLIM NLS NOTIFY PERL \
+ PYTHON SOCKS TEXTFE XFT
OPTIONS_RADIO= SPELL
OPTIONS_RADIO_SPELL= GTKSPELL LIBSEXY STATIC
@@ -102,13 +103,14 @@ USE_GNOME+= gconf2
post-patch:
@${REINPLACE_CMD} -e 's|/bin/bash|/bin/sh|g' ${WRKSRC}/autogen.sh
@${REINPLACE_CMD} -e '/^appdata_DATA/s|hexchat.appdata.xml||' \
- ${WRKSRC}/share/misc/Makefile.am ${WRKSRC}/share/misc/Makefile.in
+ ${WRKSRC}/share/misc/Makefile.am ${WRKSRC}/share/misc/Makefile.in
pre-configure:
@(cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ./autogen.sh)
post-install:
- ${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png ${STAGEDIR}${PREFIX}/share/pixmaps/
+ ${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/irc/hexchat/files/pkg-message.in b/irc/hexchat/files/pkg-message.in
index 56490e17fc7b..80d8bd6bb87c 100644
--- a/irc/hexchat/files/pkg-message.in
+++ b/irc/hexchat/files/pkg-message.in
@@ -2,6 +2,10 @@
HexChat has been installed.
-For spelling to work you must install Aspell dictionary for your Language.
+If you want spell-check to work, you need to install Aspell
+dictionary for your language.
+
+For FiSH Protection it is best to use irc/py-fishcrypt, HexChat has one
+Option FiSHLiM which doesn't work good.
===============================================================================
diff --git a/irc/hexchat/pkg-descr b/irc/hexchat/pkg-descr
index 1cdbd47f6805..ea5f5d0bb86d 100644
--- a/irc/hexchat/pkg-descr
+++ b/irc/hexchat/pkg-descr
@@ -1,8 +1,9 @@
HexChat is an IRC chat program.
-It allows you to join multiple IRC channels (chat rooms) at the same time,
-talk publicly, private one-on-one conversations etc.
+It allows you to join multiple IRC channels (chat rooms) at
+the same time, talk publicly, private one-on-one conversations etc.
-HexChat is based on XChat, but unlike XChat it's completely free for both
-Windows and Unix-like systems. Since XChat is open source, it's perfectly legal.
+HexChat is based on XChat, but unlike XChat it's completely
+free for both Windows and Unix-like systems.
+Since XChat is Open Source, it's perfectly legal.
-WWW: http://www.hexchat.org/
+WWW: http://hexchat.github.io/