aboutsummaryrefslogtreecommitdiffstats
path: root/irc/inspircd/Makefile
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2012-06-15 03:28:02 +0800
committerjgh <jgh@FreeBSD.org>2012-06-15 03:28:02 +0800
commit72e73604366b5410da02d167e6fa3c7becba24b7 (patch)
tree6a15a0baec2a198f40ba8e94081182523a43a9d4 /irc/inspircd/Makefile
parent7aa1889da0bb57a00f80b617e58ada60aa48ed25 (diff)
downloadfreebsd-ports-gnome-72e73604366b5410da02d167e6fa3c7becba24b7.tar.gz
freebsd-ports-gnome-72e73604366b5410da02d167e6fa3c7becba24b7.tar.zst
freebsd-ports-gnome-72e73604366b5410da02d167e6fa3c7becba24b7.zip
- use USERS/GROUPS framework
- remove pkg-deinstall and move cleanup instructions into pkg-plist - pet portlint on pkg-plist for mode and group warnings PR: ports/168821 Submitted by: jgh@ Approved by: maintainer, feld@feld.me
Diffstat (limited to 'irc/inspircd/Makefile')
-rw-r--r--irc/inspircd/Makefile17
1 files changed, 5 insertions, 12 deletions
diff --git a/irc/inspircd/Makefile b/irc/inspircd/Makefile
index 43f856bbd800..5b49c8e97b65 100644
--- a/irc/inspircd/Makefile
+++ b/irc/inspircd/Makefile
@@ -7,7 +7,7 @@
PORTNAME= inspircd
PORTVERSION= 2.0.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= irc
MASTER_SITES= http://cloud.github.com/downloads/inspircd/inspircd/
DISTNAME= InspIRCd-${PORTVERSION}
@@ -21,22 +21,15 @@ USE_BZIP2= yes
USE_RC_SUBR= ${PORTNAME}
MAKEFILE= BSDmakefile
-USERS= ${INSPIRCD_USR}
-GROUPS= ${INSPIRCD_GRP}
+USERS= ircd
+GROUPS= ircd
+INSPIRCD_UID= 72
-INSPIRCD_USR?= ircd
-INSPIRCD_UID?= 72
-INSPIRCD_GRP?= ircd
-INSPIRCD_GID?= 72
INSPIRCD_RUN?= /var/run/${PORTNAME}
INSPIRCD_LOG?= /var/log/${PORTNAME}/ircd.log
-SUB_LIST+= PORTNAME=${PORTNAME} \
- INSPIRCD_USR=${INSPIRCD_USR} \
- INSPIRCD_GRP=${INSPIRCD_GRP} \
+SUB_LIST+= PORTNAME=${PORTNAME} \
INSPIRCD_LOG=${INSPIRCD_LOG} \
INSPIRCD_RUN=${INSPIRCD_RUN}
-PLIST_SUB+= INSPIRCD_GRP=${INSPIRCD_GRP}
-SUB_FILES+= pkg-deinstall
# Configure script is written in perl
USE_PERL5_BUILD=yes