aboutsummaryrefslogtreecommitdiffstats
path: root/irc/kvirc
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-02-16 04:17:58 +0800
committerTobias C. Berner <tcberner@FreeBSD.org>2018-02-16 04:17:58 +0800
commita05b9f38302d4ad2877f24357f2dd0d6dea37cf5 (patch)
tree9856a4cf9a91f4091fd5345c987990ef4be43dd1 /irc/kvirc
parent25b0eeddf50b90d977e901fffc1a0f8f03d20722 (diff)
downloadfreebsd-ports-gnome-a05b9f38302d4ad2877f24357f2dd0d6dea37cf5.tar.gz
freebsd-ports-gnome-a05b9f38302d4ad2877f24357f2dd0d6dea37cf5.tar.zst
freebsd-ports-gnome-a05b9f38302d4ad2877f24357f2dd0d6dea37cf5.zip
irc/kvirc and irc/kvirc-qt4, fix build with clang6
Diffstat (limited to 'irc/kvirc')
-rw-r--r--irc/kvirc/Makefile7
-rw-r--r--irc/kvirc/files/patch-debian_git-5d45ef30
2 files changed, 36 insertions, 1 deletions
diff --git a/irc/kvirc/Makefile b/irc/kvirc/Makefile
index 477b1ffc6931..2633dd74499f 100644
--- a/irc/kvirc/Makefile
+++ b/irc/kvirc/Makefile
@@ -3,7 +3,7 @@
PORTNAME= kvirc
PORTVERSION= 4.2.0
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= irc kde
MASTER_SITES= ftp://ftp.kvirc.de/pub/kvirc/%SUBDIR%/ \
http://kvirc.gmake.de/pub/kvirc/%SUBDIR%/ \
@@ -81,5 +81,10 @@ pre-fetch-PERL-on:
post-patch:
${REINPLACE_CMD} -e "s|\(-lcrypto\)|-L${OPENSSLLIB} \1|g" \
${WRKSRC}/CMakeLists.txt
+ # Fix error: invalid suffix on literal; C++11 requires a space between literal and identifier
+ ${REINPLACE_CMD} -e 's|"KVI_OPTIONS_WIDGET_KEYWORDS|" KVI_OPTIONS_WIDGET_KEYWORDS|g' \
+ ${WRKSRC}/src/modules/options/OptionsInstanceManager.cpp
+ ${REINPLACE_CMD} -e 's|"KVI_PATH_SEPARATOR|" KVI_PATH_SEPARATOR|g' \
+ ${WRKSRC}/src/kvirc/kernel/KviApplication_filesystem.cpp
.include <bsd.port.mk>
diff --git a/irc/kvirc/files/patch-debian_git-5d45ef b/irc/kvirc/files/patch-debian_git-5d45ef
new file mode 100644
index 000000000000..1d1413904a9f
--- /dev/null
+++ b/irc/kvirc/files/patch-debian_git-5d45ef
@@ -0,0 +1,30 @@
+Description: Fixes FTBFS with gcc 6.
+ Fixes invalid conversion errors. Also fixes two wrong flag operations, already
+ fixed upstream (in 0d14434b and 934fa2e1).
+Author: Andrey Rahmatullin <wrar@debian.org>
+Bug-Debian: https://bugs.debian.org/811908
+Last-Update: 2016-11-04
+
+diff --git a/src/kvirc/kernel/KviIrcConnection.cpp b/src/kvirc/kernel/KviIrcConnection.cpp
+index f925ca7..1266b46 100644
+--- src/kvirc/kernel/KviIrcConnection.cpp
++++ src/kvirc/kernel/KviIrcConnection.cpp
+@@ -669,7 +669,8 @@ void KviIrcConnection::closeAllChannels()
+ while(m_pChannelList->first())
+ {
+ m_pChannelList->first()->close();
+- QApplication::processEvents(QEventLoop::ExcludeSocketNotifiers & QEventLoop::ExcludeUserInputEvents);
++ QEventLoop::ProcessEventsFlags f(QEventLoop::ExcludeSocketNotifiers | QEventLoop::ExcludeUserInputEvents);
++ QApplication::processEvents(f);
+ }
+ }
+
+@@ -678,7 +679,8 @@ void KviIrcConnection::closeAllQueries()
+ while(m_pQueryList->first())
+ {
+ m_pQueryList->first()->close();
+- QApplication::processEvents(QEventLoop::ExcludeSocketNotifiers & QEventLoop::ExcludeUserInputEvents);
++ QEventLoop::ProcessEventsFlags f(QEventLoop::ExcludeSocketNotifiers | QEventLoop::ExcludeUserInputEvents);
++ QApplication::processEvents(f);
+ }
+ }