aboutsummaryrefslogtreecommitdiffstats
path: root/irc/ninja/Makefile
diff options
context:
space:
mode:
authorkevlo <kevlo@FreeBSD.org>2001-01-23 16:30:12 +0800
committerkevlo <kevlo@FreeBSD.org>2001-01-23 16:30:12 +0800
commitce277b178048e37df571ab3007842ca58f229ce7 (patch)
treec38b07f3ca444ad6a7868cdde83e340aee906a77 /irc/ninja/Makefile
parentd0dbf24bc123d94ec486f6bc1f676600c6a66e06 (diff)
downloadfreebsd-ports-gnome-ce277b178048e37df571ab3007842ca58f229ce7.tar.gz
freebsd-ports-gnome-ce277b178048e37df571ab3007842ca58f229ce7.tar.zst
freebsd-ports-gnome-ce277b178048e37df571ab3007842ca58f229ce7.zip
Update to version 1.5.1
PR: 24551 Submitted by: Ports Fury
Diffstat (limited to 'irc/ninja/Makefile')
-rw-r--r--irc/ninja/Makefile21
1 files changed, 15 insertions, 6 deletions
diff --git a/irc/ninja/Makefile b/irc/ninja/Makefile
index 5e6950118b85..f486f25c89d9 100644
--- a/irc/ninja/Makefile
+++ b/irc/ninja/Makefile
@@ -6,21 +6,30 @@
#
PORTNAME= ninja
-PORTVERSION= 1.2
+PORTVERSION= 1.5.1
CATEGORIES= irc
-MASTER_SITES= ftp://ninja.qoop.org/ninja/unstable/
-DISTFILES= ${DISTNAME}-src.tar.gz
+MASTER_SITES= ftp://ninja.qoop.org/ninja/sources/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= ports@FreeBSD.org
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
GNU_CONFIGURE= yes
-PLIST_SUB= VERSION="${PORTVERSION}"
+CONFIGURE_ENV= IRCLIB="${IRCLIB}"
+
+IRCLIB= ${PREFIX}/share/ninja
pre-patch:
@${CP} ${WRKSRC}/config/configure ${WRKSRC}
post-patch:
- @${SED} -e s#__PREFIX__#$(PREFIX)#g $(WRKSRC)/include/config.h.dist > $(WRKSRC)/include/config.h.dist.new
- @${MV} $(WRKSRC)/include/config.h.dist.new $(WRKSRC)/include/config.h.dist
+ @${PERL} -e "s|%%IRCLIB%%|${IRCLIB}|g" ${WRKSRC}/include/config.h.dist
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/source/ninja ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/source/wserv ${PREFIX}/bin
+ @${MKDIR} ${IRCLIB}/translation
+ ${INSTALL_DATA} ${WRKSRC}/translation/* ${IRCLIB}/translation
.include <bsd.port.mk>