aboutsummaryrefslogtreecommitdiffstats
path: root/irc/xchat
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-09-13 01:55:41 +0800
committeraz <az@FreeBSD.org>2013-09-13 01:55:41 +0800
commit97be478202aed01041512ee00b968768877f45a6 (patch)
tree3c4966978dcdbf09071760438b6641e1107e1d97 /irc/xchat
parent6b2f9be610deb3169a4a84727e1040501062d9e1 (diff)
downloadfreebsd-ports-gnome-97be478202aed01041512ee00b968768877f45a6.tar.gz
freebsd-ports-gnome-97be478202aed01041512ee00b968768877f45a6.tar.zst
freebsd-ports-gnome-97be478202aed01041512ee00b968768877f45a6.zip
- convert to the new perl5 framework
- convert USE_GMAKE to Uses Reviewed by: kwm@ Approved by: kwm@ (gnome@)
Diffstat (limited to 'irc/xchat')
-rw-r--r--irc/xchat/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/irc/xchat/Makefile b/irc/xchat/Makefile
index 2a5ad963e59e..d69b00f328cc 100644
--- a/irc/xchat/Makefile
+++ b/irc/xchat/Makefile
@@ -18,14 +18,12 @@ LICENSE_FILE= ${WRKSRC}/COPYING
CONFLICTS= xchat-1* xchat-systray-plugin-[0-9]*
USE_BZIP2= yes
-USE_GMAKE= yes
-USES= gettext pkgconfig
+USES= gettext pkgconfig gmake
USE_GNOME= gnomehack gtk20
GNU_CONFIGURE= yes
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
CONFIGURE_ARGS= --enable-ipv6
-WANT_PERL= yes
OPTIONS_DEFINE= DBUS NOTIFY PERL PYTHON SOCKS TCL
OPTIONS_DEFAULT=DBUS GTKSPELL PERL
@@ -66,7 +64,7 @@ RUN_DEPENDS+= notify-send:${PORTSDIR}/devel/libnotify \
.endif
.if ${PORT_OPTIONS:MPERL}
-USE_PERL5= yes
+USES+= perl5
CONFIGURE_ARGS+=--enable-perl
PLIST_SUB+= PERL=""
.else