aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
authorbrnrd <brnrd@FreeBSD.org>2017-03-26 19:14:39 +0800
committerbrnrd <brnrd@FreeBSD.org>2017-03-26 19:14:39 +0800
commit0e2aeb3da67b2acf1957f3130b85ce820d7d1b90 (patch)
treedb8d39086c2e8ec19a5e5b2b2c653926da8757de /irc
parent8c926703fba98c5234961eb33c1ffe1f9e6dbec5 (diff)
downloadfreebsd-ports-gnome-0e2aeb3da67b2acf1957f3130b85ce820d7d1b90.tar.gz
freebsd-ports-gnome-0e2aeb3da67b2acf1957f3130b85ce820d7d1b90.tar.zst
freebsd-ports-gnome-0e2aeb3da67b2acf1957f3130b85ce820d7d1b90.zip
irc/weechat: Fix python3 detection
- Fix package error when python3 is used PR: 216555 Reported by: Charles P <charlespigott@googlemail.com>
Diffstat (limited to 'irc')
-rw-r--r--irc/weechat/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/irc/weechat/Makefile b/irc/weechat/Makefile
index 013d81c2cbcf..c4f4ef1f5016 100644
--- a/irc/weechat/Makefile
+++ b/irc/weechat/Makefile
@@ -88,7 +88,7 @@ TCL_USES= tcl:85+
.include <bsd.port.pre.mk>
-.if defined(PORT_OPTIONS:MPYTHON) && ${PYTHON_MAJOR_VER} >= 3
+.if !empty(PORT_OPTIONS:MPYTHON) && ${PYTHON_MAJOR_VER} >= 3
WARNING= "Using Python 3.x is NOT recommended because many \"official\" scripts won\'t work"
CMAKE_ARGS+= -DENABLE_PYTHON3:BOOL=true \
-DPYTHON_LIBRARY:FILEPATH=${LOCALBASE}/lib/libpython${PYTHON_VER}m.so