aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-10-26 05:10:51 +0800
committermarcus <marcus@FreeBSD.org>2003-10-26 05:10:51 +0800
commit2b874efe2c72f3fc9ec351d77355864168f2170f (patch)
tree9befbec936899b6c3e9240fc28976f035efb3aeb /irc
parent090c6857d098bc3a5877681e71e9f3a51bf204da (diff)
downloadfreebsd-ports-gnome-2b874efe2c72f3fc9ec351d77355864168f2170f.tar.gz
freebsd-ports-gnome-2b874efe2c72f3fc9ec351d77355864168f2170f.tar.zst
freebsd-ports-gnome-2b874efe2c72f3fc9ec351d77355864168f2170f.zip
Fix runtime on 64-bit architectures.
PR: 58539 Submitted by: Koop Mast <einekoai@chello.nl> Obtained from: xchat CVS Tested on: sparc64
Diffstat (limited to 'irc')
-rw-r--r--irc/xchat-gnome/Makefile1
-rw-r--r--irc/xchat-gnome/files/patch-src_common_server.c13
-rw-r--r--irc/xchat-gnome/files/patch-src_common_text.c11
-rw-r--r--irc/xchat-gnome/files/patch-src_fe-gtk_xtext.c22
-rw-r--r--irc/xchat2/Makefile1
-rw-r--r--irc/xchat2/files/patch-src_common_server.c13
-rw-r--r--irc/xchat2/files/patch-src_common_text.c11
-rw-r--r--irc/xchat2/files/patch-src_fe-gtk_xtext.c22
8 files changed, 94 insertions, 0 deletions
diff --git a/irc/xchat-gnome/Makefile b/irc/xchat-gnome/Makefile
index 1ac54858e52a..e5cc7c26e77d 100644
--- a/irc/xchat-gnome/Makefile
+++ b/irc/xchat-gnome/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xchat2
PORTVERSION= 2.0.5
+PORTREVISION= 1
CATEGORIES= irc gnome ipv6
MASTER_SITES= http://xchat.org/files/source/2.0/ \
http://xchat.linuxpower.org/files/source/2.0/
diff --git a/irc/xchat-gnome/files/patch-src_common_server.c b/irc/xchat-gnome/files/patch-src_common_server.c
new file mode 100644
index 000000000000..e8420fcd0e7d
--- /dev/null
+++ b/irc/xchat-gnome/files/patch-src_common_server.c
@@ -0,0 +1,13 @@
+--- src/common/server.c.orig Sun Aug 10 17:40:15 2003
++++ src/common/server.c Sat Oct 25 22:29:12 2003
+@@ -289,8 +289,8 @@
+ {
+ char *conv_line; /* holds a copy of the original string */
+ int conv_len; /* tells g_convert how much of line to convert */
+- int utf_len;
+- int read_len;
++ gsize utf_len;
++ gsize read_len;
+ GError *err;
+ gboolean retry;
+
diff --git a/irc/xchat-gnome/files/patch-src_common_text.c b/irc/xchat-gnome/files/patch-src_common_text.c
new file mode 100644
index 000000000000..59c1bdae5f5f
--- /dev/null
+++ b/irc/xchat-gnome/files/patch-src_common_text.c
@@ -0,0 +1,11 @@
+--- src/common/text.c.orig Sun Sep 21 12:36:15 2003
++++ src/common/text.c Sat Oct 25 22:29:56 2003
+@@ -446,7 +446,7 @@
+ get_stamp_str (char *fmt, time_t tim, char **ret)
+ {
+ char dest[128];
+- int len;
++ gsize len;
+
+ len = strftime (dest, sizeof (dest), fmt, localtime (&tim));
+ if (len)
diff --git a/irc/xchat-gnome/files/patch-src_fe-gtk_xtext.c b/irc/xchat-gnome/files/patch-src_fe-gtk_xtext.c
new file mode 100644
index 000000000000..d1ed80354b48
--- /dev/null
+++ b/irc/xchat-gnome/files/patch-src_fe-gtk_xtext.c
@@ -0,0 +1,22 @@
+--- src/fe-gtk/xtext.c.orig Thu Sep 18 07:26:52 2003
++++ src/fe-gtk/xtext.c Sat Oct 25 22:31:45 2003
+@@ -2126,6 +2126,7 @@
+ char *stripped;
+ guchar *new_text;
+ int len;
++ gsize glen;
+
+ stripped = gtk_xtext_selection_get_text (xtext, &len);
+ if (!stripped)
+@@ -2158,9 +2159,9 @@
+ }
+ break;
+ default:
+- new_text = g_locale_from_utf8 (stripped, len, NULL, &len, NULL);
++ new_text = g_locale_from_utf8 (stripped, len, NULL, &glen, NULL);
+ gtk_selection_data_set (selection_data_ptr, GDK_SELECTION_TYPE_STRING,
+- 8, new_text, len);
++ 8, new_text, glen);
+ g_free (new_text);
+ }
+
diff --git a/irc/xchat2/Makefile b/irc/xchat2/Makefile
index 1ac54858e52a..e5cc7c26e77d 100644
--- a/irc/xchat2/Makefile
+++ b/irc/xchat2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xchat2
PORTVERSION= 2.0.5
+PORTREVISION= 1
CATEGORIES= irc gnome ipv6
MASTER_SITES= http://xchat.org/files/source/2.0/ \
http://xchat.linuxpower.org/files/source/2.0/
diff --git a/irc/xchat2/files/patch-src_common_server.c b/irc/xchat2/files/patch-src_common_server.c
new file mode 100644
index 000000000000..e8420fcd0e7d
--- /dev/null
+++ b/irc/xchat2/files/patch-src_common_server.c
@@ -0,0 +1,13 @@
+--- src/common/server.c.orig Sun Aug 10 17:40:15 2003
++++ src/common/server.c Sat Oct 25 22:29:12 2003
+@@ -289,8 +289,8 @@
+ {
+ char *conv_line; /* holds a copy of the original string */
+ int conv_len; /* tells g_convert how much of line to convert */
+- int utf_len;
+- int read_len;
++ gsize utf_len;
++ gsize read_len;
+ GError *err;
+ gboolean retry;
+
diff --git a/irc/xchat2/files/patch-src_common_text.c b/irc/xchat2/files/patch-src_common_text.c
new file mode 100644
index 000000000000..59c1bdae5f5f
--- /dev/null
+++ b/irc/xchat2/files/patch-src_common_text.c
@@ -0,0 +1,11 @@
+--- src/common/text.c.orig Sun Sep 21 12:36:15 2003
++++ src/common/text.c Sat Oct 25 22:29:56 2003
+@@ -446,7 +446,7 @@
+ get_stamp_str (char *fmt, time_t tim, char **ret)
+ {
+ char dest[128];
+- int len;
++ gsize len;
+
+ len = strftime (dest, sizeof (dest), fmt, localtime (&tim));
+ if (len)
diff --git a/irc/xchat2/files/patch-src_fe-gtk_xtext.c b/irc/xchat2/files/patch-src_fe-gtk_xtext.c
new file mode 100644
index 000000000000..d1ed80354b48
--- /dev/null
+++ b/irc/xchat2/files/patch-src_fe-gtk_xtext.c
@@ -0,0 +1,22 @@
+--- src/fe-gtk/xtext.c.orig Thu Sep 18 07:26:52 2003
++++ src/fe-gtk/xtext.c Sat Oct 25 22:31:45 2003
+@@ -2126,6 +2126,7 @@
+ char *stripped;
+ guchar *new_text;
+ int len;
++ gsize glen;
+
+ stripped = gtk_xtext_selection_get_text (xtext, &len);
+ if (!stripped)
+@@ -2158,9 +2159,9 @@
+ }
+ break;
+ default:
+- new_text = g_locale_from_utf8 (stripped, len, NULL, &len, NULL);
++ new_text = g_locale_from_utf8 (stripped, len, NULL, &glen, NULL);
+ gtk_selection_data_set (selection_data_ptr, GDK_SELECTION_TYPE_STRING,
+- 8, new_text, len);
++ 8, new_text, glen);
+ g_free (new_text);
+ }
+