aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-12-04 22:36:40 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-12-04 22:36:40 +0800
commit2ca568790f401d48ff77c0efa90ba6d7da00331f (patch)
treec721ef1c573eb33afdf6fe718da7ae38ccadc449 /irc
parentb66ff8f87b5dcd362dee26e41682f69bdde1f8f6 (diff)
downloadfreebsd-ports-gnome-2ca568790f401d48ff77c0efa90ba6d7da00331f.tar.gz
freebsd-ports-gnome-2ca568790f401d48ff77c0efa90ba6d7da00331f.tar.zst
freebsd-ports-gnome-2ca568790f401d48ff77c0efa90ba6d7da00331f.zip
- Clarify LICENSE
- Clean up the makefile - Silence patching - Convert makefile echo's to pkg-message
Diffstat (limited to 'irc')
-rw-r--r--irc/gseen.mod/Makefile19
-rw-r--r--irc/gseen.mod/files/pkg-message.in2
2 files changed, 9 insertions, 12 deletions
diff --git a/irc/gseen.mod/Makefile b/irc/gseen.mod/Makefile
index 4912e64bc196..4911eb86a284 100644
--- a/irc/gseen.mod/Makefile
+++ b/irc/gseen.mod/Makefile
@@ -11,21 +11,20 @@ DISTNAME= ${PORTNAME}.${PORTVERSION:S/p/dev/}
MAINTAINER= ports@FreeBSD.org
COMMENT= Seen-module for the eggdrop IRC bot
-LICENSE= GPLv2
+LICENSE= GPLv2 # or later
-EXTRACT_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/irc/eggdrop:extract
+EXTRACT_DEPENDS=${NONEXISTENT}:${PORTSDIR}/irc/eggdrop:extract
BUILD_DEPENDS= eggdrop:${PORTSDIR}/irc/eggdrop
RUN_DEPENDS= eggdrop:${PORTSDIR}/irc/eggdrop
USES= tcl:85+
-
-WRKSRC= ${WRKDIR}/eggdrop
-
+GNU_CONGFIGURE= yes
CONFIGURE_ARGS= --with-tcllib=${LOCALBASE}/lib/libtcl${TCL_VER:S/.//}.so \
--with-tclinc=${TCL_INCLUDEDIR}/tcl.h
-
+WRKSRC= ${WRKDIR}/eggdrop
MAKE_JOBS_UNSAFE= yes
-GNU_CONGFIGURE= yes
+
+SUB_FILES= pkg-message
do-extract:
@${RM} -rf ${WRKDIR}
@@ -34,7 +33,7 @@ do-extract:
cd ${WRKSRC}/src/mod && ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${_DISTDIR}/${EXTRACT_ONLY} ${EXTRACT_AFTER_ARGS}
post-extract:
- ${REINPLACE_CMD} -e 's|"-g -O2"|"${CFLAGS}"|' \
+ @${REINPLACE_CMD} -e 's|"-g -O2"|"${CFLAGS}"|' \
-e 's|"-g"|"${CFLAGS}"|' \
-e 's|"-O2"|"${CFLAGS}"|' \
${WRKSRC}/configure
@@ -53,9 +52,5 @@ do-install:
${STAGEDIR}${LOCALBASE}/share/eggdrop/language
${INSTALL_DATA} ${WRKSRC}/src/mod/gseen.mod/gseen.conf \
${STAGEDIR}${PREFIX}/etc
- @${ECHO_MSG} "Please add the line"
- @${ECHO_MSG} "source ${PREFIX}/etc/gseen.conf"
- @${ECHO_MSG} "at the end of your eggdrop config file"
- @${ECHO_MSG} "and .rehash your bot"
.include <bsd.port.mk>
diff --git a/irc/gseen.mod/files/pkg-message.in b/irc/gseen.mod/files/pkg-message.in
new file mode 100644
index 000000000000..f26510132937
--- /dev/null
+++ b/irc/gseen.mod/files/pkg-message.in
@@ -0,0 +1,2 @@
+Please add the line source %%PREFIX%%/etc/gseen.conf at the end of
+your eggdrop config file and .rehash your bot