aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-12-17 10:15:13 +0800
committerbapt <bapt@FreeBSD.org>2012-12-17 10:15:13 +0800
commit421fdbd458a94c9af983273f7ee42d99120d59d9 (patch)
tree2462f02d26b3d6c876b0b158f0a6aa557f06a219 /irc
parentb254d40ce314ab3439c8eab6f789fb254328f461 (diff)
downloadfreebsd-ports-gnome-421fdbd458a94c9af983273f7ee42d99120d59d9.tar.gz
freebsd-ports-gnome-421fdbd458a94c9af983273f7ee42d99120d59d9.tar.zst
freebsd-ports-gnome-421fdbd458a94c9af983273f7ee42d99120d59d9.zip
Convert miwi's ports to new Options framework
While here fix some consistency in PEAR options name bumped revision of net/icpld and net/ipsumdump because IPV6 is now on Approved by: miwi (maintainer)
Diffstat (limited to 'irc')
-rw-r--r--irc/irssi-devel/Makefile44
-rw-r--r--irc/pisg/Makefile17
2 files changed, 26 insertions, 35 deletions
diff --git a/irc/irssi-devel/Makefile b/irc/irssi-devel/Makefile
index 1345e6313707..5be70a13e947 100644
--- a/irc/irssi-devel/Makefile
+++ b/irc/irssi-devel/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: irssi-devel
-# Date created: 03 Mar 2005
-# Whom: Vsevolod Stakhov <vsevolod@highsecure.ru>
-#
+# Created by: Vsevolod Stakhov <vsevolod@highsecure.ru>
# $FreeBSD$
-#
PORTNAME= irssi
PORTVERSION= 20120624
@@ -26,28 +22,24 @@ MAKE_JOBS_SAFE= yes
MAN1= irssi.1
-OPTIONS= PERL "Enable Perl support" on \
- PROXY "Enable proxy support" off \
- SOCKS "Enable socks proxy support" off \
- IPV6 "Enable IPv6" on \
- BOT "Enable bot" off
+OPTIONS_DEFINE= PERL PROXY SOCKS IPV6 BOT SSL
+SOCKS_DESC= Socks proxy support
+BOT_DESC= Bot support
+OPTIONS_DEFAULT= PERL IPV6 SSL
WRKSRC= ${WRKDIR}/${PORTNAME}-0.8.15-svn
-# USE_OPENSSL must be defined before bsd.port.pre.mk so use old schema
-# for WITH_SSL option
+.include <bsd.port.options.mk>
-.if defined(WITHOUT_SSL)
-CONFIGURE_ARGS+= --disable-ssl
-.else
+# Process options.
+
+.if ${PORT_OPTIONS:MSSL}
USE_OPENSSL= yes
+.else
+CONFIGURE_ARGS+= --disable-ssl
.endif
-.include <bsd.port.pre.mk>
-
-# Process options.
-
-.if !defined(WITHOUT_PERL)
+.if ${PORT_OPTIONS:MPERL}
USE_PERL5= yes
CONFIGURE_ARGS+= --with-perl-lib=site
PLIST_SUB+= WITH_PERL=""
@@ -56,23 +48,25 @@ CONFIGURE_ARGS+= --without-perl
PLIST_SUB+= WITH_PERL="@comment "
.endif
-.if defined(WITH_PROXY)
+.if ${PORT_OPTIONS:MPROXY}
CONFIGURE_ARGS+= --with-proxy
PLIST_SUB+= WITH_PROXY=""
.else
PLIST_SUB+= WITH_PROXY="@comment "
.endif
-.if defined(WITH_SOCKS)
+.if ${PORT_OPTIONS:MSOCKS}
CONFIGURE_ARGS+= --with-socks
.endif
-.if !defined(WITHOUT_IPV6)
+.if ${PORT_OPTIONS:MIPV6}
CONFIGURE_ARGS+= --enable-ipv6
CATEGORIES+= ipv6
+.else
+CONFIGURE_ARGS+= --disable-ipv6
.endif
-.if defined(WITH_BOT)
+.if ${PORT_OPTIONS:MBOT}
CONFIGURE_ARGS+= --with-bot
PLIST_SUB+= WITH_BOT=""
.else
@@ -93,4 +87,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/irssi.conf.sample ${PREFIX}/etc/irssi.conf ; \
fi
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/irc/pisg/Makefile b/irc/pisg/Makefile
index 8940365cc665..52e450439f02 100644
--- a/irc/pisg/Makefile
+++ b/irc/pisg/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: pisg
-# Date created: Mon Feb 11 13:02:35 GMT 2002
-# Whom: pgl@instinct.org
-#
+# Created by: pgl@instinct.org
# $FreeBSD$
-#
PORTNAME= pisg
PORTVERSION= 0.73
@@ -16,11 +12,12 @@ COMMENT= A Perl IRC Statistics Generator
USE_PERL5= YES
NO_BUILD= YES
-OPTIONS= LOGCHARSET "Character set for logfiles" off
+OPTIONS_DEFINE= LOGCHARSET DOCS
+LOGCHARSET_DESC= Character set for logfiles
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_LOGCHARSET)
+.if ${PORT_OPTIONS:MLOGCHARSET}
RUN_DEPENDS+= p5-Text-Iconv>=0:${PORTSDIR}/converters/p5-Text-Iconv
.endif
@@ -47,7 +44,7 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/modules/Pisg/Parser/Format/*.pm ${SITE_PERL}/Pisg/Parser/Format
${INSTALL_SCRIPT} ${WRKSRC}/pisg ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/docs/pisg-doc.txt ${DOCSDIR}/pisg-doc.txt
.endif
@@ -63,4 +60,4 @@ post-install:
@${ECHO_MSG}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>