aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
authorcrees <crees@FreeBSD.org>2011-07-06 00:46:22 +0800
committercrees <crees@FreeBSD.org>2011-07-06 00:46:22 +0800
commit454daa900fdd4125591404da8e6973978d40dad7 (patch)
treee21ae66b137f0b0c1e4313fc667b1e6c11ca262a /irc
parent5d871cc50359804d660ef54c64bbb534808a8a12 (diff)
downloadfreebsd-ports-gnome-454daa900fdd4125591404da8e6973978d40dad7.tar.gz
freebsd-ports-gnome-454daa900fdd4125591404da8e6973978d40dad7.tar.zst
freebsd-ports-gnome-454daa900fdd4125591404da8e6973978d40dad7.zip
Use USERS and GROUPS
PR: ports/157611 Approved by: rene (mentor, implicit), Moggie (maintainer)
Diffstat (limited to 'irc')
-rw-r--r--irc/ircd-ratbox/Makefile6
-rw-r--r--irc/ircd-ratbox/files/pkg-install.in87
2 files changed, 7 insertions, 86 deletions
diff --git a/irc/ircd-ratbox/Makefile b/irc/ircd-ratbox/Makefile
index e14e25eb4e35..e086cf0184f9 100644
--- a/irc/ircd-ratbox/Makefile
+++ b/irc/ircd-ratbox/Makefile
@@ -25,6 +25,9 @@ MAN8= ircd.8
USE_RC_SUBR= ircd-ratbox.sh
USE_PERL5_BUILD= yes
+USERS= ircd
+GROUPS= ${USERS}
+
LOGDIR= /var/log/${PORTNAME}
RUNDIR= /var/run/${PORTNAME}
SUB_FILES= pkg-message pkg-install
@@ -179,13 +182,12 @@ pre-build:
${PERL} ${WRKSRC}/contrib/ircd-shortcut.pl
pre-su-install:
- @${SETENV} "PKG_PREFIX=${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
${MKDIR} ${PREFIX}/etc/${PORTNAME}
- ${CHOWN} ircd:ircd ${PREFIX}/etc/${PORTNAME}
${MKDIR} ${DATADIR}/help
${MKDIR} ${PREFIX}/lib/${PORTNAME}/modules
post-install:
+ ${CHOWN} -R ircd:ircd ${PREFIX}/etc/${PORTNAME}
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
cd ${WRKSRC}/doc && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
diff --git a/irc/ircd-ratbox/files/pkg-install.in b/irc/ircd-ratbox/files/pkg-install.in
index 135cee12edb2..dab2ae6b1d38 100644
--- a/irc/ircd-ratbox/files/pkg-install.in
+++ b/irc/ircd-ratbox/files/pkg-install.in
@@ -3,93 +3,12 @@
# Adapted from irc/ircd-hybrid's script
#
-ask() {
- local question default answer
-
- question=$1
- default=$2
- if [ -z "${PACKAGE_BUILDING}" ]; then
- read -p "${question} [${default}]? " answer
- fi
- if [ x${answer} = x ]; then
- answer=${default}
- fi
- echo ${answer}
-}
-
-yesno() {
- local dflt question answer
-
- question=$1
- dflt=$2
- while :; do
- answer=$(ask "${question}" "${dflt}")
- case "${answer}" in
- [Yy]*) return 0;;
- [Nn]*) return 1;;
- esac
- echo "Please answer yes or no."
- done
-}
-
#-----------------------------------------------------------------------
if [ "x$2" = "xPRE-INSTALL" ]; then
#-----------------------------------------------------------------------
-
-if which -s pw ; then
- :
-else
- cat <<EOF
-Your system does not include the "pw" utility. You should upgrade
-to a newer version of FreeBSD. Without "pw" this script will not
-run.
-EOF
- exit 1
-fi
-
-echo ""
-if pw groupshow ircd 2> /dev/null ; then
- echo "You already have a group \"ircd\", so I will use it."
-else
- if pw groupshow 72 2> /dev/null ; then
- echo "You already have a gid \"72\". Please create a user \"ircd\""
- echo "with a default group of \"ircd\"."
- exit 1
- fi
- echo "You need a group \"ircd\"."
- if which -s pw && yesno "Would you like me to create it" y; then
- pw groupadd ircd -g 72 || exit
- echo "Done."
- else
- echo "Please create it, and try again."
- if ! pw usershow ircd 2> /dev/null ; then
- echo "While you're at it, please create a user \"ircd\""
- echo 'too, with a default group of "ircd".'
- fi
- exit 1
- fi
-fi
-
-if pw usershow ircd 2> /dev/null ; then
- echo "You already have a user \"ircd\", so I will use it."
-else
- if pw usershow 72 2> /dev/null ; then
- echo "You already have a uid \"72\". Please create a user \"irc
-d\""
- echo "with a default group of \"ircd\"."
- exit 1
- fi
- echo "You need a user \"ircd\"."
- if which -s pw && yesno "Would you like me to create it" y; then
- pw useradd ircd -g ircd -u 72 -h - -d /nonexistent \
- -s /nonexistent -c "IRC Daemon" || exit
- echo "Done."
- else
- echo "Please create it, and try again."
- exit 1
- fi
-fi
-
+#
+# ${DO_NADA}
+#
#-----------------------------------------------------------------------
elif [ "x$2" = "xPOST-INSTALL" ]; then
#-----------------------------------------------------------------------