aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
authorbrnrd <brnrd@FreeBSD.org>2017-08-14 23:24:59 +0800
committerbrnrd <brnrd@FreeBSD.org>2017-08-14 23:24:59 +0800
commit4bae62e9b16290d2b92efc258efa87de4e54fc39 (patch)
treef55e14e3aa1e077c9347c59ab3cae8e02739a41a /irc
parent827b40aa13b1557e3862706d472e32b9ea84eb78 (diff)
downloadfreebsd-ports-gnome-4bae62e9b16290d2b92efc258efa87de4e54fc39.tar.gz
freebsd-ports-gnome-4bae62e9b16290d2b92efc258efa87de4e54fc39.tar.zst
freebsd-ports-gnome-4bae62e9b16290d2b92efc258efa87de4e54fc39.zip
irc/weechat: Depend on libunwind for RUBY
- Ruby on amd64/i386 uses libunwind causing weechat to link it as well Reported by: koobs
Diffstat (limited to 'irc')
-rw-r--r--irc/weechat/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/irc/weechat/Makefile b/irc/weechat/Makefile
index ea246268667d..a5eb588d187e 100644
--- a/irc/weechat/Makefile
+++ b/irc/weechat/Makefile
@@ -97,6 +97,10 @@ CMAKE_ARGS+= -DENABLE_PYTHON3:BOOL=true \
-DPYTHON_LIBRARY:FILEPATH=${LOCALBASE}/lib/libpython${PYTHON_VER}m.so
.endif
+.if !empty(PORT_OPTIONS:MRUBY) && (${ARCH} == "amd64" || ${ARCH} == "i386")
+LIB_DEPENDS+= libunwind.so:devel/libunwind
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|$${LIBDIR}/../pkgconfig|$${CMAKE_INSTALL_PREFIX}/libdata/pkgconfig|' \
${WRKSRC}/CMakeLists.txt