aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
authordaichi <daichi@FreeBSD.org>2003-06-27 12:43:19 +0800
committerdaichi <daichi@FreeBSD.org>2003-06-27 12:43:19 +0800
commit56a4f30d98a94a30b4f46cc7ba743f674357890e (patch)
tree31a71d139d0dca3db4477112eed094dbefb981e0 /irc
parent524e66df6b1072c0cc138e7f63ea50ea8eaeb963 (diff)
downloadfreebsd-ports-gnome-56a4f30d98a94a30b4f46cc7ba743f674357890e.tar.gz
freebsd-ports-gnome-56a4f30d98a94a30b4f46cc7ba743f674357890e.tar.zst
freebsd-ports-gnome-56a4f30d98a94a30b4f46cc7ba743f674357890e.zip
bug fixes: irc/dancer
o Make the port respect CC, CFLAGS variables. o Prevent needless debugging symbols being compiled in. PR: 53804 Submitted by: Dominic Marks <dominic.marks@btinternet.com> (maintainer)
Diffstat (limited to 'irc')
-rw-r--r--irc/dancer/files/patch-Makefile11
-rw-r--r--irc/dancer/files/patch-src::Makefile.in18
2 files changed, 29 insertions, 0 deletions
diff --git a/irc/dancer/files/patch-Makefile b/irc/dancer/files/patch-Makefile
new file mode 100644
index 000000000000..ba28e6a5edfb
--- /dev/null
+++ b/irc/dancer/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile Thu Jun 26 23:43:33 2003
++++ Makefile.new Thu Jun 26 23:44:58 2003
+@@ -23,7 +23,7 @@
+ PRG = dancer
+
+ all: src/config.h
+- (cd src; make debug)
++ (cd src; make)
+
+ src/config.h:
+ (cd src; ./configure; cd ..)
diff --git a/irc/dancer/files/patch-src::Makefile.in b/irc/dancer/files/patch-src::Makefile.in
new file mode 100644
index 000000000000..507df276db47
--- /dev/null
+++ b/irc/dancer/files/patch-src::Makefile.in
@@ -0,0 +1,18 @@
+--- src/Makefile.in Mon Nov 13 02:42:37 2000
++++ src/Makefile.in.new Thu Jun 26 23:32:18 2003
+@@ -22,10 +22,11 @@
+
+ CSPECIAL =
+
+-CC = @CC@
+-CFLAGS = @CPPFLAGS@ @CFLAGS@ @DEFS@ $(CSPECIAL)
+-LDFLAGS = @LDFLAGS@
+-LIBS = @LIBS@
++CC ?= @CC@
++CFLAGS ?= @CFLAGS@
++CFLAGS += @DEFS@ $(CSPECIAL)
++LDFLAGS ?= @LDFLAGS@
++LIBS ?= @LIBS@
+
+ RM = 'rm'
+