aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2018-10-29 18:54:15 +0800
committerdanfe <danfe@FreeBSD.org>2018-10-29 18:54:15 +0800
commit89cc59efe32e4e19cef9e82d07bf737275f51b54 (patch)
treead2c658523c8ed43aa80e6680b5ea87b86a7ae4e /irc
parentc7a144f602968150a1286e491daf0b2b49ccfb54 (diff)
downloadfreebsd-ports-gnome-89cc59efe32e4e19cef9e82d07bf737275f51b54.tar.gz
freebsd-ports-gnome-89cc59efe32e4e19cef9e82d07bf737275f51b54.tar.zst
freebsd-ports-gnome-89cc59efe32e4e19cef9e82d07bf737275f51b54.zip
- Remove BROKEN_SSL line (should've been part of r483042)
- Cleanup options block a bit and use our standard LANG_HE option for Hebrew language support
Diffstat (limited to 'irc')
-rw-r--r--irc/bitchx/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/irc/bitchx/Makefile b/irc/bitchx/Makefile
index 984e5ac6bf85..f939be32ee33 100644
--- a/irc/bitchx/Makefile
+++ b/irc/bitchx/Makefile
@@ -31,21 +31,19 @@ DATADIR= ${PREFIX}/share/bx
MAKE_JOBS_UNSAFE= yes
-OPTIONS_DEFINE= DOCS HEBREW IPV6 LATIN PLUGINS SSL TOGGLES
+OPTIONS_DEFINE= DOCS LANG_HE IPV6 LATIN PLUGINS SSL TOGGLES
+OPTIONS_DEFAULT= PLUGINS SSL
LATIN_DESC= Recommended for ISO-8859-1 display
PLUGINS_DESC= Build a handful of BitchX plugins
-HEBREW_DESC= Add support for hebrew language
TOGGLES_DESC= Disable annoyance toggles
-OPTIONS_DEFAULT= PLUGINS SSL
IPV6_CONFIGURE_ENABLE= ipv6
SSL_CONFIGURE_WITH= ssl
SSL_USES= ssl
-SSL_VARS= BROKEN_SSL=openssl-devel
-PLUGINS_CONFIGURE_WITH= plugins="${PLUGIN_LIST:C/\$$/,/g}"
+PLUGINS_CONFIGURE_WITH= plugins="${PLUGIN_LIST:C/\$$/,/g}"
PLUGIN_LIST= abot acro arcfour autocycle blowfish cavlink cdrom encrypt \
europa fserv hint nap nicklist pkga possum qbx qmail wavplay
@@ -62,7 +60,7 @@ post-patch-LATIN-on:
${REINPLACE_CMD} -e 's|#undef LATIN1|#define LATIN1|' \
${WRKSRC}/include/config.h
-post-patch-HEBREW-on:
+post-patch-LANG_HE-on:
${REINPLACE_CMD} -e 's|#undef WANT_HEBREW|#define WANT_HEBREW|' \
${WRKSRC}/include/config.h