aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
authorFrank J. Laszlo <laszlof@FreeBSD.org>2007-08-13 00:27:37 +0800
committerFrank J. Laszlo <laszlof@FreeBSD.org>2007-08-13 00:27:37 +0800
commit9347ebf5de0bd632b6988679d2df1a73ac56de8b (patch)
tree6bd068d84189bd956ca2f5ecca35cc9e1094bce4 /irc
parenteae540764e95cdd57d8ed21ba30e420c368adad4 (diff)
downloadfreebsd-ports-gnome-9347ebf5de0bd632b6988679d2df1a73ac56de8b.tar.gz
freebsd-ports-gnome-9347ebf5de0bd632b6988679d2df1a73ac56de8b.tar.zst
freebsd-ports-gnome-9347ebf5de0bd632b6988679d2df1a73ac56de8b.zip
NEW PORT
Nefarious IRCu is a collection of modifications to the Undernet IRC daemon known as IRCu. This version is based on Undernet IRCu by the Undernet Coder Committee. The original code can be obtained from their webpage, http://coder-com.undernet.org/
Diffstat (limited to 'irc')
-rw-r--r--irc/Makefile1
-rw-r--r--irc/nefarious/Makefile54
-rw-r--r--irc/nefarious/distinfo3
-rw-r--r--irc/nefarious/files/patch-ircd_Makefile.in18
-rw-r--r--irc/nefarious/pkg-descr6
-rw-r--r--irc/nefarious/pkg-plist10
6 files changed, 92 insertions, 0 deletions
diff --git a/irc/Makefile b/irc/Makefile
index dc9c0de244ec..d42d01934523 100644
--- a/irc/Makefile
+++ b/irc/Makefile
@@ -68,6 +68,7 @@
SUBDIR += lostirc
SUBDIR += miau
SUBDIR += muh
+ SUBDIR += nefarious
SUBDIR += nethirc
SUBDIR += netwalker-ircc
SUBDIR += ngircd
diff --git a/irc/nefarious/Makefile b/irc/nefarious/Makefile
new file mode 100644
index 000000000000..8813670a349a
--- /dev/null
+++ b/irc/nefarious/Makefile
@@ -0,0 +1,54 @@
+# New ports collection makefile for: Nefarious
+# Date created: 12 August 2007
+# Whom: Frank J. Laszlo <laszlof@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Nefarious
+PORTVERSION= 1.0.1
+CATEGORIES= irc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= evilnet
+
+MAINTAINER= laszlof@FreeBSD.org
+COMMENT= IRC server used by evilnet based off of Undernet\'s ircu
+
+USE_BZIP2= yes
+HAS_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+PLIST_SUB+= INSTALL_PREFIX=${INSTALL_PREFIX:S/${PREFIX}\///}
+MAN8= ircd.8
+
+.include <bsd.port.pre.mk>
+
+.if !defined(INSTALL_PREFIX)
+INSTALL_PREFIX=${PREFIX}/${PORTNAME}
+.endif
+
+.if defined(WITH_OPENSSL)
+USE_OPENSSL= yes
+CONFIGURE_ARGS+= --enable-ssl
+.endif
+
+.if defined(WITH_CHROOT)
+CONFIGURE_ARGS+= --with-chroot=${INSTALL_PREFIX}
+.endif
+
+.if defined(DOMAIN)
+CONFIGURE_ARGS+= --with-domain=${DOMAIN}
+.endif
+
+CONFIGURE_ARGS+= --prefix=${INSTALL_PREFIX} --mandir=${PREFIX}/man --infodir=${PREFIX}/info
+
+pre-configure:
+ @${ECHO_CMD} ""
+ @${ECHO_CMD} "User configurable options for ${PORTNAME}:"
+ @${ECHO_CMD} "INSTALL_PREFIX - Where to install all Nefarious files (default: PREFIX/Nefarious)"
+ @${ECHO_CMD} "WITH_OPENSSL - Compile with SSL support"
+ @${ECHO_CMD} "WITH_CHROOT - chroot the ircd within INSTALL_PREFIX"
+ @${ECHO_CMD} "DOMAIN - Domain to use for IRCd"
+ @${ECHO_CMD} ""
+ @sleep 5
+
+.include <bsd.port.post.mk>
diff --git a/irc/nefarious/distinfo b/irc/nefarious/distinfo
new file mode 100644
index 000000000000..ce83829aa798
--- /dev/null
+++ b/irc/nefarious/distinfo
@@ -0,0 +1,3 @@
+MD5 (Nefarious-1.0.1.tar.bz2) = 7cd04f6ae101d5b7f93f8cbd4a1e9ee9
+SHA256 (Nefarious-1.0.1.tar.bz2) = f3fb2fd72c1b15a0411fe316d09ce926541f8e619026b40e8f464e5739bd8c09
+SIZE (Nefarious-1.0.1.tar.bz2) = 1828893
diff --git a/irc/nefarious/files/patch-ircd_Makefile.in b/irc/nefarious/files/patch-ircd_Makefile.in
new file mode 100644
index 000000000000..8aa78d2a2c5a
--- /dev/null
+++ b/irc/nefarious/files/patch-ircd_Makefile.in
@@ -0,0 +1,18 @@
+--- ircd/Makefile.in.orig Sun Aug 12 15:43:23 2007
++++ ircd/Makefile.in Sun Aug 12 15:44:03 2007
+@@ -295,13 +295,8 @@
+ ${CHOWN} ${IRCDOWN} ${DPATH}; \
+ ${CHGRP} ${IRCDGRP} ${DPATH}; \
+ fi
+- @echo `date +%Y%m%d%H%M` > /tmp/ircd.tag;
+- @echo "Installing new ircd as ${BINDIR}/ircd.`cat /tmp/ircd.tag` :"
+- ${INSTALL} -m ${IRCDMODE} -o ${IRCDOWN} -g ${IRCDGRP} ircd ${BINDIR}/ircd.`cat /tmp/ircd.tag`
+- @( cd ${BINDIR}; \
+- ${RM} -f ${SYMLINK}; \
+- ${LN_S} ircd.`cat /tmp/ircd.tag` ${SYMLINK}; )
+- @${RM} /tmp/ircd.tag
++ @echo "Installing new ircd as ${BINDIR}/ircd :"
++ ${INSTALL} -m ${IRCDMODE} -o ${IRCDOWN} -g ${IRCDGRP} ircd ${BINDIR}/ircd
+ ${INSTALL} -s -m 700 -o ${IRCDOWN} -g ${IRCDGRP} chkconf ${BINDIR}
+ ${INSTALL} -m 600 -o ${IRCDOWN} -g ${IRCDGRP} ${top_srcdir}/doc/example.conf ${DPATH}
+ ${INSTALL} -m 600 -o ${IRCDOWN} -g ${IRCDGRP} ${top_srcdir}/doc/ircd.quotes ${DPATH}
diff --git a/irc/nefarious/pkg-descr b/irc/nefarious/pkg-descr
new file mode 100644
index 000000000000..dcf51a49367f
--- /dev/null
+++ b/irc/nefarious/pkg-descr
@@ -0,0 +1,6 @@
+Nefarious IRCu is a collection of modifications to the Undernet IRC
+daemon known as IRCu. This version is based on Undernet IRCu by the
+Undernet Coder Committee. The original code can be obtained from
+their webpage, http://coder-com.undernet.org/
+
+WWW: http://www.sourceforge.net/projects/evilnet
diff --git a/irc/nefarious/pkg-plist b/irc/nefarious/pkg-plist
new file mode 100644
index 000000000000..5ed4faf5d8b4
--- /dev/null
+++ b/irc/nefarious/pkg-plist
@@ -0,0 +1,10 @@
+%%INSTALL_PREFIX%%/bin/ircd
+%%INSTALL_PREFIX%%/bin/chkconf
+%%INSTALL_PREFIX%%/lib/example.conf
+%%INSTALL_PREFIX%%/lib/ircd.quotes
+%%INSTALL_PREFIX%%/lib/ircd.rules
+%%INSTALL_PREFIX%%/lib/ircd.opermotd
+%%INSTALL_PREFIX%%/lib/ircd.motd
+@dirrm %%INSTALL_PREFIX%%/bin
+@dirrm %%INSTALL_PREFIX%%/lib
+@dirrm %%INSTALL_PREFIX%%