aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
authorDag-Erling Smørgrav <des@FreeBSD.org>2018-10-06 21:06:42 +0800
committerDag-Erling Smørgrav <des@FreeBSD.org>2018-10-06 21:06:42 +0800
commit9dff3523203bdda7ae358dcff3eb5a5ef3e54d33 (patch)
tree0721b637b4bcfc0a8ff2a945bdcb7e68f8993680 /irc
parent2e4b740f2cc9a250b2c6056d8706e15d3bfa9763 (diff)
downloadfreebsd-ports-gnome-9dff3523203bdda7ae358dcff3eb5a5ef3e54d33.tar.gz
freebsd-ports-gnome-9dff3523203bdda7ae358dcff3eb5a5ef3e54d33.tar.zst
freebsd-ports-gnome-9dff3523203bdda7ae358dcff3eb5a5ef3e54d33.zip
Fix every instance of RUN_DEPENDS:=${BUILD_DEPENDS} in p5 ports, except
for where it resulted in a change in output from build-depends-list or run-depends-list. Approved by: portmgr (adamw)
Diffstat (limited to 'irc')
-rw-r--r--irc/p5-AnyEvent-IRC/Makefile4
-rw-r--r--irc/p5-Bot-BasicBot/Makefile4
-rw-r--r--irc/p5-IRC-Bot-Hangman/Makefile4
-rw-r--r--irc/p5-POE-Component-IRC-Object/Makefile4
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-Blowfish/Makefile4
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-Bollocks/Makefile4
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-CoreList/Makefile4
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-Hailo/Makefile4
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-Karma/Makefile4
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-POE-Knee/Makefile4
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-QueryDNS/Makefile4
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-RSS-Headlines/Makefile4
-rw-r--r--irc/p5-POE-Component-IRC/Makefile4
-rw-r--r--irc/p5-POE-Filter-IRCD/Makefile4
14 files changed, 28 insertions, 28 deletions
diff --git a/irc/p5-AnyEvent-IRC/Makefile b/irc/p5-AnyEvent-IRC/Makefile
index e82c3800707a..5673a3615d84 100644
--- a/irc/p5-AnyEvent-IRC/Makefile
+++ b/irc/p5-AnyEvent-IRC/Makefile
@@ -14,9 +14,9 @@ COMMENT= Event system independent IRC protocol module
LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
-BUILD_DEPENDS= p5-AnyEvent>=0:devel/p5-AnyEvent \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-AnyEvent>=0:devel/p5-AnyEvent \
p5-Object-Event>=0.7:devel/p5-Object-Event
-RUN_DEPENDS:= ${BUILD_DEPENDS}
NO_ARCH= yes
USES= perl5
diff --git a/irc/p5-Bot-BasicBot/Makefile b/irc/p5-Bot-BasicBot/Makefile
index cb345cc4c702..760e280248f6 100644
--- a/irc/p5-Bot-BasicBot/Makefile
+++ b/irc/p5-Bot-BasicBot/Makefile
@@ -14,9 +14,9 @@ LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= p5-POE>=0:devel/p5-POE \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-POE>=0:devel/p5-POE \
p5-POE-Component-IRC>=6.90:irc/p5-POE-Component-IRC
-RUN_DEPENDS:= ${BUILD_DEPENDS}
NO_ARCH= yes
USES= perl5
diff --git a/irc/p5-IRC-Bot-Hangman/Makefile b/irc/p5-IRC-Bot-Hangman/Makefile
index 5609c4e4c3a1..50b09fc1652c 100644
--- a/irc/p5-IRC-Bot-Hangman/Makefile
+++ b/irc/p5-IRC-Bot-Hangman/Makefile
@@ -12,12 +12,12 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= IRC hangman bot
-BUILD_DEPENDS= p5-Bot-BasicBot>=0:irc/p5-Bot-BasicBot \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Bot-BasicBot>=0:irc/p5-Bot-BasicBot \
p5-Games-GuessWord>=0:games/p5-Games-GuessWord \
p5-Module-Find>=0:devel/p5-Module-Find \
p5-Chatbot-Eliza>=0:misc/p5-Chatbot-Eliza \
p5-Regexp-Common>=0:textproc/p5-Regexp-Common
-RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= modbuild
diff --git a/irc/p5-POE-Component-IRC-Object/Makefile b/irc/p5-POE-Component-IRC-Object/Makefile
index d177762f091d..36a2f9931993 100644
--- a/irc/p5-POE-Component-IRC-Object/Makefile
+++ b/irc/p5-POE-Component-IRC-Object/Makefile
@@ -11,9 +11,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Slightly simpler OO interface to POE::Component::IRC
-BUILD_DEPENDS= p5-POE>=0:devel/p5-POE \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-POE>=0:devel/p5-POE \
p5-POE-Component-IRC>=0:irc/p5-POE-Component-IRC
-RUN_DEPENDS:= ${BUILD_DEPENDS}
#PLIST_SUB= EXAMPLESDIR="share/examples/${PORTNAME}"
USES= perl5
diff --git a/irc/p5-POE-Component-IRC-Plugin-Blowfish/Makefile b/irc/p5-POE-Component-IRC-Plugin-Blowfish/Makefile
index 7e8d9778b31c..1256bf7af154 100644
--- a/irc/p5-POE-Component-IRC-Plugin-Blowfish/Makefile
+++ b/irc/p5-POE-Component-IRC-Plugin-Blowfish/Makefile
@@ -15,10 +15,10 @@ COMMENT= POE::Component::IRC plugin tthat provides blowfish encryption
LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
-BUILD_DEPENDS= p5-POE>=0.37:devel/p5-POE \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-POE>=0.37:devel/p5-POE \
p5-POE-Component-IRC>=5.07:irc/p5-POE-Component-IRC \
p5-Crypt-Blowfish_PP>=1.12:security/p5-Crypt-Blowfish_PP
-RUN_DEPENDS:= ${BUILD_DEPENDS}
PLIST_SUB= EXAMPLESDIR="share/examples/${PORTNAME}"
diff --git a/irc/p5-POE-Component-IRC-Plugin-Bollocks/Makefile b/irc/p5-POE-Component-IRC-Plugin-Bollocks/Makefile
index 5bb594685a7d..79120c09a01f 100644
--- a/irc/p5-POE-Component-IRC-Plugin-Bollocks/Makefile
+++ b/irc/p5-POE-Component-IRC-Plugin-Bollocks/Makefile
@@ -14,10 +14,10 @@ LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= p5-Dev-Bollocks>=0.06:textproc/p5-Dev-Bollocks \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Dev-Bollocks>=0.06:textproc/p5-Dev-Bollocks \
p5-POE>=0:devel/p5-POE \
p5-POE-Component-IRC>=0:irc/p5-POE-Component-IRC
-RUN_DEPENDS:= ${BUILD_DEPENDS}
OPTIONS_DEFINE= EXAMPLES
diff --git a/irc/p5-POE-Component-IRC-Plugin-CoreList/Makefile b/irc/p5-POE-Component-IRC-Plugin-CoreList/Makefile
index 9001fe69836d..16e6e2fc16dc 100644
--- a/irc/p5-POE-Component-IRC-Plugin-CoreList/Makefile
+++ b/irc/p5-POE-Component-IRC-Plugin-CoreList/Makefile
@@ -14,9 +14,9 @@ LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= p5-POE>=0:devel/p5-POE \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-POE>=0:devel/p5-POE \
p5-POE-Component-IRC>=0:irc/p5-POE-Component-IRC
-RUN_DEPENDS:= ${BUILD_DEPENDS}
OPTIONS_DEFINE= EXAMPLES
diff --git a/irc/p5-POE-Component-IRC-Plugin-Hailo/Makefile b/irc/p5-POE-Component-IRC-Plugin-Hailo/Makefile
index 4ee5ce7d705a..bd1064202d9a 100644
--- a/irc/p5-POE-Component-IRC-Plugin-Hailo/Makefile
+++ b/irc/p5-POE-Component-IRC-Plugin-Hailo/Makefile
@@ -15,12 +15,12 @@ COMMENT= PoCo-IRC plugin for a Hailo conversation simulator
LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
-BUILD_DEPENDS= p5-IRC-Utils>=0.05:irc/p5-IRC-Utils \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-IRC-Utils>=0.05:irc/p5-IRC-Utils \
p5-Math-Random-OO>=0.21:math/p5-Math-Random-OO \
p5-POE>=0:devel/p5-POE \
p5-POE-Component-Hailo>=0:devel/p5-POE-Component-Hailo \
p5-POE-Component-IRC>=6.22:irc/p5-POE-Component-IRC
-RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Script>=1.07:devel/p5-Test-Script
USES= perl5
diff --git a/irc/p5-POE-Component-IRC-Plugin-Karma/Makefile b/irc/p5-POE-Component-IRC-Plugin-Karma/Makefile
index 98d749267355..70f84927ff44 100644
--- a/irc/p5-POE-Component-IRC-Plugin-Karma/Makefile
+++ b/irc/p5-POE-Component-IRC-Plugin-Karma/Makefile
@@ -14,11 +14,11 @@ COMMENT= PoCo-IRC plugin that keeps track of karma
LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
-BUILD_DEPENDS= p5-DBD-SQLite>=0:databases/p5-DBD-SQLite \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-DBD-SQLite>=0:databases/p5-DBD-SQLite \
p5-DBI>=0:databases/p5-DBI \
p5-POE-Component-IRC>=6.22:irc/p5-POE-Component-IRC \
p5-Moose>=0:devel/p5-Moose
-RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-MockObject>=0:devel/p5-Test-MockObject
USES= perl5
diff --git a/irc/p5-POE-Component-IRC-Plugin-POE-Knee/Makefile b/irc/p5-POE-Component-IRC-Plugin-POE-Knee/Makefile
index 6003a40f962c..374e63439f9c 100644
--- a/irc/p5-POE-Component-IRC-Plugin-POE-Knee/Makefile
+++ b/irc/p5-POE-Component-IRC-Plugin-POE-Knee/Makefile
@@ -14,10 +14,10 @@ LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= p5-Math-Random>=0.69:math/p5-Math-Random \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Math-Random>=0.69:math/p5-Math-Random \
p5-POE>=0:devel/p5-POE \
p5-POE-Component-IRC>=0:irc/p5-POE-Component-IRC
-RUN_DEPENDS:= ${BUILD_DEPENDS}
NO_ARCH= yes
USES= perl5 shebangfix
diff --git a/irc/p5-POE-Component-IRC-Plugin-QueryDNS/Makefile b/irc/p5-POE-Component-IRC-Plugin-QueryDNS/Makefile
index 723629d04a7a..0e1f9ed2ec1f 100644
--- a/irc/p5-POE-Component-IRC-Plugin-QueryDNS/Makefile
+++ b/irc/p5-POE-Component-IRC-Plugin-QueryDNS/Makefile
@@ -11,10 +11,10 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= POE::Component::IRC plugin for IRC based DNS queries
-BUILD_DEPENDS= p5-Net-IP>=1.25:net-mgmt/p5-Net-IP \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Net-IP>=1.25:net-mgmt/p5-Net-IP \
p5-POE-Component-Client-DNS>=1.00:dns/p5-POE-Component-Client-DNS \
p5-POE-Component-IRC>=0:irc/p5-POE-Component-IRC
-RUN_DEPENDS:= ${BUILD_DEPENDS}
PLIST_SUB= EXAMPLESDIR="share/examples/${PORTNAME}"
USES= perl5
diff --git a/irc/p5-POE-Component-IRC-Plugin-RSS-Headlines/Makefile b/irc/p5-POE-Component-IRC-Plugin-RSS-Headlines/Makefile
index df95778cb17d..a783aa2d7252 100644
--- a/irc/p5-POE-Component-IRC-Plugin-RSS-Headlines/Makefile
+++ b/irc/p5-POE-Component-IRC-Plugin-RSS-Headlines/Makefile
@@ -14,12 +14,12 @@ LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= p5-HTTP-Message>=0:www/p5-HTTP-Message \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-HTTP-Message>=0:www/p5-HTTP-Message \
p5-POE>=1.004:devel/p5-POE \
p5-POE-Component-Client-HTTP>=0.73:www/p5-POE-Component-Client-HTTP \
p5-POE-Component-IRC>=5.07:irc/p5-POE-Component-IRC \
p5-XML-RSS>=1.1:textproc/p5-XML-RSS
-RUN_DEPENDS:= ${BUILD_DEPENDS}
NO_ARCH= yes
USES= perl5
diff --git a/irc/p5-POE-Component-IRC/Makefile b/irc/p5-POE-Component-IRC/Makefile
index 8b75c1078d8f..680c36596a17 100644
--- a/irc/p5-POE-Component-IRC/Makefile
+++ b/irc/p5-POE-Component-IRC/Makefile
@@ -14,13 +14,13 @@ LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= p5-IRC-Utils>=0.12:irc/p5-IRC-Utils \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-IRC-Utils>=0.12:irc/p5-IRC-Utils \
p5-POE>=1.311:devel/p5-POE \
p5-POE-Component-Client-DNS>=0.99:dns/p5-POE-Component-Client-DNS \
p5-POE-Component-SSLify>=0:security/p5-POE-Component-SSLify \
p5-POE-Component-Syndicator>=0.01:devel/p5-POE-Component-Syndicator \
p5-POE-Filter-IRCD>=2.42:irc/p5-POE-Filter-IRCD
-RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Differences>=0.610:devel/p5-Test-Differences
OPTIONS_DEFINE= EXAMPLES
diff --git a/irc/p5-POE-Filter-IRCD/Makefile b/irc/p5-POE-Filter-IRCD/Makefile
index 59d3efd4f328..a54912912e3b 100644
--- a/irc/p5-POE-Filter-IRCD/Makefile
+++ b/irc/p5-POE-Filter-IRCD/Makefile
@@ -15,8 +15,8 @@ LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= p5-POE>=0:devel/p5-POE
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-POE>=0:devel/p5-POE
USES= perl5
USE_PERL5= configure