aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2019-06-27 17:02:56 +0800
committerdanfe <danfe@FreeBSD.org>2019-06-27 17:02:56 +0800
commitc93306da3bd9229876f115b3fb48c3bf30e2a0be (patch)
tree9b00b47306733fd0c753d6a412fb12557feb9478 /irc
parentac6fc50dd6e23daee20d0d36234e5133336eece6 (diff)
downloadfreebsd-ports-gnome-c93306da3bd9229876f115b3fb48c3bf30e2a0be.tar.gz
freebsd-ports-gnome-c93306da3bd9229876f115b3fb48c3bf30e2a0be.tar.zst
freebsd-ports-gnome-c93306da3bd9229876f115b3fb48c3bf30e2a0be.zip
Update Guile to version 2.2.5, modern stable version, and fix dependent
ports to build against it. Most changes are rather minor and mechanical except for the devel/gdb (obtained via their bugtracker [1], courtesy of Doug Evans). One port (science/meep) I had to mark BROKEN after fixing it proved to be very tedious and actually unreliable. It is very old, there are newer versions available so it should be fixed by updating. One port (devel/libruin) had revealed a bug in the new Guile code (an auxiliary script, really) that had to be worked-round; reference to the problematic upstream commit is provided in the patch. PR: 229613 Exp-run by: antoine [1] https://sourceware.org/bugzilla/show_bug.cgi?id=21104#c8
Diffstat (limited to 'irc')
-rw-r--r--irc/weechat/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/irc/weechat/Makefile b/irc/weechat/Makefile
index 2cc708b3a17b..4ba301438d6b 100644
--- a/irc/weechat/Makefile
+++ b/irc/weechat/Makefile
@@ -3,6 +3,7 @@
PORTNAME= weechat
PORTVERSION= 2.5
+PORTREVISION= 1
CATEGORIES= irc
MASTER_SITES= https://weechat.org/files/src/
@@ -19,8 +20,7 @@ LIB_DEPENDS+= libcurl.so:ftp/curl \
USES= cmake:noninja ncurses libtool tar:xz
USE_LDCONFIG= yes
-CMAKE_ARGS+= -DENABLE_GUILE=no \
- -DLIBDATADIR=${LOCALBASE}/libdata
+CMAKE_ARGS= -DLIBDATADIR=${LOCALBASE}/libdata
OPTIONS_DEFINE= BACKTRACE DOCS CA_BUNDLE GNUTLS HEADLESS ICON ICONV \
MANPAGES NLS
@@ -58,7 +58,8 @@ DOCS_CMAKE_BOOL= ENABLE_DOC
DOCS_BUILD_DEPENDS= ${LOCALBASE}/bin/asciidoctor:textproc/rubygem-asciidoctor
GNUTLS_LIB_DEPENDS= libgnutls.so:security/gnutls
GNUTLS_USES= pkgconfig
-GUILE_LIB_DEPENDS= libguile-2.0.so:lang/guile2
+GUILE_LIB_DEPENDS= libguile-2.2.so:lang/guile2
+GUILE_CMAKE_BOOL= ENABLE_GUILE
ICONV_USES= iconv
JAVASCRIPT_LIB_DEPENDS= libv8.so:lang/v8
LUA_USES= lua pkgconfig