aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
authorzeising <zeising@FreeBSD.org>2019-11-06 06:26:59 +0800
committerzeising <zeising@FreeBSD.org>2019-11-06 06:26:59 +0800
commitd0dc5def86b713b60c00871940830b0f566bc0ec (patch)
treec8a3830aa32c41f0a667a82d507304ec741e5a87 /irc
parentc6af7a3a7c6c975929f99208c14ab75e5f1037ff (diff)
downloadfreebsd-ports-gnome-d0dc5def86b713b60c00871940830b0f566bc0ec.tar.gz
freebsd-ports-gnome-d0dc5def86b713b60c00871940830b0f566bc0ec.tar.zst
freebsd-ports-gnome-d0dc5def86b713b60c00871940830b0f566bc0ec.zip
Add USES=xorg USES=gl, ports categories i
Add USES=xorg and USES=gl to ports in categories starting with 'i'. While here, try to sprinkle other USES (mostly gnome and sdl) as needed.
Diffstat (limited to 'irc')
-rw-r--r--irc/dxirc/Makefile2
-rw-r--r--irc/hexchat/Makefile2
-rw-r--r--irc/kvirc/Makefile2
-rw-r--r--irc/quirc/Makefile2
4 files changed, 4 insertions, 4 deletions
diff --git a/irc/dxirc/Makefile b/irc/dxirc/Makefile
index e7f14c7633eb..53e68a8cfde8 100644
--- a/irc/dxirc/Makefile
+++ b/irc/dxirc/Makefile
@@ -12,7 +12,7 @@ COMMENT= Simple IRC client
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= cmake compiler:c++11-lang pkgconfig
+USES= cmake compiler:c++11-lang pkgconfig xorg
USE_XORG= ice sm x11 xext
INSTALLS_ICONS= yes
diff --git a/irc/hexchat/Makefile b/irc/hexchat/Makefile
index b85ab92353b1..0207fc7dab9b 100644
--- a/irc/hexchat/Makefile
+++ b/irc/hexchat/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= libproxy.so:net/libproxy \
RUN_DEPENDS= ${LOCALBASE}/share/xml/iso-codes/iso_639.xml:misc/iso-codes
USES= compiler:c++11-lang desktop-file-utils gettext-tools gnome \
- libtool meson ninja pkgconfig python:3.5+ shebangfix ssl
+ libtool meson ninja pkgconfig python:3.5+ shebangfix ssl xorg
USE_GNOME= cairo gtk20 intltool libxml2
USE_XORG= x11
USE_GITHUB= yes
diff --git a/irc/kvirc/Makefile b/irc/kvirc/Makefile
index 14df85f0287f..d5e83ed4ebef 100644
--- a/irc/kvirc/Makefile
+++ b/irc/kvirc/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libaudiofile.so:audio/libaudiofile \
libenchant.so:textproc/enchant
USES= cmake compiler:c++11-lang cpe desktop-file-utils gettext gnome \
- kde:5 perl5 pkgconfig python:2.7 qt:5 ssl tar:bzip2
+ kde:5 perl5 pkgconfig python:2.7 qt:5 ssl tar:bzip2 xorg
USE_GNOME= glib20
USE_PERL5= build
USE_KDE= auth codecs config configwidgets coreaddons i18n notifications \
diff --git a/irc/quirc/Makefile b/irc/quirc/Makefile
index f5c9d7d2b4bc..5a26c1914673 100644
--- a/irc/quirc/Makefile
+++ b/irc/quirc/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
OPTIONS_DEFINE= DOCS
-USES= tk
+USES= tk xorg
USE_XORG= xt
GNU_CONFIGURE= yes