aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2018-09-03 21:12:27 +0800
committerswills <swills@FreeBSD.org>2018-09-03 21:12:27 +0800
commitd9d8a3c60e9213fcb6478c89f404977123303e7a (patch)
tree3e29f2d4e66b119dadcc7b0e38c5e13bb539fd45 /irc
parent17ae520e0fd09c89986fda2c4accfd3b7e734594 (diff)
downloadfreebsd-ports-gnome-d9d8a3c60e9213fcb6478c89f404977123303e7a.tar.gz
freebsd-ports-gnome-d9d8a3c60e9213fcb6478c89f404977123303e7a.tar.zst
freebsd-ports-gnome-d9d8a3c60e9213fcb6478c89f404977123303e7a.zip
irc/hexchat: update to 2.14.2
PR: 231061 Submitted by: Piotr Kubaj <pkubaj@anongoth.pl> (maintainer)
Diffstat (limited to 'irc')
-rw-r--r--irc/hexchat/Makefile10
-rw-r--r--irc/hexchat/distinfo6
-rw-r--r--irc/hexchat/files/patch-meson__options.txt6
-rw-r--r--irc/hexchat/files/patch-plugins_perl_meson.build11
-rw-r--r--irc/hexchat/files/patch-src__common__server.c6
5 files changed, 26 insertions, 13 deletions
diff --git a/irc/hexchat/Makefile b/irc/hexchat/Makefile
index 91d2cf9cd2a4..0b714919da80 100644
--- a/irc/hexchat/Makefile
+++ b/irc/hexchat/Makefile
@@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME= hexchat
-PORTVERSION= 2.14.1
+PORTVERSION= 2.14.2
DISTVERSIONPREFIX= v
-PORTREVISION= 1
CATEGORIES= irc gnome ipv6
MAINTAINER= pkubaj@anongoth.pl
@@ -20,8 +19,8 @@ LIB_DEPENDS= libproxy.so:net/libproxy \
libfreetype.so:print/freetype2
RUN_DEPENDS= ${LOCALBASE}/share/xml/iso-codes/iso_639.xml:misc/iso-codes
-USES= meson ninja desktop-file-utils libtool pkgconfig ssl shebangfix \
- gettext-tools
+USES= desktop-file-utils gettext-tools gnome libtool meson ninja \
+ pkgconfig shebangfix ssl
USE_GNOME= cairo gtk20 intltool libxml2
USE_XORG= x11
USE_GITHUB= yes
@@ -78,6 +77,9 @@ SYSINFO_MESON_TRUE= with-sysinfo
post-patch:
@${REINPLACE_CMD} -e 's|%%CA_BUNDLE%%|${CA_BUNDLE}|' \
${WRKSRC}/src/common/server.c
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
+ -e 's|%%PERL_VER%%|${PERL_VER}|g' \
+ ${WRKSRC}/plugins/perl/meson.build
post-install:
${LN} -sf ../share/icons/hicolor/48x48/apps/${PORTNAME}.png \
diff --git a/irc/hexchat/distinfo b/irc/hexchat/distinfo
index ced655b22c21..396f672fbed3 100644
--- a/irc/hexchat/distinfo
+++ b/irc/hexchat/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1521168316
-SHA256 (hexchat-hexchat-v2.14.1_GH0.tar.gz) = fcf96f54720f5284b8ac52964e7a5e406893069fc332535afa724f7d7d6a6a81
-SIZE (hexchat-hexchat-v2.14.1_GH0.tar.gz) = 2748286
+TIMESTAMP = 1535716329
+SHA256 (hexchat-hexchat-v2.14.2_GH0.tar.gz) = 4f2c2137020913513ea559f788c41039ca6230764d8158862d5d1ee8785592d9
+SIZE (hexchat-hexchat-v2.14.2_GH0.tar.gz) = 2759172
diff --git a/irc/hexchat/files/patch-meson__options.txt b/irc/hexchat/files/patch-meson__options.txt
index 149484c439ff..57ce5e49daf4 100644
--- a/irc/hexchat/files/patch-meson__options.txt
+++ b/irc/hexchat/files/patch-meson__options.txt
@@ -1,6 +1,6 @@
---- meson_options.txt.orig 2018-03-14 02:26:31 UTC
+--- meson_options.txt.orig 2018-08-29 16:41:08 UTC
+++ meson_options.txt
-@@ -39,7 +39,7 @@ option('with-exec', type: 'boolean',
+@@ -42,7 +42,7 @@ option('with-exec', type: 'boolean',
option('with-fishlim', type: 'boolean',
description: 'Fish encryption plugin, requires openssl'
)
@@ -8,4 +8,4 @@
+option('with-lua', type: 'string',
description: 'Lua scripting plugin, value is pkg-config name to use or "false"'
)
- option('with-perl', type: 'boolean',
+ option('with-perl', type: 'string', value: 'perl',
diff --git a/irc/hexchat/files/patch-plugins_perl_meson.build b/irc/hexchat/files/patch-plugins_perl_meson.build
new file mode 100644
index 000000000000..e48911a5ffc5
--- /dev/null
+++ b/irc/hexchat/files/patch-plugins_perl_meson.build
@@ -0,0 +1,11 @@
+--- plugins/perl/meson.build.orig 2018-08-29 16:41:08 UTC
++++ plugins/perl/meson.build
+@@ -60,7 +60,7 @@ endforeach
+ perl_cflags += [
+ # Perl has its own 'config.h' that we must override
+ # TODO: Just rename ours to something more unique.
+- '-include', meson.build_root() + '/config.h'
++ '-include', meson.build_root() + '/config.h', '-I%%PREFIX%%/lib/perl5/%%PERL_VER%%/mach/CORE', '-L%%PREFIX%%/lib/perl5/%%PERL_VER%%/mach/CORE', '-lperl'
+ ]
+
+ if not cc.links('''
diff --git a/irc/hexchat/files/patch-src__common__server.c b/irc/hexchat/files/patch-src__common__server.c
index 3318f9b64aeb..fd3fd906f47e 100644
--- a/irc/hexchat/files/patch-src__common__server.c
+++ b/irc/hexchat/files/patch-src__common__server.c
@@ -1,9 +1,9 @@
---- src/common/server.c.orig 2018-03-14 02:26:31 UTC
+--- src/common/server.c.orig 2018-08-29 16:41:08 UTC
+++ src/common/server.c
-@@ -749,7 +749,7 @@ server_connect_success (server *serv)
+@@ -748,7 +748,7 @@ server_connect_success (server *serv)
+
/* it'll be a memory leak, if connection isn't terminated by
server_cleanup() */
- serv->ssl = _SSL_socket (serv->ctx, serv->sok);
- if ((err = _SSL_set_verify (serv->ctx, ssl_cb_verify, NULL)))
+ if ((err = _SSL_set_verify (serv->ctx, ssl_cb_verify, "%%CA_BUNDLE%%")))
{