aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/ddskk/Makefile
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2011-06-01 16:15:27 +0800
committerwen <wen@FreeBSD.org>2011-06-01 16:15:27 +0800
commit6e19644df526b677d849042f021b61ebf58ad44c (patch)
tree16a20e3917369a6d71b31cecde65bd718f647f56 /japanese/ddskk/Makefile
parent257e44c9c9d23d46c66e01d0a371f5cf5d9647b1 (diff)
downloadfreebsd-ports-gnome-6e19644df526b677d849042f021b61ebf58ad44c.tar.gz
freebsd-ports-gnome-6e19644df526b677d849042f021b61ebf58ad44c.tar.zst
freebsd-ports-gnome-6e19644df526b677d849042f021b61ebf58ad44c.zip
- Update to 14.2
- Make PREFIX-safe - Unbreak - Pass maintainership to submitter PR: ports/157419 Submitted by: Hiroto Kagotani <hiroto.kagotani@gmail.com>
Diffstat (limited to 'japanese/ddskk/Makefile')
-rw-r--r--japanese/ddskk/Makefile26
1 files changed, 6 insertions, 20 deletions
diff --git a/japanese/ddskk/Makefile b/japanese/ddskk/Makefile
index 67b685930d6f..c06673923977 100644
--- a/japanese/ddskk/Makefile
+++ b/japanese/ddskk/Makefile
@@ -6,38 +6,20 @@
#
PORTNAME= ddskk
-PORTVERSION= 13.1
-PORTREVISION= 5
+PORTVERSION= 14.2
CATEGORIES= japanese elisp
MASTER_SITES= http://openlab.ring.gr.jp/skk/maintrunk/ \
ftp://ftp.ring.gr.jp/pub/elisp/skk/maintrunk/ \
http://www.ring.gr.jp/archives/elisp/skk/maintrunk/
PKGNAMESUFFIX= -${EMACS_PORT_NAME}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= hiroto.kagotani@gmail.com
COMMENT= Simple Kana to Kanji conversion program on Emacsen
-BROKEN= Does not fetch
-
USE_EMACS= yes
.include <bsd.port.pre.mk>
-.if defined(EMACS_PORT_NAME)
-.if (${EMACS_PORT_NAME} == "emacs23")
-DEPPORT_SUFFIX=
-.else
-DEPPORT_SUFFIX= -${EMACS_PORT_NAME}
-.endif
-BUILD_DEPENDS= ${LOCALBASE}/${EMACS_VERSION_SITE_LISPDIR}/emu/emu.el:${PORTSDIR}/editors/apel${DEPPORT_SUFFIX}
-RUN_DEPENDS= ${BUILD_DEPENDS}
-.else
-.BEGIN:
- @${ECHO} "Error: Bad port."
- @${ECHO} "You must define EMACS_PORT_NAME."
- @${FALSE}
-.endif
-
INFO= skk
SKK_LISPDIR= ${EMACS_VERSION_SITE_LISPDIR}/skk
@@ -47,6 +29,10 @@ SKK_EXAMPLES= etc/Emacs.ad etc/dot.emacs etc/dot.skk
ALL_TARGET= elc info
MAKE_ARGS+= SKK_LISPDIR=${PREFIX}/${SKK_LISPDIR}
+pre-install:
+ # required for non-standard PREFIX
+ ${MKDIR} ${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}
+
post-install:
.for i in skk-jisx0213 skk-lookup
${INSTALL_DATA} ${WRKSRC}/${i}.el ${PREFIX}/${SKK_LISPDIR}