aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/eblook
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2015-10-10 22:03:00 +0800
committertijl <tijl@FreeBSD.org>2015-10-10 22:03:00 +0800
commit922a618b417843c8900f4076fc4d95620eefb493 (patch)
tree4ac25229c12e49e974a92ecd82e01b92eea15c00 /japanese/eblook
parent8e2211c86ac31d36abaf0b6dbaadf26adb36f654 (diff)
downloadfreebsd-ports-gnome-922a618b417843c8900f4076fc4d95620eefb493.tar.gz
freebsd-ports-gnome-922a618b417843c8900f4076fc4d95620eefb493.tar.zst
freebsd-ports-gnome-922a618b417843c8900f4076fc4d95620eefb493.zip
Remove iconv(), iconv_open() and iconv_close() symbols from libiconv.
These were FreeBSD specific aliases for libiconv(), libiconv_open() and libiconv_close() that are now also provided by libc which complicates writing configure tests that work correctly when both libc iconv and libiconv are available. Also, because the libiconv iconv.h header redefines iconv* to libiconv* correct use of the header implies that the aliases aren't used. The following ports needed fixes because there was something wrong with the way they tried to detect or use iconv: audio/deadbeef: Remove LIBICONV_PLUG from a source file. It's a compile-time option and should not be set in source code. comms/hidapi: Use standard AM_ICONV configure macro to look for iconv. deskutils/fbreader: Let ports framework deal with LIBICONV_PLUG. deskutils/ljclive: Override configure test for iconv. deskutils/owncloudclient: Add USES=iconv and patch test for iconv. devel/aegis: Bump PORTREVISION because it no longer uses libiconv. devel/libexplain: Add USES=iconv and override test for iconv. devel/sdl20: Override configure test for iconv. emulators/vmw: Replace OSVERSION checks with ICONV_LIB checks and include <iconv.h> instead of <sys/iconv.h>. irc/scrollz: Override configure test for iconv. japanese/chasen-base: Override configure test for iconv and patch configure so it no longer adds -liconv to linker flags just because it happens to be installed. japanses/eb: Patch configure test for iconv. japanses/eblook: Override configure test for iconv. java/jikes: Override configure test for iconv. multimedia/transcode: Bump PORTREVISION because only one plugin links with libiconv now. net/c3270: Override configure test for iconv. net/samba4*: Bump PORTREVISION because it no longer uses libiconv. The configure script will always add -liconv to the linker flags when it happens to be installed which would be wrong but later on binaries are linked with -Wl,--as-needed and the linker discards -liconv because it finds iconv*() functions in libc now and no longer in libiconv. net-mgmt/icinga-*: Remove dependency on iconv. net-mgmt/netxms: Patch configure so it no longer adds -liconv to linker flags just because it happens to be installed. net/asterisk11: Patch configure so it no longer adds -liconv to linker flags just because it happens to be installed. net-p2p/transmission-*: Override configure test for iconv. www/htmlcxx: Override configure test for iconv. www/httrack: Override configure test for iconv. www/xapian-omega: Override configure test for iconv. x11/mrxvt(-devel): Add USES=iconv and override configure test for iconv. x11/x3270: Override configure test for iconv. x11-wm/jwm: Override configure test for iconv. PR: 202838 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'japanese/eblook')
-rw-r--r--japanese/eblook/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/japanese/eblook/Makefile b/japanese/eblook/Makefile
index 27d540bff6ff..e22c667a808e 100644
--- a/japanese/eblook/Makefile
+++ b/japanese/eblook/Makefile
@@ -16,10 +16,10 @@ LICENSE= GPLv2
LIB_DEPENDS= libeb.so:${PORTSDIR}/japanese/eb
USES= iconv
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-eb-conf=${PREFIX}/etc/eb.conf
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-eb-conf=${PREFIX}/etc/eb.conf
CPPFLAGS+= -I${ICONV_PREFIX}/include
-LDFLAGS+= -L${ICONV_PREFIX}/lib ${ICONV_LIB}
+LIBS+= -L${ICONV_PREFIX}/lib ${ICONV_LIB}
INFO= eblook
PLIST_FILES= bin/eblook
@@ -27,10 +27,14 @@ PORTDOCS= AUTHORS COPYING ChangeLog NEWS README
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
+
+.if !empty(ICONV_LIB)
+CONFIGURE_ARGS+=ac_cv_func_iconv=yes
+.endif
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>