aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/groff/Makefile
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>1999-12-26 02:52:40 +0800
committersteve <steve@FreeBSD.org>1999-12-26 02:52:40 +0800
commit95e379eab27ed39d93427ee6b99f8df00bc21682 (patch)
tree3d9c3cb5c8362def9d0cfdcc850a5ccb9b0ac675 /japanese/groff/Makefile
parentf2a27cf7c9511afcecd1c2005fe00d3dd83b2624 (diff)
downloadfreebsd-ports-gnome-95e379eab27ed39d93427ee6b99f8df00bc21682.tar.gz
freebsd-ports-gnome-95e379eab27ed39d93427ee6b99f8df00bc21682.tar.zst
freebsd-ports-gnome-95e379eab27ed39d93427ee6b99f8df00bc21682.zip
o update the base version of GNU groff to 1.11.1
o update PATCH_SITES and PATCH_FILES too o change MAINTAINER to me <okazaki@be.to> (approved by Horikawa-san <horikawa@jp.FreeBSD.ORG>, the director of jpman: FreeBSD Japanese Manual Project) o use MANx and MANCOMPRESSED variable o use PATCH instead of /usr/bin/patch o sort PLIST Most of the work of this fix was done by the force of Kentaro Inagaki <inagaki@tg.rim.or.jp>, thanks! PR: 15682 Submitted by: maintainer
Diffstat (limited to 'japanese/groff/Makefile')
-rw-r--r--japanese/groff/Makefile36
1 files changed, 27 insertions, 9 deletions
diff --git a/japanese/groff/Makefile b/japanese/groff/Makefile
index 7b8c7cbfa682..03c760ad312d 100644
--- a/japanese/groff/Makefile
+++ b/japanese/groff/Makefile
@@ -1,36 +1,54 @@
# New ports collection makefile for: ja-groff
-# Version required: 1.10+0.99
+# Version required: 1.11.1+0.99.1
# Date created: 14 April 1995
# Whom: Nobuhiro Yasutomi <nobu@psrc.isac.co.jp>
#
# $FreeBSD$
#
-DISTNAME= groff-1.10
-PKGNAME= ja-groff-0.99
+DISTNAME= groff-1.11.1
+PKGNAME= ja-groff-0.99.1.1
CATEGORIES= japanese print
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= groff
-PATCH_SITES= ftp://ftp.ae.keio.ac.jp/pub/GNU/ \
- ftp://ftp.tohoku.ac.jp/pub/GNU/japanese/
-PATCHFILES= jgroff-0.99.diff.gz
+PATCH_SITES= ${MASTER_SITE_PORTS_JP} \
+ http://www.tg.rim.or.jp/~inagaki/
+PATCHFILES= jgroff-0.99.1.diff.gz jgroff-0.99.1-0.99.1.1.diff.gz
PATCH_DIST_STRIP= -p1
-MAINTAINER= graphite@jp.freebsd.org
+MAINTAINER= okazaki@be.to
USE_GMAKE= yes
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --program-prefix=g
+CONFIGURE_ENV= INSTALL="${INSTALL}" \
+ INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
+ INSTALL_SCRIPT="${INSTALL_SCRIPT}" \
+ INSTALL_DATA="${INSTALL_DATA}" INSTALL_MAN="${INSTALL_MAN}"
+
DESCS= ${WRKSRC}/devnippon/DESC.proto ${WRKSRC}/devps/DESC.in
+MAN1= groff.1 gtroff.1 gtbl.1 gpic.1 geqn.1 grops.1 grotty.1 \
+ grodvi.1 tfmtodit.1 grolj4.1 hpftodit.1 grefer.1 glookbib.1 \
+ gindxbib.1 lkbib.1 gsoelim.1 addftinfo.1 pfbtops.1 psbb.1 \
+ afmtodit.1 grog.1 gnroff.1
+MAN5= groff_font.5 groff_out.5
+MAN7= me.7 msafer.7 groff_char.7 groff_mm.7 groff_mmse.7 groff_ms.7
+MANCOMPRESSED= yes
+
+post-extract:
+ @${RM} ${WRKSRC}/config.cache
+ @${RM} ${WRKSRC}/config.log
+
#for not writing "/usr/local" explicitly in the patch
post-patch:
@for f in ${DESCS}; do \
${MV} -f $${f} $${f}.tmp; \
${SED} -e '$$d' $${f}.tmp > $${f}; \
case $${f} in \
- */devnippon/*) \
+ */devnippon/*) \
${ECHO} "postpro ${PREFIX}/bin/grotty" >> $${f}; \
;; \
*/devps/*) \
@@ -56,6 +74,6 @@ post-install:
@${CP} -p /usr/share/tmac/troffrc ${PREFIX}/share/groff/tmac
@${CP} -p /usr/share/tmac/mdoc/doc-common ${PREFIX}/share/groff/tmac/mdoc
@${CP} -p /usr/share/tmac/mdoc/doc-syms ${PREFIX}/share/groff/tmac/mdoc
- @/usr/bin/patch -d ${PREFIX}/share/groff/tmac < ${FILESDIR}/rc.diff
+ @${PATCH} -d ${PREFIX}/share/groff/tmac < ${FILESDIR}/rc.diff
.include <bsd.port.post.mk>