aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/jd
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2015-04-15 16:20:27 +0800
committerTijl Coosemans <tijl@FreeBSD.org>2015-04-15 16:20:27 +0800
commit074ea5282a00d556c73d86231bec5444990597dc (patch)
treeeec3d608e84e79f0187985e5a1e29cd4f04f13eb /japanese/jd
parent522c152d1c7b0c92982e310110fa6d59f915ffeb (diff)
downloadfreebsd-ports-gnome-074ea5282a00d556c73d86231bec5444990597dc.tar.gz
freebsd-ports-gnome-074ea5282a00d556c73d86231bec5444990597dc.tar.zst
freebsd-ports-gnome-074ea5282a00d556c73d86231bec5444990597dc.zip
converters/libiconv:
- Remove const qualifier from iconv(3) to match POSIX: http://pubs.opengroup.org/onlinepubs/9699919799/functions/iconv.html - Patch iconv.h to expose more GNU extensions when LIBICONV_PLUG is defined because the base system iconv supports these extensions too. Add/remove patches to/from ports to call iconv with non-const arguments. This breaks some ports on FreeBSD 10 because base system iconv.h still has the const qualifier. Fix this by letting USES=iconv add a build dependency on converters/libiconv so ports can use its iconv.h (with LIBICONV_PLUG defined) instead of the base system iconv.h. This exposed some ports that link with libiconv when it is available instead of using libc iconv. In these cases one of the following changes has been made: - patch configure scripts to test for libc iconv first - add ac_cv_lib_iconv_libiconv=no or similar to CONFIGURE_ARGS to disable some configure tests - converters/wkhtmltopdf: this includes Qt4 so add a patch from devel/qt4 - lang/gcc5-aux: respect CFLAGS and friends during configure such that LIBICONV_PLUG is defined in the iconv test, also switch to external gettext - mail/gnarwl: replace patches with CPPFLAGS/LIBS - multimedia/ffmpeg2theora: remove iconv test from SConstruct and use ICONV_LIB in port Makefile instead, also fix a bug in subtitles.c - net-im/licq: finish conversion to cmake - net-mgmt/bandwidthd, net-mgmt/icinga, net-mgmt/nagios, net-mgmt/nagios4: don't need iconv - textproc/p5-XML-TinyXML: finish conversion to USES=perl5 Other changes: - databases/qdbm and slaves: respect CFLAGS and friends, also enable bzip2 and lzo support - games/ldmud: respect CFLAGS and friends - graphics/inventor: replace some patches with MAKE_ARGS/MAKE_ENV to respect CFLAGS and friends, also remove FreeBSD/alpha patch and add missing xorg dependencies PR: 199099 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'japanese/jd')
-rw-r--r--japanese/jd/Makefile4
-rw-r--r--japanese/jd/files/patch-configure.ac11
2 files changed, 13 insertions, 2 deletions
diff --git a/japanese/jd/Makefile b/japanese/jd/Makefile
index 8a75986ca276..eba692ac68cc 100644
--- a/japanese/jd/Makefile
+++ b/japanese/jd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= jd
PORTVERSION= 2.8.8
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= japanese www
MASTER_SITES= SFJP
MASTER_SITE_SUBDIR= jd4linux/61281
@@ -18,7 +18,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libgnutls.so:${PORTSDIR}/security/gnutls \
libgcrypt.so:${PORTSDIR}/security/libgcrypt
-USES= autoreconf iconv libtool tar:tgz
+USES= autoreconf iconv:translit libtool tar:tgz
USE_GNOME= gtk20 gtkmm24 libgnomeui
GNU_CONFIGURE= yes
diff --git a/japanese/jd/files/patch-configure.ac b/japanese/jd/files/patch-configure.ac
new file mode 100644
index 000000000000..ba33e83222ef
--- /dev/null
+++ b/japanese/jd/files/patch-configure.ac
@@ -0,0 +1,11 @@
+--- configure.ac.orig 2013-02-10 11:38:45 UTC
++++ configure.ac
+@@ -30,7 +30,7 @@ dnl
+ case "${host_os}" in
+ freebsd*)
+ echo "os = freebsd"
+- AC_DEFINE(ICONV_CONST, const, "iconv_const")
++ AC_DEFINE(ICONV_CONST, , "iconv_const")
+ AC_DEFINE(USE_MKTIME, , "use mktime")
+ ;;
+ solaris*)