aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/mule-wnn6
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1994-12-23 14:56:00 +0800
committerasami <asami@FreeBSD.org>1994-12-23 14:56:00 +0800
commit138c6dfc143c7d5645b1f24b026757cfd7bc7546 (patch)
tree727d1c0aff130995a84b435637fc780ac1f35759 /japanese/mule-wnn6
parent0e72246c963c5d59849c9a0aab0313edf1d80608 (diff)
downloadfreebsd-ports-gnome-138c6dfc143c7d5645b1f24b026757cfd7bc7546.tar.gz
freebsd-ports-gnome-138c6dfc143c7d5645b1f24b026757cfd7bc7546.tar.zst
freebsd-ports-gnome-138c6dfc143c7d5645b1f24b026757cfd7bc7546.zip
Fetch patch file into $DISTDIR directly instead of current dir.
Diffstat (limited to 'japanese/mule-wnn6')
-rw-r--r--japanese/mule-wnn6/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/japanese/mule-wnn6/Makefile b/japanese/mule-wnn6/Makefile
index 3dec4421b1f9..9110db049aa5 100644
--- a/japanese/mule-wnn6/Makefile
+++ b/japanese/mule-wnn6/Makefile
@@ -3,7 +3,7 @@
# Date created: 22 November 1994
# Whom: Satoshi Asami (asami)
#
-# $Id: Makefile,v 1.3 1994/11/26 23:07:02 ats Exp $
+# $Id: Makefile,v 1.4 1994/11/27 03:40:09 asami Exp $
#
DISTNAME= mule-2.1
@@ -27,13 +27,13 @@ PREBUILD_COOKIE= ${.CURDIR}/work/.prebuild_done
pre-fetch:
@if [ ! -d ${DISTDIR} ]; then mkdir -p ${DISTDIR}; fi
- @for file in ${PATCHFILES}; do \
- if [ ! -f ${DISTDIR}/$$file ]; then \
+ @(cd ${DISTDIR}; \
+ for file in ${PATCHFILES}; do \
+ if [ ! -f $$file ]; then \
echo ">> Fetching patch $$file from remote site..."; \
- ${NCFTP} ${NCFTPFLAGS} ${PATCHSITE}$$file \
- && mv $$file ${DISTDIR}; \
+ ${NCFTP} ${NCFTPFLAGS} ${PATCHSITE}$$file; \
fi \
- done
+ done)
pre-patch: ${PREPATCH_COOKIE}