aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/wordpress
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2014-04-27 02:16:30 +0800
committersunpoet <sunpoet@FreeBSD.org>2014-04-27 02:16:30 +0800
commit4322755df41220db501ff3b0ae61155c02c78b4b (patch)
treeec6e738762a146abbd5ff4f1af34fe6dfe92014b /japanese/wordpress
parentcc313d6b427d32d980f09575bc3adb8b116f7747 (diff)
downloadfreebsd-ports-gnome-4322755df41220db501ff3b0ae61155c02c78b4b.tar.gz
freebsd-ports-gnome-4322755df41220db501ff3b0ae61155c02c78b4b.tar.zst
freebsd-ports-gnome-4322755df41220db501ff3b0ae61155c02c78b4b.zip
- Update to 3.9
- Pass maintainership to submitter - While I'm here: - Allow packaging as user - Remove .include <bsd.port.options.mk> Changes: http://ja.wordpress.org/2014/04/17/wordpress-3-9-ja/ PR: ports/189017 Submitted by: Joe Horn <joehorn@gmail.com>
Diffstat (limited to 'japanese/wordpress')
-rw-r--r--japanese/wordpress/Makefile35
-rw-r--r--japanese/wordpress/distinfo4
-rw-r--r--japanese/wordpress/files/pkg-install.in12
3 files changed, 16 insertions, 35 deletions
diff --git a/japanese/wordpress/Makefile b/japanese/wordpress/Makefile
index 0fa3b323c9bc..1e33116a651d 100644
--- a/japanese/wordpress/Makefile
+++ b/japanese/wordpress/Makefile
@@ -2,12 +2,12 @@
# $FreeBSD$
PORTNAME= wordpress
-PORTVERSION= 3.8.1
+PORTVERSION= 3.9
CATEGORIES= japanese www
MASTER_SITES= http://ja.wordpress.org/
DISTNAME= ${PORTNAME}-${PORTVERSION}-ja
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= joehorn@gmail.com
COMMENT= State-of-the-art semantic personal publishing platform
LICENSE= GPLv2
@@ -19,39 +19,32 @@ USE_PHP= curl gd mysql pcre tokenizer xml zip
WANT_PHP_WEB= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
-SUB_FILES= pkg-message pkg-install
-SUB_LIST= CHGRP="${CHGRP}" CHOWN="${CHOWN}" CHMOD="${CHMOD}"\
- FIND="${FIND}" WWWGRP="${WWWGRP}" WWWOWN="${WWWOWN}"
+SUB_FILES= pkg-message
PLIST= ${WRKDIR}/pkg-plist
PORTDOCS= license.txt readme.html
OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
pre-everything::
@${ECHO_CMD} "If you want to upgrade, you must read upgrade document."
@${ECHO_CMD} ""
@sleep 1
pre-install:
- cd ${WRKSRC}/ && \
- (${FIND} -s * -type f | ${SED} -e 's|^|%%WWWDIR%%/|'; \
- ${FIND} -d . -type d | ${SED} -e 's|^\.|@dirrm %%WWWDIR%%|') > ${PLIST}
+ ${ECHO_CMD} '@owner www' > ${PLIST}
+ ${ECHO_CMD} '@group www' >> ${PLIST}
+ cd ${WRKSRC}/ && ${FIND} -s * -type f | ${SED} -e 's|^|%%WWWDIR%%/|' >> ${PLIST}
+ cd ${WRKSRC}/ && ${FIND} -d . -type d | ${SED} -e 's|^\.|@dirrm %%WWWDIR%%|' >> ${PLIST}
+ ${ECHO_CMD} '@owner' >> ${PLIST}
+ ${ECHO_CMD} '@group' >> ${PLIST}
if [ ! -f ${WRKSRC}/wp-config-sample.php ]; then ${CP} \
${WRKSRC}/wp-config.php.sample ${WRKSRC}/wp-config.php; fi
do-install:
- ${INSTALL} -d -g ${WWWGRP} -m 755 -o ${WWWOWN} ${WWWDIR}/
- ${CP} -R ${WRKSRC}/ ${WWWDIR}/
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}/
- cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
-.endif
-
-post-install:
- @${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
- @${CAT} ${PKGMESSAGE}
+ ${INSTALL} -d -m 755 ${STAGEDIR}${WWWDIR}/
+ ${CP} -R ${WRKSRC}/ ${STAGEDIR}${WWWDIR}/
+ ${FIND} ${STAGEDIR}${WWWDIR}/ -type d -exec ${CHMOD} g+w '{}' \;
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}/
+ cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}/
.include <bsd.port.mk>
diff --git a/japanese/wordpress/distinfo b/japanese/wordpress/distinfo
index ebdc8431b5c8..3a9cac945bcf 100644
--- a/japanese/wordpress/distinfo
+++ b/japanese/wordpress/distinfo
@@ -1,2 +1,2 @@
-SHA256 (wordpress-3.8.1-ja.tar.gz) = 5a5598c7da4de1ee1a8a4aea92b10f0de5f4c738a54d51312f9fec0ec32ebf83
-SIZE (wordpress-3.8.1-ja.tar.gz) = 6315056
+SHA256 (wordpress-3.9-ja.tar.gz) = 173d4399a468e0229e27c46d89b7628c103d6cab5066c44103c7f76f1ed15c30
+SIZE (wordpress-3.9-ja.tar.gz) = 6250676
diff --git a/japanese/wordpress/files/pkg-install.in b/japanese/wordpress/files/pkg-install.in
deleted file mode 100644
index 93fe0df35ab8..000000000000
--- a/japanese/wordpress/files/pkg-install.in
+++ /dev/null
@@ -1,12 +0,0 @@
-#!/bin/sh
-case $2 in
- PRE-INSTALL)
- ;;
- POST-INSTALL)
- %%CHOWN%% -R %%WWWOWN%% %%WWWDIR%%/wp-content
- %%FIND%% %%WWWDIR%% -type d -print | xargs %%CHGRP%% %%WWWGRP%%
- %%FIND%% %%WWWDIR%% -type d -print | xargs %%CHMOD%% g+w
- ;;
- *)
- ;;
-esac