aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/xpdf/Makefile
diff options
context:
space:
mode:
authormita <mita@FreeBSD.org>2002-05-03 17:48:25 +0800
committermita <mita@FreeBSD.org>2002-05-03 17:48:25 +0800
commit4de1facb49de6495097e7f3991f0fcbe9451e918 (patch)
treee989302cb41c0036efc6b26d9397285762e71890 /japanese/xpdf/Makefile
parent59234d58625204f744a2f07701b55f1bf2f1a6c3 (diff)
downloadfreebsd-ports-gnome-4de1facb49de6495097e7f3991f0fcbe9451e918.tar.gz
freebsd-ports-gnome-4de1facb49de6495097e7f3991f0fcbe9451e918.tar.zst
freebsd-ports-gnome-4de1facb49de6495097e7f3991f0fcbe9451e918.zip
The port adds configuration files necessary to read japanese PDFs by xpdf.
Uses print/adobe-cmaps port. Submitted by: mita [ports-jp 12657]
Diffstat (limited to 'japanese/xpdf/Makefile')
-rw-r--r--japanese/xpdf/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/japanese/xpdf/Makefile b/japanese/xpdf/Makefile
new file mode 100644
index 000000000000..e4451b2121d1
--- /dev/null
+++ b/japanese/xpdf/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: ja-xpdf
+# Date created: 21 Avr 2002
+# Whom: MITA Yoshio <mita@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xpdf
+PORTVERSION= 1.00
+CATEGORIES= japanese
+MASTER_SITES= ftp://ftp.foolabs.com/pub/xpdf/
+DISTNAME= xpdf-japanese
+
+MAINTAINER= mita@FreeBSD.org
+
+RUN_DEPENDS= xpdf:${PORTSDIR}/graphics/xpdf\
+ ${LOCALBASE}/share/ghostscript/Resource/CMap/Adobe-Japan1-0:${PORTSDIR}/print/adobe-cmaps\
+ ${PKG_DBDIR}/ja-alias-fonts-1.0:${PORTSDIR}/japanese/alias-fonts
+
+NO_BUILD= yes
+USE_X_PREFIX= yes
+INSTALL_FILES= Adobe-Japan1.cidToUnicode ISO-2022-JP.unicodeMap \
+ EUC-JP.unicodeMap Shift-JIS.unicodeMap \
+ README
+do-install:
+ ${MKDIR} ${PREFIX}/share/xpdf/japanese
+.for i in ${INSTALL_FILES}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${PREFIX}/share/xpdf/japanese
+.endfor
+ ${INSTALL_DATA} ${FILESDIR}/dot.xpdfrc ${PREFIX}/share/xpdf/japanese
+ ${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+
+.include <bsd.port.mk>