aboutsummaryrefslogtreecommitdiffstats
path: root/japanese
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2005-11-13 19:23:30 +0800
committernork <nork@FreeBSD.org>2005-11-13 19:23:30 +0800
commit0ce1adf2564ca9e5267a6e0ffe72e5f1b3e38c4d (patch)
tree7454b4a10aec7e8d2cc8556eb5aca003afa73eab /japanese
parent07a499bf855bfd9f893f0112bcfdeacb1ec056dd (diff)
downloadfreebsd-ports-gnome-0ce1adf2564ca9e5267a6e0ffe72e5f1b3e38c4d.tar.gz
freebsd-ports-gnome-0ce1adf2564ca9e5267a6e0ffe72e5f1b3e38c4d.tar.zst
freebsd-ports-gnome-0ce1adf2564ca9e5267a6e0ffe72e5f1b3e38c4d.zip
Chase dependency on ja-p5-Jcode.
I don't bump PORTREVISION. Because dependency on ja-p5-Jcode is correct, only path isn't correct. This is build phase issue.
Diffstat (limited to 'japanese')
-rw-r--r--japanese/eijiro-fpw/Makefile9
-rw-r--r--japanese/kcode/Makefile2
-rw-r--r--japanese/mypaedia-fpw/Makefile12
-rw-r--r--japanese/otojiro-fpw/Makefile9
-rw-r--r--japanese/srd-fpw/Makefile12
-rw-r--r--japanese/waeijiro-fpw/Makefile9
6 files changed, 46 insertions, 7 deletions
diff --git a/japanese/eijiro-fpw/Makefile b/japanese/eijiro-fpw/Makefile
index fb35842a3f47..c22b2c45381f 100644
--- a/japanese/eijiro-fpw/Makefile
+++ b/japanese/eijiro-fpw/Makefile
@@ -17,7 +17,7 @@ COMMENT= EIJIRO English - Japanese Dictionary (EPWING V1 format)
EXTRACT_DEPENDS=${LOCALBASE}/share/freepwing/fpwutils.mk:${PORTSDIR}/japanese/freepwing
BUILD_DEPENDS= ${LOCALBASE}/libexec/freepwing/catdump:${PORTSDIR}/japanese/freepwing \
- ${SITE_PERL}/${PERL_ARCH}/Jcode.pm:${PORTSDIR}/japanese/p5-Jcode
+ ${JCODE}:${PORTSDIR}/japanese/p5-Jcode
RESTRICTED= "The original dictionary is not free"
NO_PACKAGE= "The original dictionary is not free"
@@ -29,6 +29,13 @@ SRCFILE?= eijiro52.txt
# For eijiro included in a book sold by ALC Inc.
# (http://www.alc.co.jp/alcshop/eng/eijiro/)
.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500801
+JCODE= ${SITE_PERL}/${PERL_ARCH}/Jcode.pm
+.else
+JCODE= ${SITE_PERL}/Jcode.pm
+.endif
+
DICT_ARCHIVE!= ${ECHO_CMD} ${DICT_PATH}/eijiro-original/*.exe || ${TRUE}
.if exists(${DICT_ARCHIVE})
EXTRACT_DEPENDS+= lha:${PORTSDIR}/archivers/lha
diff --git a/japanese/kcode/Makefile b/japanese/kcode/Makefile
index 84c6219d2a07..612b6528f699 100644
--- a/japanese/kcode/Makefile
+++ b/japanese/kcode/Makefile
@@ -32,6 +32,8 @@ MANCOMPRESSED= no
IGNORE= This port requires perl 5.6.0 or later
.elif ${PERL_LEVEL} < 500800
_RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Jcode.pm:${PORTSDIR}/japanese/p5-Jcode
+else
+_RUN_DEPENDS= ${SITE_PERL}/Jcode.pm:${PORTSDIR}/japanese/p5-Jcode
.endif
do-extract:
diff --git a/japanese/mypaedia-fpw/Makefile b/japanese/mypaedia-fpw/Makefile
index 50e45af07e96..7ca91d3b1fe2 100644
--- a/japanese/mypaedia-fpw/Makefile
+++ b/japanese/mypaedia-fpw/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= An encyclopedia "Mypaedia" (EPWING V1 format)
BUILD_DEPENDS= fpwmake:${PORTSDIR}/japanese/freepwing \
- ${SITE_PERL}/${PERL_ARCH}/Jcode.pm:${PORTSDIR}/japanese/p5-Jcode
+ ${JCODE}:${PORTSDIR}/japanese/p5-Jcode
IS_INTERACTIVE= YES
RESTRICTED= "The original dictionary is not free"
@@ -55,4 +55,12 @@ do-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500801
+JCODE= ${SITE_PERL}/${PERL_ARCH}/Jcode.pm
+.else
+JCODE= ${SITE_PERL}/Jcode.pm
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/japanese/otojiro-fpw/Makefile b/japanese/otojiro-fpw/Makefile
index 93303b4dd3fc..f05c86c3dd00 100644
--- a/japanese/otojiro-fpw/Makefile
+++ b/japanese/otojiro-fpw/Makefile
@@ -18,7 +18,7 @@ COMMENT= OTOJIRO English - Japanese Dictionary (EPWING V1 format)
EXTRACT_DEPENDS=${LOCALBASE}/share/freepwing/fpwutils.mk:${PORTSDIR}/japanese/freepwing
BUILD_DEPENDS= ${LOCALBASE}/libexec/freepwing/catdump:${PORTSDIR}/japanese/freepwing \
- ${SITE_PERL}/${PERL_ARCH}/Jcode.pm:${PORTSDIR}/japanese/p5-Jcode
+ ${JCODE}:${PORTSDIR}/japanese/p5-Jcode
RESTRICTED= "The original dictionary is not free"
NO_PACKAGE= "The original dictionary is not free"
@@ -31,6 +31,13 @@ SRCFILE?= otojiro.txt
# For eijiro included in a book sold by ALC Inc.
# (http://www.alc.co.jp/alcshop/eng/eijiro/)
.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500801
+JCODE= ${SITE_PERL}/${PERL_ARCH}/Jcode.pm
+.else
+JCODE= ${SITE_PERL}/Jcode.pm
+.endif
+
DICT_ARCHIVE!= ${ECHO_CMD} ${DICT_PATH}/eijiro-original/*.exe || ${TRUE}
.if exists(${DICT_ARCHIVE})
EXTRACT_DEPENDS+= lha:${PORTSDIR}/archivers/lha
diff --git a/japanese/srd-fpw/Makefile b/japanese/srd-fpw/Makefile
index 8ba4d468a858..9ef4313fe34f 100644
--- a/japanese/srd-fpw/Makefile
+++ b/japanese/srd-fpw/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A English - Japanese Dictionary "Random House" (EPWING V1 format)
BUILD_DEPENDS= fpwmake:${PORTSDIR}/japanese/freepwing \
- ${SITE_PERL}/${PERL_ARCH}/Jcode.pm:${PORTSDIR}/japanese/p5-Jcode
+ ${JCODE}:${PORTSDIR}/japanese/p5-Jcode
IS_INTERACTIVE= YES
RESTRICTED= "The original dictionary is not free"
@@ -59,4 +59,12 @@ do-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500801
+JCODE= ${SITE_PERL}/${PERL_ARCH}/Jcode.pm
+.else
+JCODE= ${SITE_PERL}/Jcode.pm
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/japanese/waeijiro-fpw/Makefile b/japanese/waeijiro-fpw/Makefile
index 91159a5d684a..1994b70fa7e6 100644
--- a/japanese/waeijiro-fpw/Makefile
+++ b/japanese/waeijiro-fpw/Makefile
@@ -18,7 +18,7 @@ COMMENT= WAEIJIRO English - Japanese Dictionary (EPWING V1 format)
EXTRACT_DEPENDS=${LOCALBASE}/share/freepwing/fpwutils.mk:${PORTSDIR}/japanese/freepwing
BUILD_DEPENDS= ${LOCALBASE}/libexec/freepwing/catdump:${PORTSDIR}/japanese/freepwing \
- ${SITE_PERL}/${PERL_ARCH}/Jcode.pm:${PORTSDIR}/japanese/p5-Jcode
+ ${JCODE}:${PORTSDIR}/japanese/p5-Jcode
RESTRICTED= "The original dictionary is not free"
NO_PACKAGE= "The original dictionary is not free"
@@ -29,6 +29,13 @@ SRCFILE?= waeiji52.txt
# For eijiro included in a book sold by ALC Inc.
# (http://www.alc.co.jp/alcshop/eng/eijiro/)
.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500801
+JCODE= ${SITE_PERL}/${PERL_ARCH}/Jcode.pm
+.else
+JCODE= ${SITE_PERL}/Jcode.pm
+.endif
+
DICT_ARCHIVE!= ${ECHO_CMD} ${DICT_PATH}/eijiro-original/*.exe || ${TRUE}
.if exists(${DICT_ARCHIVE})
EXTRACT_DEPENDS+= lha:${PORTSDIR}/archivers/lha