aboutsummaryrefslogtreecommitdiffstats
path: root/japanese
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2006-07-03 17:10:27 +0800
committernork <nork@FreeBSD.org>2006-07-03 17:10:27 +0800
commit0e1dc267be6456749da9ccbb99d6ff081f24000c (patch)
tree0bdc03aa15b20188a2107623de9b078a2dc1a83f /japanese
parent03e9bd18d60cf12b2e06a823e71fbe6a0067ef2e (diff)
downloadfreebsd-ports-gnome-0e1dc267be6456749da9ccbb99d6ff081f24000c.tar.gz
freebsd-ports-gnome-0e1dc267be6456749da9ccbb99d6ff081f24000c.tar.zst
freebsd-ports-gnome-0e1dc267be6456749da9ccbb99d6ff081f24000c.zip
Fix build error.
PR: ports/99737 Submitted by: Yoshisato YANAGISAWA <yanagisawa@csg.is.titech.ac.jp> Pointy hat to: myself
Diffstat (limited to 'japanese')
-rw-r--r--japanese/p5-nkf/Makefile2
-rw-r--r--japanese/p5-nkf/files/patch-nkf.c43
2 files changed, 1 insertions, 44 deletions
diff --git a/japanese/p5-nkf/Makefile b/japanese/p5-nkf/Makefile
index 717ba3fd5ae6..309f89d395ac 100644
--- a/japanese/p5-nkf/Makefile
+++ b/japanese/p5-nkf/Makefile
@@ -14,7 +14,7 @@ DESCR= ${.CURDIR}/pkg-descr
PLIST= ${.CURDIR}/pkg-plist
PERL_CONFIGURE= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION:S/.//:S/./-/}/NKF.mod
+WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION:S/.//g}/NKF.mod
PATCHDIR= ${.CURDIR}/files
MAN3= NKF.3
diff --git a/japanese/p5-nkf/files/patch-nkf.c b/japanese/p5-nkf/files/patch-nkf.c
deleted file mode 100644
index fbae08d14d6b..000000000000
--- a/japanese/p5-nkf/files/patch-nkf.c
+++ /dev/null
@@ -1,43 +0,0 @@
---- ../nkf.c.orig Mon Mar 27 21:46:58 2006
-+++ ../nkf.c Sun May 7 22:37:16 2006
-@@ -3323,9 +3323,9 @@
- void (*f)PROTO((int c2,int c1));
- int c;
- {
-+ int shift = 20;
- const char *hex = "0123456789ABCDEF";
- c &= 0x00FFFFFF;
-- int shift = 20;
- while(shift >= 0){
- if(c >= 1<<shift){
- while(shift >= 0){
-@@ -3417,6 +3417,7 @@
- c = unicode_subchar;
- (*oconv)((c>>8)&0xFF, c&0xFF);
- return;
-+#if 0
- int shift = 16;
- while(shift >= 0){
- if(c >= 1<<shift){
-@@ -3429,10 +3430,13 @@
- }
- }
- return;
-+#endif
- }
- #endif
-
- #ifdef UTF8_OUTPUT_ENABLE
-+extern const unsigned short *const x0212_to_utf8_2bytes[];
-+
- int
- e2w_conv(c2, c1)
- int c2, c1;
-@@ -3449,7 +3453,6 @@
- if(ms_ucs_map_f == UCS_MAP_ASCII&& c2 == 0x8F22 && c1 == 0x43){
- return 0xA6;
- }
-- extern const unsigned short *const x0212_to_utf8_2bytes[];
- c2 = (c2&0x7f) - 0x21;
- if (0<=c2 && c2<sizeof_euc_to_utf8_2bytes)
- p = x0212_to_utf8_2bytes[c2];