aboutsummaryrefslogtreecommitdiffstats
path: root/japanese
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2013-12-16 00:22:17 +0800
committerwg <wg@FreeBSD.org>2013-12-16 00:22:17 +0800
commit781e42a27d143c9dd7bb035b0e0230c7c1b12e88 (patch)
tree528f950c491cb30f26166e5e23d4b77ad233a5ee /japanese
parent2a2657433c0cd564b2a2da9e60eb35d412a019f2 (diff)
downloadfreebsd-ports-gnome-781e42a27d143c9dd7bb035b0e0230c7c1b12e88.tar.gz
freebsd-ports-gnome-781e42a27d143c9dd7bb035b0e0230c7c1b12e88.tar.zst
freebsd-ports-gnome-781e42a27d143c9dd7bb035b0e0230c7c1b12e88.zip
Use setuptools for all Python ports.
Setuptools is the preferred method to manage Python distributions after many changes to the packaging ecosystem over the past couple of years. Only ports using USE_PYDISTUTILS= yes are affected by this commit, ports using USE_PYDISTUTILS= easy_install remains the same however this usage is now deprecated and should be converted to USE_PYDISTUTILS= yes. Some Python distributions do not work with setuptools out of the box because they extend the install command from distutils and not setuptools, and so they need to be patched accordingly. pip (which leverages setuptools) works around the issue by using eggs, however we want to get rid of those as well, as support for "flat" installation is unavailable or has other issues associated with it. This work allows us to unify how python packages are built, ensure that Python distributions are installed consistently, reduces complexity for Python port maintainers and paves the way for simplifying the Python ports framework in the future. With hat on: python Reviewed by: koobs, antoine Exp-run: bdrewery Approved by: bdrewery (portmgr)
Diffstat (limited to 'japanese')
-rw-r--r--japanese/tegaki-recognize/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/japanese/tegaki-recognize/Makefile b/japanese/tegaki-recognize/Makefile
index a87166cb15db..5a6bda1fc477 100644
--- a/japanese/tegaki-recognize/Makefile
+++ b/japanese/tegaki-recognize/Makefile
@@ -1,11 +1,6 @@
+# Created by: Timothy Beyer <beyert@cs.ucr.edu>
# $FreeBSD$
-# Date created: 15 Aug 2010
-# Whom: Timothy Beyer <beyert@cs.ucr.edu>
-#
-# $FreeBSD$
-#
-
PORTNAME= tegaki
PORTVERSION= 0.3.1.2
CATEGORIES= japanese python
@@ -18,7 +13,7 @@ COMMENT= Open-Source Chinese and Japanese Handwriting Recognition
LICENSE= GPLv2
-LIB_DEPENDS= zinnia.0:${PORTSDIR}/japanese/zinnia
+LIB_DEPENDS= libzinnia.so:${PORTSDIR}/japanese/zinnia
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/tegakigtk/recognizer.py:${PORTSDIR}/japanese/py-tegaki-gtk
USE_PYTHON= -2.7
@@ -37,4 +32,9 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
+post-patch:
+ @${REINPLACE_CMD} \
+ -e 's,distutils\.command\.install ,setuptools\.command\.install ,' \
+ ${WRKSRC}/setup.py
+
.include <bsd.port.post.mk>