aboutsummaryrefslogtreecommitdiffstats
path: root/japanese
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2008-01-24 15:33:46 +0800
committerclsung <clsung@FreeBSD.org>2008-01-24 15:33:46 +0800
commita4831b5814fe020d8f74fe511959f8ed438b75a5 (patch)
tree16d0d91785ba3c524920b1837b778de8f1e71349 /japanese
parentf71e033f1cc49fc193d13cbdf3ebbec49d999d69 (diff)
downloadfreebsd-ports-gnome-a4831b5814fe020d8f74fe511959f8ed438b75a5.tar.gz
freebsd-ports-gnome-a4831b5814fe020d8f74fe511959f8ed438b75a5.tar.zst
freebsd-ports-gnome-a4831b5814fe020d8f74fe511959f8ed438b75a5.zip
This is a python bindings for MeCab.
WWW: http://mecab.sourceforge.net/ PR: ports/115871 Submitted by: Junji NAKANISHI <jun-g at daemonfreaks.com>
Diffstat (limited to 'japanese')
-rw-r--r--japanese/Makefile1
-rw-r--r--japanese/py-mecab/Makefile28
-rw-r--r--japanese/py-mecab/distinfo3
-rw-r--r--japanese/py-mecab/pkg-descr3
-rw-r--r--japanese/py-mecab/pkg-plist4
5 files changed, 39 insertions, 0 deletions
diff --git a/japanese/Makefile b/japanese/Makefile
index 449fe8fdb349..d79e74098a48 100644
--- a/japanese/Makefile
+++ b/japanese/Makefile
@@ -290,6 +290,7 @@
SUBDIR += prn
SUBDIR += ptex
SUBDIR += py-kanjilib
+ SUBDIR += py-mecab
SUBDIR += pycodec
SUBDIR += pycodec-zope
SUBDIR += qkc
diff --git a/japanese/py-mecab/Makefile b/japanese/py-mecab/Makefile
new file mode 100644
index 000000000000..4ac78a78327b
--- /dev/null
+++ b/japanese/py-mecab/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: py-mecab
+# Date created: 27 August 2007
+# Whom: Junji NAKANISHI <jun-g@daemonfreaks.com>
+#
+# $FreeBSD$
+
+PORTNAME= mecab
+PORTVERSION= 0.96
+CATEGORIES= japanese python textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-python-${PORTVERSION}
+
+MAINTAINER= jun-g@daemonfreaks.com
+COMMENT= Python bindings for MeCab
+
+BUILD_DEPENDS= swig>=1.3:${PORTSDIR}/devel/swig13
+LIB_DEPENDS= mecab.1:${PORTSDIR}/japanese/mecab
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+PYDISTUTILS_EGGINFO= ${PORTNAME}_python-${PKGVERSION}-${PYTHON_VERSION:S/thon//}.egg-info
+
+.include <bsd.port.pre.mk>
+
+PKGNAMEPREFIX:= ${PKGNAMEPREFIX}${PYTHON_PKGNAMEPREFIX}
+
+.include <bsd.port.post.mk>
diff --git a/japanese/py-mecab/distinfo b/japanese/py-mecab/distinfo
new file mode 100644
index 000000000000..e81612593368
--- /dev/null
+++ b/japanese/py-mecab/distinfo
@@ -0,0 +1,3 @@
+MD5 (mecab-python-0.96.tar.gz) = 5faa154aa8a95145d6a58befa42e6c40
+SHA256 (mecab-python-0.96.tar.gz) = afad397d45dd0dcebaffa8a3c8ba85e822113479f8aa61a4b84fb2d9e47fb636
+SIZE (mecab-python-0.96.tar.gz) = 51276
diff --git a/japanese/py-mecab/pkg-descr b/japanese/py-mecab/pkg-descr
new file mode 100644
index 000000000000..4b4d21dde41d
--- /dev/null
+++ b/japanese/py-mecab/pkg-descr
@@ -0,0 +1,3 @@
+This is a python bindings for MeCab.
+
+WWW: http://mecab.sourceforge.net/
diff --git a/japanese/py-mecab/pkg-plist b/japanese/py-mecab/pkg-plist
new file mode 100644
index 000000000000..1773dc2163bf
--- /dev/null
+++ b/japanese/py-mecab/pkg-plist
@@ -0,0 +1,4 @@
+%%PYTHON_SITELIBDIR%%/_MeCab.so
+%%PYTHON_SITELIBDIR%%/MeCab.py
+%%PYTHON_SITELIBDIR%%/MeCab.pyc
+%%PYTHON_SITELIBDIR%%/MeCab.pyo