aboutsummaryrefslogtreecommitdiffstats
path: root/japanese
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-11-30 02:22:32 +0800
committertijl <tijl@FreeBSD.org>2014-11-30 02:22:32 +0800
commitb3a361d8eb7b71f0b468fd98e66a366d09af5fcf (patch)
treedd9cb6760a88c6c8e370786a93ecef5ba96f616c /japanese
parent237bc033e6203c347316781328565cb5a7f8b2cf (diff)
downloadfreebsd-ports-gnome-b3a361d8eb7b71f0b468fd98e66a366d09af5fcf.tar.gz
freebsd-ports-gnome-b3a361d8eb7b71f0b468fd98e66a366d09af5fcf.tar.zst
freebsd-ports-gnome-b3a361d8eb7b71f0b468fd98e66a366d09af5fcf.zip
Split devel/gettext in devel/gettext-runtime and devel/gettext-tools. The
first contains runtime libraries such as libintl and the latter contains developer tools such as msgfmt. Ports that use gettext will usually need a LIB_DEPENDS on gettext-runtime and a BUILD_DEPENDS on gettext-tools. USES=gettext-runtime can be used to set a LIB/BUILD/RUN_DEPENDS on devel/gettext-runtime and USES=gettext-tools can be used to set a BUILD/RUN_DEPENDS on devel/gettext-tools. USES=gettext is now the same as "USES=gettext-runtime gettext-tools" meaning a LIB_DEPENDS on devel/gettext-runtime and a BUILD_DEPENDS on devel/gettext-tools. Update gettext to 0.19.3. Remove :oldver from converters/libiconv and devel/gettext-runtime. Leave symlinks with the old library versions to avoid the need to bump PORTREVISION on a large number of dependent ports. When most of the dependent ports have had normal version updates, PORTREVISION can be bumped on the remaining ones (low number) and the links can be removed. Fix some ports that installed files in lib/locale instead of share/locale. PR: 194038 Reviewed by: bapt Exp-run: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'japanese')
-rw-r--r--japanese/im-ja/Makefile2
-rw-r--r--japanese/mecab/Makefile20
-rw-r--r--japanese/mecab/files/patch-src_Makefile.am10
-rw-r--r--japanese/mecab/pkg-plist2
-rw-r--r--japanese/mozc-server/Makefile2
5 files changed, 13 insertions, 23 deletions
diff --git a/japanese/im-ja/Makefile b/japanese/im-ja/Makefile
index 8294731b9b16..d05473fe2a00 100644
--- a/japanese/im-ja/Makefile
+++ b/japanese/im-ja/Makefile
@@ -16,7 +16,7 @@ ANTHY_DESC= Use Anthy
CANNA_DESC= Use Canna
WNN_DESC= Use FreeWnn
-USES= gmake libtool pathfix perl5 pkgconfig
+USES= gettext gmake libtool pathfix perl5 pkgconfig
USE_GNOME= gconf2 gnomeprefix intlhack libglade2
USE_PERL5= build
GNU_CONFIGURE= yes
diff --git a/japanese/mecab/Makefile b/japanese/mecab/Makefile
index 320da5506ece..abd432c6f869 100644
--- a/japanese/mecab/Makefile
+++ b/japanese/mecab/Makefile
@@ -16,9 +16,7 @@ LICENSE_COMB= multi
GNU_CONFIGURE= yes
CONFIGURE_ARGS= ac_cv_lib_stdcpp_main=no
INSTALL_TARGET= install-strip
-USES= iconv gettext:build libtool perl5
-USE_AUTOTOOLS= autoconf autoheader automake aclocal libtoolize
-AUTOMAKE_ARGS= --add-missing --copy --force
+USES= gettext-tools iconv libtool perl5
USE_PERL5= build
USE_LDCONFIG= yes
@@ -30,18 +28,18 @@ PORTDOCS= AUTHORS README *.html
OPTIONS_DEFINE= DOCS
post-patch:
- ${REINPLACE_CMD} -e 's/-O3/${CFLAGS}/' ${WRKSRC}/${CONFIGURE_SCRIPT}.in
- ${REINPLACE_CMD} -e 's/conf_DATA = mecabrc/conf_DATA = mecabrc.sample/' ${WRKSRC}/Makefile.am
-
-post-configure:
- ${CP} ${WRKSRC}/mecabrc ${WRKSRC}/mecabrc.sample
-
-pre-install:
- ${CHMOD} a+x ${WRKSRC}/install-sh
+ @${REINPLACE_CMD} '/^libmecab_la_LIBADD =/s/$$/ $$(LTLIBICONV)/' \
+ ${WRKSRC}/src/Makefile.in
+ @${REINPLACE_CMD} \
+ -e '/CFLAGS/s|-O3|${CFLAGS}|' \
+ -e '/CXXFLAGS/s|-O3|${CXXFLAGS}|' \
+ ${WRKSRC}/configure
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:N*.html:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/doc/*.html ${STAGEDIR}${DOCSDIR}
+ ${MV} ${STAGEDIR}${PREFIX}/etc/mecabrc \
+ ${STAGEDIR}${PREFIX}/etc/mecabrc.sample
.include <bsd.port.mk>
diff --git a/japanese/mecab/files/patch-src_Makefile.am b/japanese/mecab/files/patch-src_Makefile.am
deleted file mode 100644
index ef6af96278ea..000000000000
--- a/japanese/mecab/files/patch-src_Makefile.am
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/Makefile.am.orig 2013-01-24 14:35:35.000000000 +0900
-+++ src/Makefile.am 2013-04-07 21:39:46.000000000 +0900
-@@ -17,6 +17,7 @@
- feature_index.cpp feature_index.h lbfgs.cpp \
- lbfgs.h learner_tagger.cpp learner_tagger.h learner.cpp \
- learner_node.h libmecab.cpp
-+libmecab_la_LIBADD = $(LTLIBICONV)
-
- include_HEADERS = mecab.h
- bin_PROGRAMS = mecab
diff --git a/japanese/mecab/pkg-plist b/japanese/mecab/pkg-plist
index a7e881113ede..070ad8640b23 100644
--- a/japanese/mecab/pkg-plist
+++ b/japanese/mecab/pkg-plist
@@ -1,5 +1,6 @@
bin/mecab
bin/mecab-config
+@sample etc/mecabrc.sample
include/mecab.h
lib/libmecab.a
lib/libmecab.so
@@ -11,4 +12,3 @@ libexec/mecab/mecab-dict-index
libexec/mecab/mecab-system-eval
libexec/mecab/mecab-test-gen
man/man1/mecab.1.gz
-@sample etc/mecabrc.sample
diff --git a/japanese/mozc-server/Makefile b/japanese/mozc-server/Makefile
index 497cc0989b69..8af49aceb448 100644
--- a/japanese/mozc-server/Makefile
+++ b/japanese/mozc-server/Makefile
@@ -47,6 +47,8 @@ USE_XORG= xcb
USE_GNOME= glib20 gtk20
.elif ${BUILD_MOZC_LIST:Mmozc_el} == "mozc_el"
USE_EMACS= yes
+.elif ${BUILD_MOZC_LIST:Mfcitx_mozc}
+USES+= gettext-tools
.endif
# Use GCC only when the stock clang does not have libc++.so.