aboutsummaryrefslogtreecommitdiffstats
path: root/japanese
diff options
context:
space:
mode:
authordas <das@FreeBSD.org>2005-02-12 21:19:47 +0800
committerdas <das@FreeBSD.org>2005-02-12 21:19:47 +0800
commitd0a8169f66cd61514add7ee911c6b6db0e51c1b9 (patch)
tree2f20a76d035a3b6d76643819e4d11cd7456ce538 /japanese
parentffbef27bb1180c2cd5cf7122154e05f714d21605 (diff)
downloadfreebsd-ports-gnome-d0a8169f66cd61514add7ee911c6b6db0e51c1b9.tar.gz
freebsd-ports-gnome-d0a8169f66cd61514add7ee911c6b6db0e51c1b9.tar.zst
freebsd-ports-gnome-d0a8169f66cd61514add7ee911c6b6db0e51c1b9.zip
Fix build. Ports that formerly attempted to work around problems
created by matherr() no longer need to do so.
Diffstat (limited to 'japanese')
-rw-r--r--japanese/tcl76/Makefile3
-rw-r--r--japanese/tcl76/files/Makefile.lib5
2 files changed, 6 insertions, 2 deletions
diff --git a/japanese/tcl76/Makefile b/japanese/tcl76/Makefile
index 12e28b7b779c..2c030cbfe7b2 100644
--- a/japanese/tcl76/Makefile
+++ b/japanese/tcl76/Makefile
@@ -49,7 +49,8 @@ post-configure:
@${CP} ${FILESDIR}/Makefile.lib ${WRKSRC}
pre-build:
- cd ${WRKSRC} && ${MAKE} -f Makefile.lib PREFIX=${PREFIX} VERSION=${VERSION} && ${RM} *.o
+ cd ${WRKSRC} && ${MAKE} -f Makefile.lib PREFIX=${PREFIX} \
+ VERSION=${VERSION} OSVERSION=${OSVERSION} && ${RM} *.o
pre-install:
${MKDIR} ${PREFIX}/lib/tcl${VERSION}
diff --git a/japanese/tcl76/files/Makefile.lib b/japanese/tcl76/files/Makefile.lib
index 90c451c4ea69..52921a346a55 100644
--- a/japanese/tcl76/files/Makefile.lib
+++ b/japanese/tcl76/files/Makefile.lib
@@ -4,10 +4,13 @@ TCL_LIBRARY= ${PREFIX}/lib/tcl${VERSION}
CFLAGS+= -I. -I./../generic \
-DHAVE_UNISTD_H=1 -DHAVE_SYS_TIME_H=1 \
-DTIME_WITH_SYS_TIME=1 -DHAVE_TM_ZONE=1 \
- -DHAVE_TM_GMTOFF=1 -DSTDC_HEADERS=1 -DNEED_MATHERR=1 \
+ -DHAVE_TM_GMTOFF=1 -DSTDC_HEADERS=1 \
-DHAVE_SYS_IOCTL_H=1 -DHAVE_SYS_FILIO_H=1 -DKANJI \
-DTCL_LIBRARY=\"${TCL_LIBRARY}\" \
-DTCL_PACKAGE_PATH="\"/usr/local/lib\""
+.if ${OSVERSION} < 600011
+CFLAGS+= -DNEED_MATHERR=1
+.endif
GENERIC_DIR= ../generic
UNIX_DIR= .