aboutsummaryrefslogtreecommitdiffstats
path: root/japanese
diff options
context:
space:
mode:
authormax <max@FreeBSD.org>1996-11-07 22:52:26 +0800
committermax <max@FreeBSD.org>1996-11-07 22:52:26 +0800
commite5eabcf7844aa83a63972b1d6a5eaad61ca78b7d (patch)
tree1479d3083ad4bb5c0c506df2c81d698613021e70 /japanese
parent15a6b84abb5edb680265e88c61715bb4fa4cd282 (diff)
downloadfreebsd-ports-gnome-e5eabcf7844aa83a63972b1d6a5eaad61ca78b7d.tar.gz
freebsd-ports-gnome-e5eabcf7844aa83a63972b1d6a5eaad61ca78b7d.tar.zst
freebsd-ports-gnome-e5eabcf7844aa83a63972b1d6a5eaad61ca78b7d.zip
On system without ptex2 and platex, after doing ``make install'' in
platex, ``make package'' in ptex2 failed. It happend as: ``Make install'' led to ``make install'' in ptex2 and it installed old LaTeX files which ptex2 doesn't seem to use. However, they seem to be necessary for platex to generate newer pLaTeX files. Before installing new files, pLaTex removes old files, and that causes some files for ptex2 package to be missing. To solve this problem, ptex2 now doesn't install old LaTeX files and instead, platex port installs them. The Bug Found by: asami Simplified character code dependent contitionals.
Diffstat (limited to 'japanese')
-rw-r--r--japanese/platex-common/Makefile41
1 files changed, 20 insertions, 21 deletions
diff --git a/japanese/platex-common/Makefile b/japanese/platex-common/Makefile
index 048d02fb0da2..9e3075070c3d 100644
--- a/japanese/platex-common/Makefile
+++ b/japanese/platex-common/Makefile
@@ -3,16 +3,17 @@
# Date created: 5 Nov 1995
# Whom: Hideaki Ohmon <ohmon@sfc.keio.ac.jp>
#
-# $Id: Makefile,v 1.9 1996/10/27 00:20:25 max Exp $
+# $Id: Makefile,v 1.10 1996/11/02 05:28:19 max Exp $
#
DISTNAME= platex2e
PKGNAME= jp-platex2e-96.03
CATEGORIES+= japanese print
MASTER_SITES= ftp://ftp.ascii.co.jp/pub/TeX/ascii-ptex/platex2e/1996-03-05/ \
- ftp://ftp.iij.ad.jp/pub/TeX/CTAN/systems/knuth/lib/ \
- ftp://ftp.riken.go.jp/pub/tex-archive/systems/knuth/lib/
-DISTFILES= base-9512.tar.gz hyphen.tex.gz
+ ftp://ftp.iij.ad.jp/pub/TeX/CTAN/systems/knuth/lib/ \
+ ftp://ftp.ascii.co.jp/pub/TeX/ascii-ptex/corresponding-sources/ \
+ ftp://ftp.riken.go.jp/pub/tex-archive/systems/knuth/lib/
+DISTFILES= base-9512.tar.gz hyphen.tex.gz lib-6.9.tar.gz
EXTRACT_ONLY= base-9512.tar.gz
MAINTAINER= max@FreeBSD.ORG
@@ -44,41 +45,39 @@ pre-fetch:
KANJI-CODE= JIS
.endif
.if ${KANJI-CODE} == JIS
-DISTFILES+= pl9603j.tar.gz
-EXTRACT_ONLY+= pl9603j.tar.gz
-.endif
-.if ${KANJI-CODE} == SJIS
-DISTFILES+= pl9603s.tar.gz
-EXTRACT_ONLY+= pl9603s.tar.gz
-.endif
-.if ${KANJI-CODE} == EUC
-DISTFILES+= pl9603e.tar.gz
-EXTRACT_ONLY+= pl9603e.tar.gz
-.endif
-.if ${KANJI-CODE} != JIS && ${KANJI-CODE} != SJIS && ${KANJI-CODE} != EUC
+PLIB_FILE= pl9603j.tar.gz
+.elif ${KANJI-CODE} == SJIS
+PLIB_FILE= pl9603s.tar.gz
+.elif ${KANJI-CODE} == EUC
+PLIB_FILE= pl9603e.tar.gz
+.elifdef KANJI-CODE
@echo "Error: invalid value for KANJI-CODE: \"${KANJI-CODE}\""
@echo "Possible values are: JIS (default), SJIS, EUC."
- exit 1
+ @false
.endif
+DISTFILES+= ${PLIB_FILE}
+EXTRACT_ONLY+= ${PLIB_FILE}
post-extract:
- @rm ${WRKDIR}/base/hyphen.tex
+ @${RM} ${WRKDIR}/base/hyphen.tex
@gzip -cd ${DISTDIR}/hyphen.tex.gz > ${WRKDIR}/base/hyphen.tex
do-build:
+ @(cd ${PREFIX}/lib ; \
+ tar zxf ${DISTDIR}/lib-6.9.tar.gz texmf/tex/latex2e/base)
@(cd ${WRKDIR}/base ; yes | initex unpack.ins ; initex latex.ltx)
@(cd ${WRKSRC} ; TEXINPUTS=".:${WRKDIR}/base" ; export TEXINPUTS ; \
yes | iniptex plcore.ins ; iniptex platex.ltx)
do-install:
- @rm -rf ${PREFIX}/lib/texmf/tex/latex2e/base/*
+ @${RM} -rf ${PREFIX}/lib/texmf/tex/latex2e/base/*
@${MKDIR} ${PREFIX}/lib/texmf/tex/latex2e/base
(cd ${WRKDIR}/base ; \
for f in *.cls *.clo *.sty *.fd *.def *.ltx ; do \
${INSTALL_DATA} $$f ${PREFIX}/lib/texmf/tex/latex2e/base ; \
done ; \
${INSTALL_DATA} latex.fmt ${PREFIX}/lib/texmf/ini)
- @rm -f ${PREFIX}/bin/latex
+ @${RM} -f ${PREFIX}/bin/latex
@ln -s ${PREFIX}/bin/virtex ${PREFIX}/bin/latex
@${MKDIR} ${PREFIX}/lib/texmf/tex/platex2e/base
(cd ${WRKSRC} ; \
@@ -86,7 +85,7 @@ do-install:
${INSTALL_DATA} $$f ${PREFIX}/lib/texmf/tex/platex2e/base ; \
done ; \
${INSTALL_DATA} platex.fmt ${PREFIX}/lib/texmf/ini)
- @rm -f ${PREFIX}/bin/platex
+ @${RM} -f ${PREFIX}/bin/platex
@ln -s ${PREFIX}/bin/virptex ${PREFIX}/bin/platex
.include <bsd.port.mk>