aboutsummaryrefslogtreecommitdiffstats
path: root/japanese
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-07-09 16:40:17 +0800
committerMathieu Arnold <mat@FreeBSD.org>2018-07-09 16:40:17 +0800
commitf6d56007b984e83ebda7162c99abc18d5bde982e (patch)
treeaa20f69168c1d6c9e0dbf200cc417eb6ea9147ca /japanese
parentbd0d393e807d8d13fca4ce0ff12e4497385e3e24 (diff)
downloadfreebsd-ports-gnome-f6d56007b984e83ebda7162c99abc18d5bde982e.tar.gz
freebsd-ports-gnome-f6d56007b984e83ebda7162c99abc18d5bde982e.tar.zst
freebsd-ports-gnome-f6d56007b984e83ebda7162c99abc18d5bde982e.zip
Remove all := from BUILD_DEPENDS, here are never needed.
While there, cleanup, and sort depends. When build and run dependencies are the same, there are three ways to avoid duplicating the list while not adding the framework added BUILD_DEPENDS to the RUN_DEPENDS. In order of preference, they are: 1) use RUN_DEPENDS to set BUILD_DEPENDS: BUILD_DEPENDS= ${RUN_DEPENDS} RUN_DEPENDS= foo:bar/baz 2) create another variable and use it: MY_DEPENDS= foo:bar/baz BUILD_DEPENDS= ${MY_DEPENDS} RUN_DEPENDS= ${MY_DEPENDS} 3) use BUILD_DEPENDS to set RUN_DEPENDS and force evaluation: BUILD_DEPENDS= foo:bar/baz RUN_DEPENDS:= ${BUILD_DEPENDS} Sponsored by: Absolight
Diffstat (limited to 'japanese')
-rw-r--r--japanese/p5-Date-Japanese-Holiday/Makefile2
-rw-r--r--japanese/p5-Encode-JP-Mobile/Makefile2
-rw-r--r--japanese/p5-HTML-MobileJp/Makefile2
-rw-r--r--japanese/p5-WWW-MobileCarrierJP/Makefile2
4 files changed, 4 insertions, 4 deletions
diff --git a/japanese/p5-Date-Japanese-Holiday/Makefile b/japanese/p5-Date-Japanese-Holiday/Makefile
index 0189ecdb064a..be7d6ff74ae8 100644
--- a/japanese/p5-Date-Japanese-Holiday/Makefile
+++ b/japanese/p5-Date-Japanese-Holiday/Makefile
@@ -9,10 +9,10 @@ MASTER_SITES= CPAN
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Perl module for Calculate Japanese Holiday
+BUILD_DEPENDS= ${RUN_DEPENDS}
RUN_DEPENDS= p5-Date-Calc>5.3:devel/p5-Date-Calc \
p5-Date-Simple>1.03:devel/p5-Date-Simple \
p5-Time-modules>0.01:devel/p5-Time-modules
-BUILD_DEPENDS:= ${RUN_DEPENDS}
USES= perl5
USE_PERL5= configure
diff --git a/japanese/p5-Encode-JP-Mobile/Makefile b/japanese/p5-Encode-JP-Mobile/Makefile
index dac03a1d8be2..0f0954796974 100644
--- a/japanese/p5-Encode-JP-Mobile/Makefile
+++ b/japanese/p5-Encode-JP-Mobile/Makefile
@@ -9,10 +9,10 @@ MASTER_SITES= CPAN
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Perl extension for encoding for mobile phones in Japan
+BUILD_DEPENDS= ${RUN_DEPENDS}
RUN_DEPENDS= \
p5-File-ShareDir>=0.05:devel/p5-File-ShareDir \
p5-MIME-Tools>=5.428:mail/p5-MIME-Tools
-BUILD_DEPENDS:= ${RUN_DEPENDS}
TEST_DEPENDS= \
p5-YAML>0:textproc/p5-YAML
diff --git a/japanese/p5-HTML-MobileJp/Makefile b/japanese/p5-HTML-MobileJp/Makefile
index 3dd9df9b4a62..28f6feaa5a13 100644
--- a/japanese/p5-HTML-MobileJp/Makefile
+++ b/japanese/p5-HTML-MobileJp/Makefile
@@ -13,10 +13,10 @@ COMMENT= Generate mobile-jp html tags
LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
+BUILD_DEPENDS= ${RUN_DEPENDS}
RUN_DEPENDS= p5-HTML-Parser>=0:www/p5-HTML-Parser \
p5-Params-Validate>=0:devel/p5-Params-Validate \
p5-URI>=0:net/p5-URI
-BUILD_DEPENDS:= ${RUN_DEPENDS}
TEST_DEPENDS= p5-Test-Base>0:devel/p5-Test-Base \
p5-YAML>=0:textproc/p5-YAML
diff --git a/japanese/p5-WWW-MobileCarrierJP/Makefile b/japanese/p5-WWW-MobileCarrierJP/Makefile
index ce91da12760a..d32adeb72729 100644
--- a/japanese/p5-WWW-MobileCarrierJP/Makefile
+++ b/japanese/p5-WWW-MobileCarrierJP/Makefile
@@ -13,6 +13,7 @@ COMMENT= Scrape Japanese mobile carrier information
LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
+BUILD_DEPENDS= ${RUN_DEPENDS}
RUN_DEPENDS= p5-Moose>=0.60:devel/p5-Moose \
p5-Filter>=0:devel/p5-Filter \
p5-HTML-Selector-XPath>=0.03:www/p5-HTML-Selector-XPath \
@@ -21,7 +22,6 @@ RUN_DEPENDS= p5-Moose>=0.60:devel/p5-Moose \
p5-libwww>=5.834:www/p5-libwww \
p5-URI>=0:net/p5-URI \
p5-CAM-PDF>=0:textproc/p5-CAM-PDF
-BUILD_DEPENDS:= ${RUN_DEPENDS}
TEST_DEPENDS= p5-LWP-Online>=1.07:www/p5-LWP-Online \
p5-Test-Base>0:devel/p5-Test-Base