aboutsummaryrefslogtreecommitdiffstats
path: root/java/Makefile
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2004-04-18 14:18:19 +0800
committerglewis <glewis@FreeBSD.org>2004-04-18 14:18:19 +0800
commitc6be855aa13a04f210b455dff2c16eadb3560193 (patch)
treec5b56e7134bac571a5305f7ea05a14b842f36668 /java/Makefile
parentbf7c5a26438d5de7a395decfe955b125826ddb78 (diff)
downloadfreebsd-ports-gnome-c6be855aa13a04f210b455dff2c16eadb3560193.tar.gz
freebsd-ports-gnome-c6be855aa13a04f210b455dff2c16eadb3560193.tar.zst
freebsd-ports-gnome-c6be855aa13a04f210b455dff2c16eadb3560193.zip
Add a port of jakarta-commons-discovery.
The Discovery Component is about discovering, or finding, implementations for pluggable interfaces. It provides facilities intantiating classes in general, and for lifecycle management of singleton (factory) classes. Fundamentally, Discovery locates classes that implement a given Java interface. The discovery pattern, though not necessarily this package, is used in many projects including JAXP (SaxParserFactory and others) and commons-logging (LogFactory). By extracting this pattern, other projects can (re)use it and take advantage of improvements to the pattern as Discovery evolves. Discovery improves over previous implementations by establishing facilities for working within managed environments. These allow configuration and property overrides without appealing to the global System properties (which are scoped across an entire JVM). PR: 65490 Submitted by: Herve Quiroz <herve.quiroz@esil.univ-mrs.fr>
Diffstat (limited to 'java/Makefile')
-rw-r--r--java/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/java/Makefile b/java/Makefile
index e956ad1d9097..228570b41523 100644
--- a/java/Makefile
+++ b/java/Makefile
@@ -39,6 +39,7 @@
SUBDIR += jakarta-commons-cli
SUBDIR += jakarta-commons-collections
SUBDIR += jakarta-commons-dbcp
+ SUBDIR += jakarta-commons-discovery
SUBDIR += jakarta-commons-lang
SUBDIR += jakarta-commons-logging
SUBDIR += jakarta-commons-pool