aboutsummaryrefslogtreecommitdiffstats
path: root/java/bootstrap-openjdk/Makefile
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2013-10-22 05:27:59 +0800
committerJung-uk Kim <jkim@FreeBSD.org>2013-10-22 05:27:59 +0800
commit30b9bd7b949781c7a8a2c12f5c1a65c0ef557e7a (patch)
tree717fb27624ae8ca3889e6f8787c9b9e0e7e43ae3 /java/bootstrap-openjdk/Makefile
parent238e1b9f9788623aa7e9f99f5eb867e914c44e91 (diff)
downloadfreebsd-ports-gnome-30b9bd7b949781c7a8a2c12f5c1a65c0ef557e7a.tar.gz
freebsd-ports-gnome-30b9bd7b949781c7a8a2c12f5c1a65c0ef557e7a.tar.zst
freebsd-ports-gnome-30b9bd7b949781c7a8a2c12f5c1a65c0ef557e7a.zip
- Update to r330538.
- Turn off mixed mode for HotSpot (i. e., JIT compiler) by default for extreme safety. Although it may be too conservative and/or slow, it is okay because it is not useful for anything but bootstrapping OpenJDK itself. In fact, it does not seem stable within jails (e. g., QAT) for unknown reasons. - Revert r330422. Now it is obsolete by r330500.
Diffstat (limited to 'java/bootstrap-openjdk/Makefile')
-rw-r--r--java/bootstrap-openjdk/Makefile7
1 files changed, 2 insertions, 5 deletions
diff --git a/java/bootstrap-openjdk/Makefile b/java/bootstrap-openjdk/Makefile
index 91896a6c66f9..e1fd1ac0dcfc 100644
--- a/java/bootstrap-openjdk/Makefile
+++ b/java/bootstrap-openjdk/Makefile
@@ -18,8 +18,8 @@ RUN_DEPENDS= ${LOCALBASE}/share/java/zi:${PORTSDIR}/java/java-zoneinfo
ONLY_FOR_ARCH= amd64 i386
DISTINFO_FILE= ${.CURDIR}/distinfo.${ARCH}
-DISTVERSION_amd64= r330107
-DISTVERSION_i386= r330107
+DISTVERSION_amd64= r330538
+DISTVERSION_i386= r330538
JDK_NAME= openjdk
JDK_PORT= openjdk6
@@ -37,9 +37,6 @@ INSTALLDIR= ${STAGEDIR}${PREFIX}/${JDK_ROOT}
.if ${OSVERSION} >= 900010
RUN_DEPENDS+= ${LOCALBASE}/lib/compat/libz.so.5:${PORTSDIR}/misc/compat8x
.endif
-.if ${OSVERSION} >= 1000054
-RUN_DEPENDS+= ${LOCALBASE}/lib/compat/libstdc++.so.6:${PORTSDIR}/misc/compat9x
-.endif
.if ${ARCH} == "i386"
PLIST_SUB+= CLIENTVM=""