aboutsummaryrefslogtreecommitdiffstats
path: root/java/bouncycastle/Makefile
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2006-07-19 14:45:20 +0800
committerale <ale@FreeBSD.org>2006-07-19 14:45:20 +0800
commit238b16ffc58487fa165162dbeb9e16f88ed841d7 (patch)
tree4cde7c4ed79667d844891d31873a59c82f0aedd4 /java/bouncycastle/Makefile
parentc13a4016dceb370c3c4530b6129954aefb515f04 (diff)
downloadfreebsd-ports-gnome-238b16ffc58487fa165162dbeb9e16f88ed841d7.tar.gz
freebsd-ports-gnome-238b16ffc58487fa165162dbeb9e16f88ed841d7.tar.zst
freebsd-ports-gnome-238b16ffc58487fa165162dbeb9e16f88ed841d7.zip
Update to 1.33 release:
- install only jars for the selected jdk to avoid class conflicts - drop support for obsolate jdks - take maintainership [1] Approved by: glewis [1]
Diffstat (limited to 'java/bouncycastle/Makefile')
-rw-r--r--java/bouncycastle/Makefile22
1 files changed, 13 insertions, 9 deletions
diff --git a/java/bouncycastle/Makefile b/java/bouncycastle/Makefile
index 8d1dd04aba86..4e566f5681c3 100644
--- a/java/bouncycastle/Makefile
+++ b/java/bouncycastle/Makefile
@@ -6,27 +6,31 @@
#
PORTNAME= bouncycastle
-PORTVERSION= 1.30
+PORTVERSION= 1.33
CATEGORIES= java security
MASTER_SITES= http://www.bouncycastle.org/download/ \
http://polydistortion.net/bc/download/ \
http://bouncycastle.gva.es/download/
DISTNAME= crypto-${DISTVERSION}
-MAINTAINER= glewis@FreeBSD.org
+MAINTAINER= ale@FreeBSD.org
COMMENT= Cleanroom build of Java Cryptography Extensions
-USE_JAVA= yes
-JAVA_VERSION= 1.2+
NO_BUILD= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
+JDKMVERSION= ${JAVA_PORT_VERSION:C/^([0-9])\.([0-9])(.*)$/\1\2/}
DISTVERSION= ${PORTVERSION:S/.//}
+JARS= bcprov bcmail bctsp bcpg bctest
+
+PORTDOCS= *
+
do-install:
- cd ${WRKSRC}/jars && \
- for jar in *.jar; do \
- ${INSTALL_DATA} $${jar} \
- ${JAVAJARDIR}/`echo $${jar} | sed -e "s/-${DISTVERSION}//"`; \
- done
+.for jar in ${JARS}
+ ${INSTALL_DATA} ${WRKSRC}/jars/${jar}-jdk${JDKMVERSION}-${DISTVERSION}.jar \
+ ${JAVAJARDIR}/${jar}.jar
+.endfor
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/*.html ${DOCSDIR}