aboutsummaryrefslogtreecommitdiffstats
path: root/java/eclipse-gef
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2003-07-08 18:21:02 +0800
committerolgeni <olgeni@FreeBSD.org>2003-07-08 18:21:02 +0800
commit2fd696b34361e01615f9d6b893d2656b7a1379d7 (patch)
treea2322e6a9c2c2224c04dbc0d96bd101cf10df67b /java/eclipse-gef
parent34a17664d0182e002cc23812bd087f8638e10bcf (diff)
downloadfreebsd-ports-gnome-2fd696b34361e01615f9d6b893d2656b7a1379d7.tar.gz
freebsd-ports-gnome-2fd696b34361e01615f9d6b893d2656b7a1379d7.tar.zst
freebsd-ports-gnome-2fd696b34361e01615f9d6b893d2656b7a1379d7.zip
Add the Graphical Editing Framework for Eclipse.
Diffstat (limited to 'java/eclipse-gef')
-rw-r--r--java/eclipse-gef/Makefile27
-rw-r--r--java/eclipse-gef/distinfo1
-rw-r--r--java/eclipse-gef/pkg-descr4
-rw-r--r--java/eclipse-gef/pkg-plist68
4 files changed, 100 insertions, 0 deletions
diff --git a/java/eclipse-gef/Makefile b/java/eclipse-gef/Makefile
new file mode 100644
index 000000000000..16db945cbc4f
--- /dev/null
+++ b/java/eclipse-gef/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: eclipse-gef
+# Date created: July 8, 2003
+# Whom: olgeni@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= eclipse-gef
+PORTVERSION= 2.1.1
+CATEGORIES= java devel
+MASTER_SITES= http://download.eclipse.org/tools/gef/downloads/drops/R-2.1.1-200306180934/
+DISTNAME= GEF-SDK-I20030618
+DIST_SUBDIR= eclipse
+
+MAINTAINER= java@FreeBSD.ORG
+COMMENT= Graphical Editing Framework for the Eclipse IDE
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+USE_ZIP= yes
+
+do-install:
+ @${MKDIR} ${PREFIX}/eclipse
+ @${CP} -r ${WRKSRC}/plugins ${PREFIX}/eclipse
+ @${CP} -r ${WRKSRC}/features ${PREFIX}/eclipse
+
+.include <bsd.port.mk>
diff --git a/java/eclipse-gef/distinfo b/java/eclipse-gef/distinfo
new file mode 100644
index 000000000000..332721558bef
--- /dev/null
+++ b/java/eclipse-gef/distinfo
@@ -0,0 +1 @@
+MD5 (eclipse/GEF-SDK-I20030618.zip) = 640be83f698e591193cc8d4da0174691
diff --git a/java/eclipse-gef/pkg-descr b/java/eclipse-gef/pkg-descr
new file mode 100644
index 000000000000..965c2fbcf015
--- /dev/null
+++ b/java/eclipse-gef/pkg-descr
@@ -0,0 +1,4 @@
+The Graphical Editing Framework (GEF) allows developers to take an
+existing application model and easily create a rich graphical editor.
+
+WWW: http://www.eclipse.org/gef/
diff --git a/java/eclipse-gef/pkg-plist b/java/eclipse-gef/pkg-plist
new file mode 100644
index 000000000000..685163aadc45
--- /dev/null
+++ b/java/eclipse-gef/pkg-plist
@@ -0,0 +1,68 @@
+eclipse/features/org.eclipse.gef.source_2.1.1/cpl-v10.html
+eclipse/features/org.eclipse.gef.source_2.1.1/eclipse_update_120.jpg
+eclipse/features/org.eclipse.gef.source_2.1.1/feature.properties
+eclipse/features/org.eclipse.gef.source_2.1.1/feature.xml
+eclipse/features/org.eclipse.gef.source_2.1.1/license.html
+eclipse/features/org.eclipse.gef_2.1.1/cpl-v10.html
+eclipse/features/org.eclipse.gef_2.1.1/eclipse_update_120.jpg
+eclipse/features/org.eclipse.gef_2.1.1/feature.properties
+eclipse/features/org.eclipse.gef_2.1.1/feature.xml
+eclipse/features/org.eclipse.gef_2.1.1/license.html
+eclipse/plugins/org.eclipse.draw2d.doc.isv_2.1.1/about.html
+eclipse/plugins/org.eclipse.draw2d.doc.isv_2.1.1/doc.properties
+eclipse/plugins/org.eclipse.draw2d.doc.isv_2.1.1/doc.zip
+eclipse/plugins/org.eclipse.draw2d.doc.isv_2.1.1/plugin.properties
+eclipse/plugins/org.eclipse.draw2d.doc.isv_2.1.1/plugin.xml
+eclipse/plugins/org.eclipse.draw2d.doc.isv_2.1.1/toc.xml
+eclipse/plugins/org.eclipse.draw2d.doc.isv_2.1.1/topics_Guide.xml
+eclipse/plugins/org.eclipse.draw2d.doc.isv_2.1.1/topics_Reference.xml
+eclipse/plugins/org.eclipse.draw2d_2.1.1/about.html
+eclipse/plugins/org.eclipse.draw2d_2.1.1/draw2d.jar
+eclipse/plugins/org.eclipse.draw2d_2.1.1/icons/debugGEF.gif
+eclipse/plugins/org.eclipse.draw2d_2.1.1/plugin.properties
+eclipse/plugins/org.eclipse.draw2d_2.1.1/plugin.xml
+eclipse/plugins/org.eclipse.gef.doc.isv_2.1.1/about.html
+eclipse/plugins/org.eclipse.gef.doc.isv_2.1.1/doc.properties
+eclipse/plugins/org.eclipse.gef.doc.isv_2.1.1/doc.zip
+eclipse/plugins/org.eclipse.gef.doc.isv_2.1.1/icons/debugGEF.gif
+eclipse/plugins/org.eclipse.gef.doc.isv_2.1.1/plugin.properties
+eclipse/plugins/org.eclipse.gef.doc.isv_2.1.1/plugin.xml
+eclipse/plugins/org.eclipse.gef.doc.isv_2.1.1/toc.xml
+eclipse/plugins/org.eclipse.gef.doc.isv_2.1.1/topics_Guide.xml
+eclipse/plugins/org.eclipse.gef.doc.isv_2.1.1/topics_Reference.xml
+eclipse/plugins/org.eclipse.gef.source_2.1.1/about.html
+eclipse/plugins/org.eclipse.gef.source_2.1.1/about.ini
+eclipse/plugins/org.eclipse.gef.source_2.1.1/about.mappings
+eclipse/plugins/org.eclipse.gef.source_2.1.1/about.properties
+eclipse/plugins/org.eclipse.gef.source_2.1.1/eclipse32.gif
+eclipse/plugins/org.eclipse.gef.source_2.1.1/plugin.properties
+eclipse/plugins/org.eclipse.gef.source_2.1.1/plugin.xml
+eclipse/plugins/org.eclipse.gef.source_2.1.1/src/org.eclipse.draw2d_2.1.1/draw2dsrc.zip
+eclipse/plugins/org.eclipse.gef.source_2.1.1/src/org.eclipse.gef_2.1.1/gefsrc.zip
+eclipse/plugins/org.eclipse.gef_2.1.1/about.html
+eclipse/plugins/org.eclipse.gef_2.1.1/about.ini
+eclipse/plugins/org.eclipse.gef_2.1.1/about.mappings
+eclipse/plugins/org.eclipse.gef_2.1.1/about.properties
+eclipse/plugins/org.eclipse.gef_2.1.1/eclipse32.gif
+eclipse/plugins/org.eclipse.gef_2.1.1/gef.jar
+eclipse/plugins/org.eclipse.gef_2.1.1/icons/debugGEF.gif
+eclipse/plugins/org.eclipse.gef_2.1.1/plugin.properties
+eclipse/plugins/org.eclipse.gef_2.1.1/plugin.xml
+eclipse/plugins/org.eclipse.gef_2.1.1/readme/readme_gef_211.html
+@dirrm eclipse/plugins/org.eclipse.gef_2.1.1/readme
+@dirrm eclipse/plugins/org.eclipse.gef_2.1.1/icons
+@dirrm eclipse/plugins/org.eclipse.gef_2.1.1
+@dirrm eclipse/plugins/org.eclipse.gef.source_2.1.1/src/org.eclipse.gef_2.1.1
+@dirrm eclipse/plugins/org.eclipse.gef.source_2.1.1/src/org.eclipse.draw2d_2.1.1
+@dirrm eclipse/plugins/org.eclipse.gef.source_2.1.1/src
+@dirrm eclipse/plugins/org.eclipse.gef.source_2.1.1
+@dirrm eclipse/plugins/org.eclipse.gef.doc.isv_2.1.1/icons
+@dirrm eclipse/plugins/org.eclipse.gef.doc.isv_2.1.1
+@dirrm eclipse/plugins/org.eclipse.draw2d_2.1.1/icons
+@dirrm eclipse/plugins/org.eclipse.draw2d_2.1.1
+@dirrm eclipse/plugins/org.eclipse.draw2d.doc.isv_2.1.1
+@dirrm eclipse/features/org.eclipse.gef_2.1.1
+@dirrm eclipse/features/org.eclipse.gef.source_2.1.1
+@unexec rmdir %D/eclipse/plugins 2>/dev/null || true
+@unexec rmdir %D/eclipse/features 2>/dev/null || true
+@unexec rmdir %D/eclipse 2>/dev/null || true