aboutsummaryrefslogtreecommitdiffstats
path: root/java/eclipse-propedit
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2014-06-17 18:18:20 +0800
committervanilla <vanilla@FreeBSD.org>2014-06-17 18:18:20 +0800
commit20b9da7bf87c3a8dc60cdbd02621d4608ce717cc (patch)
treeaa0ecc526d19097bc9dfa7dd6eb14fbf8224793e /java/eclipse-propedit
parent7f6fb59c5021040bca4a032f4864c5db8c04598c (diff)
downloadfreebsd-ports-gnome-20b9da7bf87c3a8dc60cdbd02621d4608ce717cc.tar.gz
freebsd-ports-gnome-20b9da7bf87c3a8dc60cdbd02621d4608ce717cc.tar.zst
freebsd-ports-gnome-20b9da7bf87c3a8dc60cdbd02621d4608ce717cc.zip
Stagify.
Approved by: portmgr@
Diffstat (limited to 'java/eclipse-propedit')
-rw-r--r--java/eclipse-propedit/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/java/eclipse-propedit/Makefile b/java/eclipse-propedit/Makefile
index 9d6997b6877a..f7203d13cc19 100644
--- a/java/eclipse-propedit/Makefile
+++ b/java/eclipse-propedit/Makefile
@@ -23,14 +23,13 @@ USE_JAVA= yes
JAVA_VERSION= 1.6+
JAVA_OS= native
-NO_STAGE= yes
do-install:
- @${MKDIR} ${PREFIX}/lib/eclipse
- @${CP} -r ${WRKSRC}/eclipse/plugins ${PREFIX}/lib/eclipse
- @${CP} -r ${WRKSRC}/eclipse/features ${PREFIX}/lib/eclipse
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/eclipse
+ @${CP} -r ${WRKSRC}/eclipse/plugins ${STAGEDIR}${PREFIX}/lib/eclipse
+ @${CP} -r ${WRKSRC}/eclipse/features ${STAGEDIR}${PREFIX}/lib/eclipse
@(cd ${WRKSRC}; ${FIND} -s eclipse/features eclipse/plugins -not -type d) | ${SED} -e 's,^eclipse,lib/eclipse,' >> ${TMPPLIST}
@(cd ${WRKSRC}; ${FIND} -s -d eclipse/features eclipse/plugins -type d) \
- | ${GREP} -vE 'eclipse/plugins$$|eclipse/features$$' \
- | ${SED} -ne 's,^,@dirrm lib/,p' >> ${TMPPLIST}
+ | ${GREP} -vE 'eclipse/plugins$$|eclipse/features$$' \
+ | ${SED} -ne 's,^,@dirrm lib/,p' >> ${TMPPLIST}
.include <bsd.port.mk>